aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2022-07-26 08:07:53 +0000
committerFukang Chen <loader@FreeBSD.org>2022-07-26 10:51:15 +0000
commit8b3b5be996ab726510d4506a9c4d26051407b309 (patch)
tree06334fbc131f66cc7f475b5d50490de51737fc96
parent3f737e76ddbf6706887278f53fc211ca2e8bc45a (diff)
databases/py-sqlite-utils: Python CLI utility and library for manipulating SQLite databases
Python CLI utility and library for manipulating SQLite databases. Some feature highlights * Pipe JSON (or CSV or TSV) directly into a new SQLite database file, automatically creating a table with the appropriate schema * Run in-memory SQL queries, including joins, directly against data in CSV, TSV or JSON files and view the results * Configure SQLite full-text search against your database tables and run search queries against them, ordered by relevance * Run transformations against your tables to make schema changes that SQLite ALTER TABLE does not directly support, such as changing the type of a column * Extract columns into separate tables to better normalize your existing data WWW: https://github.com/simonw/sqlite-utils
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-sqlite-utils/Makefile25
-rw-r--r--databases/py-sqlite-utils/distinfo3
-rw-r--r--databases/py-sqlite-utils/pkg-descr17
4 files changed, 46 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 0400fab0b390..d3cfbd679fd4 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -833,6 +833,7 @@
SUBDIR += py-sqlalchemy13
SUBDIR += py-sqlalchemy14
SUBDIR += py-sqlite-fts4
+ SUBDIR += py-sqlite-utils
SUBDIR += py-sqlite3
SUBDIR += py-sqlobject
SUBDIR += py-sqlparse
diff --git a/databases/py-sqlite-utils/Makefile b/databases/py-sqlite-utils/Makefile
new file mode 100644
index 000000000000..7897e7c7e64d
--- /dev/null
+++ b/databases/py-sqlite-utils/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= sqlite-utils
+PORTVERSION= 3.28
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= loader@FreeBSD.org
+COMMENT= Python CLI utility and library for manipulating SQLite databases
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite-fts4>0:databases/py-sqlite-fts4@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click-default-group>0:devel/py-click-default-group@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tabulate>0:devel/py-tabulate@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hypothesis>0:devel/py-hypothesis@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/databases/py-sqlite-utils/distinfo b/databases/py-sqlite-utils/distinfo
new file mode 100644
index 000000000000..7a2d9319ddef
--- /dev/null
+++ b/databases/py-sqlite-utils/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1658735281
+SHA256 (sqlite-utils-3.28.tar.gz) = 790b01f4be16c32756b9b5eae07b6b7c905b6613ca538d646877c50b05b0a53a
+SIZE (sqlite-utils-3.28.tar.gz) = 188238
diff --git a/databases/py-sqlite-utils/pkg-descr b/databases/py-sqlite-utils/pkg-descr
new file mode 100644
index 000000000000..7850324bb5ba
--- /dev/null
+++ b/databases/py-sqlite-utils/pkg-descr
@@ -0,0 +1,17 @@
+Python CLI utility and library for manipulating SQLite databases.
+
+Some feature highlights
+
+* Pipe JSON (or CSV or TSV) directly into a new SQLite database
+ file, automatically creating a table with the appropriate schema
+* Run in-memory SQL queries, including joins, directly against data
+ in CSV, TSV or JSON files and view the results
+* Configure SQLite full-text search against your database tables
+ and run search queries against them, ordered by relevance
+* Run transformations against your tables to make schema changes
+ that SQLite ALTER TABLE does not directly support, such as
+ changing the type of a column
+* Extract columns into separate tables to better normalize your
+ existing data
+
+WWW: https://github.com/simonw/sqlite-utils