aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-16 15:31:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-16 15:31:55 +0000
commit8b63c1dad1f3227f90b76de7ed283fcee254f688 (patch)
treea9ee039f970bc74fb63556277574df21bf496664
parent0db7382c2da218a0239b71fa90376f6036efc6f2 (diff)
databases/octosql: New port: OctoSQL is a query tool for databases, file formats, etc
-rw-r--r--databases/Makefile1
-rw-r--r--databases/octosql/Makefile19
-rw-r--r--databases/octosql/distinfo5
-rw-r--r--databases/octosql/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 0e75205fc1fd..f7179c8b04ac 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -229,6 +229,7 @@
SUBDIR += ocaml-dbm
SUBDIR += ocaml-mysql
SUBDIR += ocaml-sqlite3
+ SUBDIR += octosql
SUBDIR += odbc-cpp-wrapper
SUBDIR += ods2sql
SUBDIR += opendbviewer
diff --git a/databases/octosql/Makefile b/databases/octosql/Makefile
new file mode 100644
index 000000000000..60731f3275eb
--- /dev/null
+++ b/databases/octosql/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= octosql
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.11.1
+CATEGORIES= databases
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= OctoSQL is a query tool for databases, file formats, etc
+WWW= https://github.com/cube2222/octosql
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/cube2222/octosql
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/databases/octosql/distinfo b/databases/octosql/distinfo
new file mode 100644
index 000000000000..80ba4aff30e1
--- /dev/null
+++ b/databases/octosql/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1665905418
+SHA256 (go/databases_octosql/octosql-v0.11.1/v0.11.1.mod) = 0b79d55eb7452c0f7cf892ba1b666c6629e2ce5e68dfbb100c5dddf196e185aa
+SIZE (go/databases_octosql/octosql-v0.11.1/v0.11.1.mod) = 3239
+SHA256 (go/databases_octosql/octosql-v0.11.1/v0.11.1.zip) = bf2ec13d564fa6144c5463eddbb36ed3d72a30fb754268e4fe65e92887ddde65
+SIZE (go/databases_octosql/octosql-v0.11.1/v0.11.1.zip) = 2340891
diff --git a/databases/octosql/pkg-descr b/databases/octosql/pkg-descr
new file mode 100644
index 000000000000..5f6dd19c133a
--- /dev/null
+++ b/databases/octosql/pkg-descr
@@ -0,0 +1,6 @@
+OctoSQL is predominantly a CLI tool which lets you query a plethora of
+databases and file formats using SQL through a unified interface, even do JOINs
+between them.
+
+At the same time it's an easily extensible full-blown dataflow engine, and you
+can use it to add a SQL interface to your own applications.