aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-15 05:53:20 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-16 02:30:59 +0000
commit8b7faa2b662f9eeb85d8c26cf5b3f4161320ff91 (patch)
tree43b4313b4591cdabe4ce2fa5a113f99ce68ec456
parent4dd811efa614bf07c1e15382d14f16eba768d614 (diff)
downloadports-8b7faa2b662f9eeb85d8c26cf5b3f4161320ff91.tar.gz
ports-8b7faa2b662f9eeb85d8c26cf5b3f4161320ff91.zip
net/asterisk16: Fix build with OpenSSL 3
Although astersisk itself builds fine with OpenSSL 3 however one of it's internal project pjproject fails to detect OpenSSL 3 and picks up gnutls as a dependency but fails to detect the library. Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--net/asterisk16/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 69584ffe0bbb..89dadfb692db 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -195,7 +195,9 @@ CXX= clang++${LLVM_VERSION}
.endif
.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
-CXXFLAGS+= -DOPENSSL_API_COMPAT=0x30000000L
+LIB_DEPENDS+= libgnutls.so:security/gnutls
+CXXFLAGS+= -DOPENSSL_API_COMPAT=0x10100000L
+LDFLAGS+= -lgnutls
.endif
.include <bsd.port.pre.mk>