aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-09-29 10:29:25 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-10-15 15:44:42 +0000
commit8bc0f1e6d3d18811c33a876273d591c04b2a8b44 (patch)
treebe1039e3b5c25f415a2453c5f231dc797f878b88
parentfb389b02e81f0500376d29bbd80fa61ba4bb6e40 (diff)
downloadports-8bc0f1e6d3d18811c33a876273d591c04b2a8b44.tar.gz
ports-8bc0f1e6d3d18811c33a876273d591c04b2a8b44.zip
net/samba413: fix build with lld 17
Building net/samba413 with lld 17 results in the following link errors: runner ['cc', '-Wl,--as-needed', '-Wl,--version-script=/wrkdirs/share/dim/ports/net/samba413/work/samba-4.13.17/bin/default/lib/replace/replace.vscript', '-shared', 'lib/replace/replace.c.2.o', 'lib/replace/strptime.c.2.o', 'lib/replace/cwrap.c.2.o', 'lib/replace/xattr.c.2.o', '-o/wrkdirs/share/dim/ports/net/samba413/work/samba-4.13.17/bin/default/lib/replace/libreplace-samba4.so', '-Wl,-Bstatic', '-Wl,-Bdynamic', '-L/usr/local/lib', '-L/usr/local/lib', '-fstack-protector-strong', '-L/usr/local/lib', '-Wl,-z,relro,-z,now', '-Wl,-no-undefined', '-Wl,--export-dynamic'] ld: error: version script assignment of 'local' to symbol '_end' failed: symbol not defined ld: error: version script assignment of 'local' to symbol '__bss_start' failed: symbol not defined ld: error: version script assignment of 'local' to symbol '_edata' failed: symbol not defined cc: error: linker command failed with exit code 1 (use -v to see invocation) Since the linker version scripts are generated dynamically, suppress errors with lld >= 17 due to these undefined symbols. PR: 274313 Approved by: maintainer timeout (2 weeks) MFH: 2023Q4
-rw-r--r--net/samba413/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net/samba413/Makefile b/net/samba413/Makefile
index 7207ba3a7a46..4847973cf78d 100644
--- a/net/samba413/Makefile
+++ b/net/samba413/Makefile
@@ -567,6 +567,10 @@ MAKE_ENV+= RPCGEN_CPP="${CPP}"
#.if ${readline_ARGS} == port
#CFLAGS+= -D_FUNCTION_DEF
#.endif
+# Some symbols in samba's linker version scripts are not defined, but since the
+# scripts are generated dynamically, suppress errors with lld >= 17 due to these
+# undefined symbols.
+LDFLAGS+= -Wl,--undefined-version
# Make sure that the right version of Python is used by the tools
# https://bugzilla.samba.org/show_bug.cgi?id=7305