aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNAKAJI Hiroyuki <nakaji@kankyo-u.ac.jp>2022-09-22 15:44:11 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-09-24 16:37:35 +0000
commit8c6fdee92af393f5b153e015fcf9b370e0818587 (patch)
tree3ea33bdbd8535e77c8336a909b84fd74f5b30203
parentb729e54157309dbd6f30e2f5cec8bf3df0c41612 (diff)
downloadports-8c6fdee92af393f5b153e015fcf9b370e0818587.tar.gz
ports-8c6fdee92af393f5b153e015fcf9b370e0818587.zip
net/tsclient: Fix build
Remove BROKEN*: ld: error: duplicate symbol: gConnect PR: 266543 Reported by: nakaji@kankyo-u.ac.jp Approved by: ports@thepentagon.org (maintainer, timeout > 2 weeks)
-rw-r--r--net/tsclient/Makefile3
-rw-r--r--net/tsclient/files/patch-src_connect.c10
-rw-r--r--net/tsclient/files/patch-src_connect.h11
-rw-r--r--net/tsclient/files/patch-src_main.c10
4 files changed, 31 insertions, 3 deletions
diff --git a/net/tsclient/Makefile b/net/tsclient/Makefile
index c9d63b78cc3c..e622d53447c2 100644
--- a/net/tsclient/Makefile
+++ b/net/tsclient/Makefile
@@ -8,9 +8,6 @@ MAINTAINER= ports@thepentagon.org
COMMENT= GNOME 2 frontend for rdesktop and vncviewer
WWW= https://sourceforge.net/projects/tsclient/
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: gConnect
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: gConnect
-
RUN_DEPENDS= rdesktop:net/rdesktop
USES= gettext gmake gnome libtool pathfix pkgconfig
diff --git a/net/tsclient/files/patch-src_connect.c b/net/tsclient/files/patch-src_connect.c
new file mode 100644
index 000000000000..29c517588d08
--- /dev/null
+++ b/net/tsclient/files/patch-src_connect.c
@@ -0,0 +1,10 @@
+--- src/connect.c.orig 2007-04-12 03:15:35.000000000 +0900
++++ src/connect.c 2022-09-08 13:45:16.005967000 +0900
+@@ -27,6 +27,7 @@
+ #include "connect.h"
+ #include "mrulist.h"
+
++GtkWidget *gConnect;
+
+ /***************************************
+ * *
diff --git a/net/tsclient/files/patch-src_connect.h b/net/tsclient/files/patch-src_connect.h
new file mode 100644
index 000000000000..0439937eb0db
--- /dev/null
+++ b/net/tsclient/files/patch-src_connect.h
@@ -0,0 +1,11 @@
+--- src/connect.h.orig 2007-03-27 02:34:26.000000000 +0900
++++ src/connect.h 2022-09-08 13:45:24.448781000 +0900
+@@ -4,7 +4,7 @@
+ * *
+ ***************************************/
+
+-GtkWidget *gConnect; // used for global accessibility of main form! :-P
++// GtkWidget *gConnect; // used for global accessibility of main form! :-P
+
+ int create_frmConnect (void);
+
diff --git a/net/tsclient/files/patch-src_main.c b/net/tsclient/files/patch-src_main.c
new file mode 100644
index 000000000000..c25d9e3ec7f9
--- /dev/null
+++ b/net/tsclient/files/patch-src_main.c
@@ -0,0 +1,10 @@
+--- src/main.c.orig 2007-04-12 03:21:51.000000000 +0900
++++ src/main.c 2022-09-08 13:45:37.689308000 +0900
+@@ -17,6 +17,7 @@
+ #include "support.h"
+ #include "connect.h"
+
++extern GtkWidget *gConnect;
+
+ static void tsc_print_help ();
+ static void tsc_print_version ();