aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-04-11 16:42:14 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-04-12 09:41:32 +0000
commit8cd785de155f660685d9d64ba9c9dc9ae53066c1 (patch)
treefa1442f3ccc5dff79c77f23ef35a6f86447851ee
parent723fd8be9ca063f30f4dcb0220970043ff3677b5 (diff)
downloadports-8cd785de155f660685d9d64ba9c9dc9ae53066c1.tar.gz
ports-8cd785de155f660685d9d64ba9c9dc9ae53066c1.zip
lang/crystal: Update to 1.4.0
ChangeLog: https://crystal-lang.org/2022/04/06/1.4.0-released.html PR: 262581 Reported by: slowdive@me.com Approved by: greg@unrelenting.technology (maintainer, timeout > 2 weeks)
-rw-r--r--lang/crystal/Makefile7
-rw-r--r--lang/crystal/distinfo8
-rw-r--r--lang/crystal/files/extra-patch-src_openssl_lib__crypto.cr39
-rw-r--r--lang/crystal/files/extra-patch-src_openssl_lib__ssl.cr28
-rw-r--r--lang/crystal/pkg-plist135
5 files changed, 182 insertions, 35 deletions
diff --git a/lang/crystal/Makefile b/lang/crystal/Makefile
index be4aa0c53286..ee3c0443abad 100644
--- a/lang/crystal/Makefile
+++ b/lang/crystal/Makefile
@@ -1,6 +1,5 @@
PORTNAME= crystal
-DISTVERSION= 1.2.2
-PORTREVISION= 1
+DISTVERSION= 1.4.0
CATEGORIES= lang
MASTER_SITES= https://dl.unrelenting.technology/crystal/:bootstrap
DISTFILES= ${BOOTSTRAP_PATH}:bootstrap
@@ -15,12 +14,12 @@ LICENSE= APACHE20
ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= requires prebuilt bootstrap compiler
+BUILD_DEPENDS= ${LOCALBASE}/bin/llvm-config${LLVM_VERSION}:devel/llvm${BOOTSTRAP_LLVM_VERSION} \
+ git:devel/git
LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded \
libevent.so:devel/libevent \
libpcre.so:devel/pcre \
libLLVM-${LLVM_VERSION:C/^([6-9])0/\1/:S/-devel/15/}.so:devel/llvm${LLVM_VERSION}
-BUILD_DEPENDS= ${LOCALBASE}/bin/llvm-config${LLVM_VERSION}:devel/llvm${BOOTSTRAP_LLVM_VERSION} \
- git:devel/git
RUN_DEPENDS= pkg-config:devel/pkgconf
USES= compiler gmake pkgconfig ssl
diff --git a/lang/crystal/distinfo b/lang/crystal/distinfo
index a556c9576048..0bc66fe1af2e 100644
--- a/lang/crystal/distinfo
+++ b/lang/crystal/distinfo
@@ -1,7 +1,5 @@
-TIMESTAMP = 1640645935
+TIMESTAMP = 1649536911
SHA256 (crystal/crystal-1.1.1-freebsd12-amd64-llvm10) = bceb45f9d886cfbfac866761dcb954788156908d3a54e35f58c9e3f716cf91ed
SIZE (crystal/crystal-1.1.1-freebsd12-amd64-llvm10) = 11997032
-SHA256 (crystal/crystal-1.1.1-freebsd12-aarch64-llvm10) = 51433c9cff796da1423e2a6d77c87891cd7ba4cee37ef25322b2e801aba2b53b
-SIZE (crystal/crystal-1.1.1-freebsd12-aarch64-llvm10) = 11093864
-SHA256 (crystal/crystal-lang-crystal-1.2.2_GH0.tar.gz) = 6d963a71ef5f6c73faa272a0f81b50e9ddbf814b1ec07e557ce5c95f84d6077e
-SIZE (crystal/crystal-lang-crystal-1.2.2_GH0.tar.gz) = 2621720
+SHA256 (crystal/crystal-lang-crystal-1.4.0_GH0.tar.gz) = 543443a253fe338d0dec4f4158d728806a8db65bdd4bf3dbe3d0afcd1361b495
+SIZE (crystal/crystal-lang-crystal-1.4.0_GH0.tar.gz) = 2879181
diff --git a/lang/crystal/files/extra-patch-src_openssl_lib__crypto.cr b/lang/crystal/files/extra-patch-src_openssl_lib__crypto.cr
index d935d28e2021..124851bf55fa 100644
--- a/lang/crystal/files/extra-patch-src_openssl_lib__crypto.cr
+++ b/lang/crystal/files/extra-patch-src_openssl_lib__crypto.cr
@@ -1,12 +1,26 @@
---- src/openssl/lib_crypto.cr.orig 2021-08-08 15:06:11 UTC
-+++ src/openssl/lib_crypto.cr
-@@ -1,21 +1,11 @@
+--- src/openssl/lib_crypto.cr.orig 2022-04-09 14:20:55.000000000 -0700
++++ src/openssl/lib_crypto.cr 2022-04-09 14:15:51.000000000 -0700
+@@ -1,31 +1,7 @@
{% begin %}
lib LibCrypto
-- {% from_libressl = (`hash pkg-config 2> /dev/null || printf %s false` != "false") &&
-- (`test -f $(pkg-config --silence-errors --variable=includedir libcrypto)/openssl/opensslv.h || printf %s false` != "false") &&
-- (`printf "#include <openssl/opensslv.h>\nLIBRESSL_VERSION_NUMBER" | ${CC:-cc} $(pkg-config --cflags --silence-errors libcrypto || true) -E -`.chomp.split('\n').last != "LIBRESSL_VERSION_NUMBER") %}
-- {% ssl_version = `hash pkg-config 2> /dev/null && pkg-config --silence-errors --modversion libcrypto || printf %s 0.0.0`.split.last.gsub(/[^0-9.]/, "") %}
+- {% if flag?(:win32) %}
+- {% from_libressl = false %}
+- {% ssl_version = nil %}
+- {% for dir in Crystal::LIBRARY_PATH.split(';') %}
+- {% unless ssl_version %}
+- {% config_path = "#{dir.id}\\openssl_VERSION" %}
+- {% if config_version = read_file?(config_path) %}
+- {% ssl_version = config_version.chomp %}
+- {% end %}
+- {% end %}
+- {% end %}
+- {% ssl_version ||= "0.0.0" %}
+- {% else %}
+- {% from_libressl = (`hash pkg-config 2> /dev/null || printf %s false` != "false") &&
+- (`test -f $(pkg-config --silence-errors --variable=includedir libcrypto)/openssl/opensslv.h || printf %s false` != "false") &&
+- (`printf "#include <openssl/opensslv.h>\nLIBRESSL_VERSION_NUMBER" | ${CC:-cc} $(pkg-config --cflags --silence-errors libcrypto || true) -E -`.chomp.split('\n').last != "LIBRESSL_VERSION_NUMBER") %}
+- {% ssl_version = `hash pkg-config 2> /dev/null && pkg-config --silence-errors --modversion libcrypto || printf %s 0.0.0`.split.last.gsub(/[^0-9.]/, "") %}
+- {% end %}
-
- {% if from_libressl %}
- LIBRESSL_VERSION = {{ ssl_version }}
@@ -20,8 +34,13 @@
end
{% end %}
--@[Link(ldflags: "`command -v pkg-config > /dev/null && pkg-config --libs --silence-errors libcrypto || printf %s '-lcrypto'`")]
-+@[Link(ldflags: "-LCRYSTAL_SSL_LDFLAGS -lcrypto")]
+@@ -34,7 +10,7 @@
+ @[Link("crypt32")] # CertOpenStore, ...
+ @[Link("user32")] # GetProcessWindowStation, GetUserObjectInformationW, _MessageBoxW
+ {% else %}
+- @[Link(ldflags: "`command -v pkg-config > /dev/null && pkg-config --libs --silence-errors libcrypto || printf %s '-lcrypto'`")]
++ @[Link(ldflags: "-LCRYSTAL_SSL_LDFLAGS -lcrypto")]
+ {% end %}
lib LibCrypto
alias Char = LibC::Char
- alias Int = LibC::Int
+
diff --git a/lang/crystal/files/extra-patch-src_openssl_lib__ssl.cr b/lang/crystal/files/extra-patch-src_openssl_lib__ssl.cr
index 54181f2f4b95..20ec2243b192 100644
--- a/lang/crystal/files/extra-patch-src_openssl_lib__ssl.cr
+++ b/lang/crystal/files/extra-patch-src_openssl_lib__ssl.cr
@@ -1,13 +1,27 @@
---- src/openssl/lib_ssl.cr.orig 2021-08-08 15:06:09 UTC
-+++ src/openssl/lib_ssl.cr
-@@ -6,22 +6,12 @@ require "./lib_crypto"
+--- src/openssl/lib_ssl.cr.orig 2022-04-09 14:24:40.000000000 -0700
++++ src/openssl/lib_ssl.cr 2022-04-09 14:24:07.000000000 -0700
+@@ -6,32 +6,8 @@
{% begin %}
lib LibSSL
-- {% from_libressl = (`hash pkg-config 2> /dev/null || printf %s false` != "false") &&
-- (`test -f $(pkg-config --silence-errors --variable=includedir libssl)/openssl/opensslv.h || printf %s false` != "false") &&
-- (`printf "#include <openssl/opensslv.h>\nLIBRESSL_VERSION_NUMBER" | ${CC:-cc} $(pkg-config --cflags --silence-errors libssl || true) -E -`.chomp.split('\n').last != "LIBRESSL_VERSION_NUMBER") %}
-- {% ssl_version = `hash pkg-config 2> /dev/null && pkg-config --silence-errors --modversion libssl || printf %s 0.0.0`.split.last.gsub(/[^0-9.]/, "") %}
+- {% if flag?(:win32) %}
+- {% from_libressl = false %}
+- {% ssl_version = nil %}
+- {% for dir in Crystal::LIBRARY_PATH.split(';') %}
+- {% unless ssl_version %}
+- {% config_path = "#{dir.id}\\openssl_VERSION" %}
+- {% if config_version = read_file?(config_path) %}
+- {% ssl_version = config_version.chomp %}
+- {% end %}
+- {% end %}
+- {% end %}
+- {% ssl_version ||= "0.0.0" %}
+- {% else %}
+- {% from_libressl = (`hash pkg-config 2> /dev/null || printf %s false` != "false") &&
+- (`test -f $(pkg-config --silence-errors --variable=includedir libssl)/openssl/opensslv.h || printf %s false` != "false") &&
+- (`printf "#include <openssl/opensslv.h>\nLIBRESSL_VERSION_NUMBER" | ${CC:-cc} $(pkg-config --cflags --silence-errors libssl || true) -E -`.chomp.split('\n').last != "LIBRESSL_VERSION_NUMBER") %}
+- {% ssl_version = `hash pkg-config 2> /dev/null && pkg-config --silence-errors --modversion libssl || printf %s 0.0.0`.split.last.gsub(/[^0-9.]/, "") %}
+- {% end %}
-
- {% if from_libressl %}
- LIBRESSL_VERSION = {{ ssl_version }}
diff --git a/lang/crystal/pkg-plist b/lang/crystal/pkg-plist
index 8446629d733c..495d726b5411 100644
--- a/lang/crystal/pkg-plist
+++ b/lang/crystal/pkg-plist
@@ -62,13 +62,48 @@ lib/crystal/compiler/crystal/command/env.cr
lib/crystal/compiler/crystal/command/eval.cr
lib/crystal/compiler/crystal/command/format.cr
lib/crystal/compiler/crystal/command/playground.cr
+lib/crystal/compiler/crystal/command/repl.cr
lib/crystal/compiler/crystal/command/spec.cr
lib/crystal/compiler/crystal/compiler.cr
lib/crystal/compiler/crystal/config.cr
lib/crystal/compiler/crystal/crystal_path.cr
lib/crystal/compiler/crystal/error.cr
lib/crystal/compiler/crystal/exception.cr
+lib/crystal/compiler/crystal/ffi/call_interface.cr
+lib/crystal/compiler/crystal/ffi/closure.cr
+lib/crystal/compiler/crystal/ffi/ffi.cr
+lib/crystal/compiler/crystal/ffi/lib_ffi.cr
+lib/crystal/compiler/crystal/ffi/type.cr
lib/crystal/compiler/crystal/formatter.cr
+lib/crystal/compiler/crystal/interpreter.cr
+lib/crystal/compiler/crystal/interpreter/c.cr
+lib/crystal/compiler/crystal/interpreter/cast.cr
+lib/crystal/compiler/crystal/interpreter/class_vars.cr
+lib/crystal/compiler/crystal/interpreter/closure.cr
+lib/crystal/compiler/crystal/interpreter/compiled_block.cr
+lib/crystal/compiler/crystal/interpreter/compiled_def.cr
+lib/crystal/compiler/crystal/interpreter/compiled_instructions.cr
+lib/crystal/compiler/crystal/interpreter/compiler.cr
+lib/crystal/compiler/crystal/interpreter/constants.cr
+lib/crystal/compiler/crystal/interpreter/context.cr
+lib/crystal/compiler/crystal/interpreter/debug.cr
+lib/crystal/compiler/crystal/interpreter/disassembler.cr
+lib/crystal/compiler/crystal/interpreter/escaping_exception.cr
+lib/crystal/compiler/crystal/interpreter/ffi_closure_context.cr
+lib/crystal/compiler/crystal/interpreter/instruction.cr
+lib/crystal/compiler/crystal/interpreter/instructions.cr
+lib/crystal/compiler/crystal/interpreter/interpreter.cr
+lib/crystal/compiler/crystal/interpreter/lib_function.cr
+lib/crystal/compiler/crystal/interpreter/local_vars.cr
+lib/crystal/compiler/crystal/interpreter/local_vars_gatherer.cr
+lib/crystal/compiler/crystal/interpreter/multidispatch.cr
+lib/crystal/compiler/crystal/interpreter/op_code.cr
+lib/crystal/compiler/crystal/interpreter/primitives.cr
+lib/crystal/compiler/crystal/interpreter/repl.cr
+lib/crystal/compiler/crystal/interpreter/to_bool.cr
+lib/crystal/compiler/crystal/interpreter/value.cr
+lib/crystal/compiler/crystal/loader.cr
+lib/crystal/compiler/crystal/loader/unix.cr
lib/crystal/compiler/crystal/macros.cr
lib/crystal/compiler/crystal/macros/interpreter.cr
lib/crystal/compiler/crystal/macros/macros.cr
@@ -129,9 +164,10 @@ lib/crystal/compiler/crystal/syntax/transformer.cr
lib/crystal/compiler/crystal/syntax/virtual_file.cr
lib/crystal/compiler/crystal/syntax/visitor.cr
lib/crystal/compiler/crystal/tools/context.cr
+lib/crystal/compiler/crystal/tools/doc.cr
lib/crystal/compiler/crystal/tools/doc/constant.cr
lib/crystal/compiler/crystal/tools/doc/generator.cr
-lib/crystal/compiler/crystal/tools/doc/highlighter.cr
+lib/crystal/compiler/crystal/tools/doc/html/404.html
lib/crystal/compiler/crystal/tools/doc/html/_head.html
lib/crystal/compiler/crystal/tools/doc/html/_list_items.html
lib/crystal/compiler/crystal/tools/doc/html/_method_detail.html
@@ -171,12 +207,13 @@ lib/crystal/compiler/crystal/tools/init/template/license.ecr
lib/crystal/compiler/crystal/tools/init/template/readme.md.ecr
lib/crystal/compiler/crystal/tools/init/template/shard.yml.ecr
lib/crystal/compiler/crystal/tools/init/template/spec_helper.cr.ecr
+lib/crystal/compiler/crystal/tools/playground.cr
lib/crystal/compiler/crystal/tools/playground/agent.cr
lib/crystal/compiler/crystal/tools/playground/agent_instrumentor_transformer.cr
lib/crystal/compiler/crystal/tools/playground/public/application.css
lib/crystal/compiler/crystal/tools/playground/public/application.js
lib/crystal/compiler/crystal/tools/playground/public/favicon.ico
-lib/crystal/compiler/crystal/tools/playground/public/icon.png
+lib/crystal/compiler/crystal/tools/playground/public/icon.svg
lib/crystal/compiler/crystal/tools/playground/public/session.js
lib/crystal/compiler/crystal/tools/playground/public/settings.js
lib/crystal/compiler/crystal/tools/playground/public/vendor/ansi_up-1.3.0/ansi_up.js
@@ -206,6 +243,7 @@ lib/crystal/compiler/crystal/tools/table_print.cr
lib/crystal/compiler/crystal/tools/typed_def_processor.cr
lib/crystal/compiler/crystal/types.cr
lib/crystal/compiler/crystal/util.cr
+lib/crystal/compiler/requires.cr
lib/crystal/complex.cr
lib/crystal/compress/deflate/deflate.cr
lib/crystal/compress/deflate/reader.cr
@@ -235,7 +273,10 @@ lib/crystal/crypto/subtle.cr
lib/crystal/crystal/at_exit_handlers.cr
lib/crystal/crystal/compiler_rt.cr
lib/crystal/crystal/compiler_rt/divmod128.cr
+lib/crystal/crystal/compiler_rt/fixint.cr
+lib/crystal/crystal/compiler_rt/float.cr
lib/crystal/crystal/compiler_rt/mul.cr
+lib/crystal/crystal/compiler_rt/multi3.cr
lib/crystal/crystal/datum.cr
lib/crystal/crystal/digest/md5.cr
lib/crystal/crystal/digest/sha1.cr
@@ -248,6 +289,8 @@ lib/crystal/crystal/elf.cr
lib/crystal/crystal/fiber_channel.cr
lib/crystal/crystal/hasher.cr
lib/crystal/crystal/iconv.cr
+lib/crystal/crystal/interpreter.cr
+lib/crystal/crystal/lib_iconv.cr
lib/crystal/crystal/mach_o.cr
lib/crystal/crystal/main.cr
lib/crystal/crystal/once.cr
@@ -255,6 +298,9 @@ lib/crystal/crystal/pointer_linked_list.cr
lib/crystal/crystal/rw_lock.cr
lib/crystal/crystal/scheduler.cr
lib/crystal/crystal/spin_lock.cr
+lib/crystal/crystal/syntax_highlighter.cr
+lib/crystal/crystal/syntax_highlighter/colorize.cr
+lib/crystal/crystal/syntax_highlighter/html.cr
lib/crystal/crystal/system.cr
lib/crystal/crystal/system/dir.cr
lib/crystal/crystal/system/env.cr
@@ -265,6 +311,7 @@ lib/crystal/crystal/system/file_descriptor.cr
lib/crystal/crystal/system/file_info.cr
lib/crystal/crystal/system/group.cr
lib/crystal/crystal/system/mime.cr
+lib/crystal/crystal/system/path.cr
lib/crystal/crystal/system/print_error.cr
lib/crystal/crystal/system/process.cr
lib/crystal/crystal/system/random.cr
@@ -288,17 +335,37 @@ lib/crystal/crystal/system/unix/group.cr
lib/crystal/crystal/system/unix/hostname.cr
lib/crystal/crystal/system/unix/lib_event2.cr
lib/crystal/crystal/system/unix/mime.cr
+lib/crystal/crystal/system/unix/path.cr
lib/crystal/crystal/system/unix/process.cr
lib/crystal/crystal/system/unix/pthread.cr
lib/crystal/crystal/system/unix/pthread_condition_variable.cr
lib/crystal/crystal/system/unix/pthread_mutex.cr
lib/crystal/crystal/system/unix/socket.cr
+lib/crystal/crystal/system/unix/syscall.cr
lib/crystal/crystal/system/unix/sysconf_cpucount.cr
lib/crystal/crystal/system/unix/sysctl_cpucount.cr
lib/crystal/crystal/system/unix/time.cr
lib/crystal/crystal/system/unix/urandom.cr
lib/crystal/crystal/system/unix/user.cr
lib/crystal/crystal/system/user.cr
+lib/crystal/crystal/system/wasi/cpucount.cr
+lib/crystal/crystal/system/wasi/dir.cr
+lib/crystal/crystal/system/wasi/event_loop.cr
+lib/crystal/crystal/system/wasi/fiber.cr
+lib/crystal/crystal/system/wasi/file.cr
+lib/crystal/crystal/system/wasi/file_descriptor.cr
+lib/crystal/crystal/system/wasi/group.cr
+lib/crystal/crystal/system/wasi/hostname.cr
+lib/crystal/crystal/system/wasi/lib_wasi.cr
+lib/crystal/crystal/system/wasi/main.cr
+lib/crystal/crystal/system/wasi/path.cr
+lib/crystal/crystal/system/wasi/process.cr
+lib/crystal/crystal/system/wasi/random.cr
+lib/crystal/crystal/system/wasi/socket.cr
+lib/crystal/crystal/system/wasi/thread.cr
+lib/crystal/crystal/system/wasi/thread_mutex.cr
+lib/crystal/crystal/system/wasi/user.cr
+lib/crystal/crystal/system/wasi/wasi.cr
lib/crystal/crystal/system/win32/cpucount.cr
lib/crystal/crystal/system/win32/dir.cr
lib/crystal/crystal/system/win32/env.cr
@@ -309,13 +376,17 @@ lib/crystal/crystal/system/win32/file_descriptor.cr
lib/crystal/crystal/system/win32/file_info.cr
lib/crystal/crystal/system/win32/hostname.cr
lib/crystal/crystal/system/win32/mime.cr
+lib/crystal/crystal/system/win32/path.cr
lib/crystal/crystal/system/win32/process.cr
lib/crystal/crystal/system/win32/random.cr
lib/crystal/crystal/system/win32/socket.cr
lib/crystal/crystal/system/win32/thread.cr
lib/crystal/crystal/system/win32/thread_mutex.cr
lib/crystal/crystal/system/win32/time.cr
+lib/crystal/crystal/system/win32/visual_studio.cr
lib/crystal/crystal/system/win32/windows_registry.cr
+lib/crystal/crystal/system/win32/windows_sdk.cr
+lib/crystal/crystal/system/win32/wmain.cr
lib/crystal/crystal/system/win32/zone_names.cr
lib/crystal/crystal/system/windows.cr
lib/crystal/crystal/thread_local_value.cr
@@ -355,15 +426,19 @@ lib/crystal/exception.cr
lib/crystal/exception/call_stack.cr
lib/crystal/exception/call_stack/dwarf.cr
lib/crystal/exception/call_stack/elf.cr
+lib/crystal/exception/call_stack/interpreter.cr
lib/crystal/exception/call_stack/libunwind.cr
lib/crystal/exception/call_stack/mach_o.cr
lib/crystal/exception/call_stack/null.cr
+lib/crystal/exception/call_stack/stackwalk.cr
lib/crystal/exception/lib_unwind.cr
lib/crystal/fiber.cr
lib/crystal/fiber/context.cr
lib/crystal/fiber/context/aarch64.cr
lib/crystal/fiber/context/arm.cr
lib/crystal/fiber/context/i386.cr
+lib/crystal/fiber/context/interpreted.cr
+lib/crystal/fiber/context/wasm32.cr
lib/crystal/fiber/context/x86_64-microsoft.cr
lib/crystal/fiber/context/x86_64-sysv.cr
lib/crystal/fiber/stack_pool.cr
@@ -427,6 +502,7 @@ lib/crystal/io/byte_format.cr
lib/crystal/io/console.cr
lib/crystal/io/delimited.cr
lib/crystal/io/encoding.cr
+lib/crystal/io/encoding_stubs.cr
lib/crystal/io/error.cr
lib/crystal/io/evented.cr
lib/crystal/io/file_descriptor.cr
@@ -516,7 +592,6 @@ lib/crystal/lib_c/aarch64-linux-gnu/c/sys/resource.cr
lib/crystal/lib_c/aarch64-linux-gnu/c/sys/select.cr
lib/crystal/lib_c/aarch64-linux-gnu/c/sys/socket.cr
lib/crystal/lib_c/aarch64-linux-gnu/c/sys/stat.cr
-lib/crystal/lib_c/aarch64-linux-gnu/c/sys/syscall.cr
lib/crystal/lib_c/aarch64-linux-gnu/c/sys/time.cr
lib/crystal/lib_c/aarch64-linux-gnu/c/sys/types.cr
lib/crystal/lib_c/aarch64-linux-gnu/c/sys/un.cr
@@ -552,7 +627,6 @@ lib/crystal/lib_c/aarch64-linux-musl/c/sys/resource.cr
lib/crystal/lib_c/aarch64-linux-musl/c/sys/select.cr
lib/crystal/lib_c/aarch64-linux-musl/c/sys/socket.cr
lib/crystal/lib_c/aarch64-linux-musl/c/sys/stat.cr
-lib/crystal/lib_c/aarch64-linux-musl/c/sys/syscall.cr
lib/crystal/lib_c/aarch64-linux-musl/c/sys/time.cr
lib/crystal/lib_c/aarch64-linux-musl/c/sys/types.cr
lib/crystal/lib_c/aarch64-linux-musl/c/sys/un.cr
@@ -590,7 +664,6 @@ lib/crystal/lib_c/arm-linux-gnueabihf/c/sys/resource.cr
lib/crystal/lib_c/arm-linux-gnueabihf/c/sys/select.cr
lib/crystal/lib_c/arm-linux-gnueabihf/c/sys/socket.cr
lib/crystal/lib_c/arm-linux-gnueabihf/c/sys/stat.cr
-lib/crystal/lib_c/arm-linux-gnueabihf/c/sys/syscall.cr
lib/crystal/lib_c/arm-linux-gnueabihf/c/sys/time.cr
lib/crystal/lib_c/arm-linux-gnueabihf/c/sys/types.cr
lib/crystal/lib_c/arm-linux-gnueabihf/c/sys/un.cr
@@ -626,7 +699,6 @@ lib/crystal/lib_c/i386-linux-gnu/c/sys/resource.cr
lib/crystal/lib_c/i386-linux-gnu/c/sys/select.cr
lib/crystal/lib_c/i386-linux-gnu/c/sys/socket.cr
lib/crystal/lib_c/i386-linux-gnu/c/sys/stat.cr
-lib/crystal/lib_c/i386-linux-gnu/c/sys/syscall.cr
lib/crystal/lib_c/i386-linux-gnu/c/sys/time.cr
lib/crystal/lib_c/i386-linux-gnu/c/sys/types.cr
lib/crystal/lib_c/i386-linux-gnu/c/sys/un.cr
@@ -662,7 +734,6 @@ lib/crystal/lib_c/i386-linux-musl/c/sys/resource.cr
lib/crystal/lib_c/i386-linux-musl/c/sys/select.cr
lib/crystal/lib_c/i386-linux-musl/c/sys/socket.cr
lib/crystal/lib_c/i386-linux-musl/c/sys/stat.cr
-lib/crystal/lib_c/i386-linux-musl/c/sys/syscall.cr
lib/crystal/lib_c/i386-linux-musl/c/sys/time.cr
lib/crystal/lib_c/i386-linux-musl/c/sys/types.cr
lib/crystal/lib_c/i386-linux-musl/c/sys/un.cr
@@ -672,6 +743,31 @@ lib/crystal/lib_c/i386-linux-musl/c/time.cr
lib/crystal/lib_c/i386-linux-musl/c/unistd.cr
lib/crystal/lib_c/i686-linux-gnu
lib/crystal/lib_c/i686-linux-musl
+lib/crystal/lib_c/wasm32-wasi/c/arpa/inet.cr
+lib/crystal/lib_c/wasm32-wasi/c/errno.cr
+lib/crystal/lib_c/wasm32-wasi/c/fcntl.cr
+lib/crystal/lib_c/wasm32-wasi/c/iconv.cr
+lib/crystal/lib_c/wasm32-wasi/c/netdb.cr
+lib/crystal/lib_c/wasm32-wasi/c/netinet/in.cr
+lib/crystal/lib_c/wasm32-wasi/c/netinet/tcp.cr
+lib/crystal/lib_c/wasm32-wasi/c/sched.cr
+lib/crystal/lib_c/wasm32-wasi/c/stdarg.cr
+lib/crystal/lib_c/wasm32-wasi/c/stddef.cr
+lib/crystal/lib_c/wasm32-wasi/c/stdint.cr
+lib/crystal/lib_c/wasm32-wasi/c/stdio.cr
+lib/crystal/lib_c/wasm32-wasi/c/stdlib.cr
+lib/crystal/lib_c/wasm32-wasi/c/string.cr
+lib/crystal/lib_c/wasm32-wasi/c/sys/file.cr
+lib/crystal/lib_c/wasm32-wasi/c/sys/resource.cr
+lib/crystal/lib_c/wasm32-wasi/c/sys/select.cr
+lib/crystal/lib_c/wasm32-wasi/c/sys/socket.cr
+lib/crystal/lib_c/wasm32-wasi/c/sys/stat.cr
+lib/crystal/lib_c/wasm32-wasi/c/sys/time.cr
+lib/crystal/lib_c/wasm32-wasi/c/sys/times.cr
+lib/crystal/lib_c/wasm32-wasi/c/sys/types.cr
+lib/crystal/lib_c/wasm32-wasi/c/termios.cr
+lib/crystal/lib_c/wasm32-wasi/c/time.cr
+lib/crystal/lib_c/wasm32-wasi/c/unistd.cr
lib/crystal/lib_c/x86_64-darwin/c/arpa/inet.cr
lib/crystal/lib_c/x86_64-darwin/c/dirent.cr
lib/crystal/lib_c/x86_64-darwin/c/dlfcn.cr
@@ -806,7 +902,6 @@ lib/crystal/lib_c/x86_64-linux-gnu/c/sys/resource.cr
lib/crystal/lib_c/x86_64-linux-gnu/c/sys/select.cr
lib/crystal/lib_c/x86_64-linux-gnu/c/sys/socket.cr
lib/crystal/lib_c/x86_64-linux-gnu/c/sys/stat.cr
-lib/crystal/lib_c/x86_64-linux-gnu/c/sys/syscall.cr
lib/crystal/lib_c/x86_64-linux-gnu/c/sys/time.cr
lib/crystal/lib_c/x86_64-linux-gnu/c/sys/types.cr
lib/crystal/lib_c/x86_64-linux-gnu/c/sys/un.cr
@@ -842,7 +937,6 @@ lib/crystal/lib_c/x86_64-linux-musl/c/sys/resource.cr
lib/crystal/lib_c/x86_64-linux-musl/c/sys/select.cr
lib/crystal/lib_c/x86_64-linux-musl/c/sys/socket.cr
lib/crystal/lib_c/x86_64-linux-musl/c/sys/stat.cr
-lib/crystal/lib_c/x86_64-linux-musl/c/sys/syscall.cr
lib/crystal/lib_c/x86_64-linux-musl/c/sys/time.cr
lib/crystal/lib_c/x86_64-linux-musl/c/sys/types.cr
lib/crystal/lib_c/x86_64-linux-musl/c/sys/un.cr
@@ -927,8 +1021,11 @@ lib/crystal/lib_c/x86_64-portbld-freebsd
lib/crystal/lib_c/x86_64-unknown-freebsd
lib/crystal/lib_c/x86_64-windows-msvc/c/afunix.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/basetsd.cr
+lib/crystal/lib_c/x86_64-windows-msvc/c/combaseapi.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/consoleapi.cr
+lib/crystal/lib_c/x86_64-windows-msvc/c/consoleapi2.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/corecrt.cr
+lib/crystal/lib_c/x86_64-windows-msvc/c/dbghelp.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/direct.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/errhandlingapi.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/errno.cr
@@ -941,7 +1038,9 @@ lib/crystal/lib_c/x86_64-windows-msvc/c/inaddr.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/int_safe.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/io.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/ioapiset.cr
+lib/crystal/lib_c/x86_64-windows-msvc/c/knownfolders.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/libloaderapi.cr
+lib/crystal/lib_c/x86_64-windows-msvc/c/malloc.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/memoryapi.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/minwinbase.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/mswsock.cr
@@ -950,12 +1049,14 @@ lib/crystal/lib_c/x86_64-windows-msvc/c/processenv.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/processthreadsapi.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/profileapi.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/regapix.cr
+lib/crystal/lib_c/x86_64-windows-msvc/c/shlobj_core.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/stdarg.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/stddef.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/stdint.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/stdio.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/stdlib.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/string.cr
+lib/crystal/lib_c/x86_64-windows-msvc/c/stringapiset.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/synchapi.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/sys/stat.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/sys/types.cr
@@ -965,6 +1066,7 @@ lib/crystal/lib_c/x86_64-windows-msvc/c/timezoneapi.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/win_def.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/winbase.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/windows.cr
+lib/crystal/lib_c/x86_64-windows-msvc/c/winnls.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/winnt.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/winreg.cr
lib/crystal/lib_c/x86_64-windows-msvc/c/winsock2.cr
@@ -977,6 +1079,7 @@ lib/crystal/llvm.cr
lib/crystal/llvm/abi.cr
lib/crystal/llvm/abi/aarch64.cr
lib/crystal/llvm/abi/arm.cr
+lib/crystal/llvm/abi/wasm32.cr
lib/crystal/llvm/abi/x86.cr
lib/crystal/llvm/abi/x86_64.cr
lib/crystal/llvm/abi/x86_win64.cr
@@ -1036,6 +1139,7 @@ lib/crystal/mime/media_type.cr
lib/crystal/mime/multipart.cr
lib/crystal/mime/multipart/builder.cr
lib/crystal/mime/multipart/parser.cr
+lib/crystal/mime/multipart/state.cr
lib/crystal/mutex.cr
lib/crystal/named_tuple.cr
lib/crystal/nil.cr
@@ -1067,7 +1171,11 @@ lib/crystal/openssl/digest.cr
lib/crystal/openssl/error.cr
lib/crystal/openssl/hmac.cr
lib/crystal/openssl/lib_crypto.cr
+lib/crystal/openssl/lib_crypto.cr.bak
+lib/crystal/openssl/lib_crypto.cr.orig
lib/crystal/openssl/lib_ssl.cr
+lib/crystal/openssl/lib_ssl.cr.bak
+lib/crystal/openssl/lib_ssl.cr.orig
lib/crystal/openssl/md5.cr
lib/crystal/openssl/pkcs5.cr
lib/crystal/openssl/sha1.cr
@@ -1139,11 +1247,19 @@ lib/crystal/steppable.cr
lib/crystal/string.cr
lib/crystal/string/builder.cr
lib/crystal/string/formatter.cr
+lib/crystal/string/grapheme.cr
+lib/crystal/string/grapheme/grapheme.cr
+lib/crystal/string/grapheme/properties.cr
lib/crystal/string/utf16.cr
lib/crystal/string_pool.cr
lib/crystal/string_scanner.cr
lib/crystal/struct.cr
lib/crystal/symbol.cr
+lib/crystal/syscall.cr
+lib/crystal/syscall/aarch64-linux.cr
+lib/crystal/syscall/arm-linux.cr
+lib/crystal/syscall/i386-linux.cr
+lib/crystal/syscall/x86_64-linux.cr
lib/crystal/system.cr
lib/crystal/system/group.cr
lib/crystal/system/user.cr
@@ -1178,6 +1294,7 @@ lib/crystal/uuid/json.cr
lib/crystal/uuid/yaml.cr
lib/crystal/va_list.cr
lib/crystal/value.cr
+lib/crystal/wasi_error.cr
lib/crystal/weak_ref.cr
lib/crystal/windows_stubs.cr
lib/crystal/winerror.cr