aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-01-06 22:22:55 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-01-06 22:22:55 +0000
commit8d656131d2060996dafb4e8006622dc684a095d6 (patch)
tree38063902ee15deb52b35b9904ca90af3a69ae597
parent46a16993155de085a8ba2cf505d48e32a04194f1 (diff)
downloadports-8d656131d2060996dafb4e8006622dc684a095d6.tar.gz
ports-8d656131d2060996dafb4e8006622dc684a095d6.zip
net/freerdp: sort out port
1. Move manpages from LOCALBASE/man/ to LOCALBASE/share/man/. 2. Update ARM NEON support (details are at https://reviews.freebsd.org/D43127). 3. Unification of the pkg-plist with upcoming net/freerdp3: replace "2" with "%%MAJORVERSION%%". Approved by: arrowd (mentor) Differential Revision: https://reviews.freebsd.org/D43352
-rw-r--r--net/freerdp/Makefile11
-rw-r--r--net/freerdp/files/patch-client_Wayland_CMakeLists.txt16
-rw-r--r--net/freerdp/files/patch-client_Wayland_wlfreerdp.c6
-rw-r--r--net/freerdp/files/patch-client_X11_CMakeLists.txt15
-rw-r--r--net/freerdp/files/patch-cmake_InstallFreeRDPMan.cmake10
-rw-r--r--net/freerdp/files/patch-winpr_CMakeLists.txt18
-rw-r--r--net/freerdp/files/patch-winpr_libwinpr_sysinfo_sysinfo.c19
-rw-r--r--net/freerdp/files/patch-winpr_tools_hash-cli_CMakeLists.txt15
-rw-r--r--net/freerdp/files/patch-winpr_tools_makecert-cli_CMakeLists.txt15
-rw-r--r--net/freerdp/pkg-plist504
10 files changed, 288 insertions, 341 deletions
diff --git a/net/freerdp/Makefile b/net/freerdp/Makefile
index 94cb27800e04..f33ad9a3b578 100644
--- a/net/freerdp/Makefile
+++ b/net/freerdp/Makefile
@@ -1,5 +1,6 @@
PORTNAME= freerdp
DISTVERSION= 2.11.4
+PORTREVISION= 1
CATEGORIES= net comms
MASTER_SITES= https://pub.freerdp.com/releases/ \
https://github.com/FreeRDP/FreeRDP/releases/download/${DISTVERSION}/
@@ -34,9 +35,6 @@ CMAKE_OFF= WITH_DSP_EXPERIMENTAL WITH_GPROF WITH_GSSAPI WITH_GSTREAMER_0_10 WITH
WITH_SANITIZE_THREAD WITH_SERVER WITH_SERVER_INTERFACE \
WITH_SMARTCARD_INSPECT WITH_THIRD_PARTY WITH_VALGRIND_MEMCHECK
-CMAKE_ARGS_aarch64+= -DWITH_NEON=ON
-CFLAGS_aarch64+= -D__ARM_NEON__=__ARM_NEON # clang
-
PLIST_SUB+= PATCHVERSION="${PATCHVERSION}"
PLIST_SUB+= MAJORVERSION="${MAJORVERSION}"
@@ -48,10 +46,12 @@ OPTIONS_RADIO= SCALE
OPTIONS_RADIO_SCALE= CAIRO SWSCALE
OPTIONS_SUB= yes
+OPTIONS_DEFINE_aarch64= NEON
OPTIONS_DEFINE_armv6= NEON
OPTIONS_DEFINE_armv7= NEON
OPTIONS_DEFINE_amd64= SSE
OPTIONS_DEFINE_i386= SSE
+OPTIONS_DEFAULT_aarch64= NEON
OPTIONS_DEFAULT_amd64= SSE
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
@@ -97,11 +97,8 @@ LAME_CMAKE_BOOL= WITH_LAME
MANPAGES_BUILD_DEPENDS= xmlto:textproc/xmlto
MANPAGES_CMAKE_BOOL= WITH_MANPAGES
-NEON_DESC= Enable Media Processing Engine instructions
+NEON_DESC= Enable Media Processing Engine instructions
NEON_CMAKE_BOOL= WITH_NEON
-.if ! ${CFLAGS:M-march*}
-NEON_CFLAGS= -march=armv7-a
-.endif
OPENH264_DESC= H.264 video codec support via OpenH264
OPENH264_LIB_DEPENDS= libopenh264.so:multimedia/openh264
diff --git a/net/freerdp/files/patch-client_Wayland_CMakeLists.txt b/net/freerdp/files/patch-client_Wayland_CMakeLists.txt
deleted file mode 100644
index 6b61bfbfc46f..000000000000
--- a/net/freerdp/files/patch-client_Wayland_CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
---- client/Wayland/CMakeLists.txt.orig 2017-11-28 14:26:30 UTC
-+++ client/Wayland/CMakeLists.txt
-@@ -39,5 +39,12 @@ target_link_libraries(${MODULE_NAME} ${$
- install(TARGETS ${MODULE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT client)
-
- set_property(TARGET ${MODULE_NAME} PROPERTY FOLDER "Client/Wayland")
-+
-+if(WITH_MANPAGES)
- configure_file(wlfreerdp.1.in ${CMAKE_CURRENT_BINARY_DIR}/wlfreerdp.1)
--install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/wlfreerdp.1 1)
-+ if(BSD)
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/wlfreerdp.1 DESTINATION man/man1)
-+ else()
-+ install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/wlfreerdp.1 1)
-+ endif()
-+endif(WITH_MANPAGES)
diff --git a/net/freerdp/files/patch-client_Wayland_wlfreerdp.c b/net/freerdp/files/patch-client_Wayland_wlfreerdp.c
index 0b7fd973f414..f718b79ccb76 100644
--- a/net/freerdp/files/patch-client_Wayland_wlfreerdp.c
+++ b/net/freerdp/files/patch-client_Wayland_wlfreerdp.c
@@ -1,6 +1,6 @@
---- client/Wayland/wlfreerdp.c.orig
+--- client/Wayland/wlfreerdp.c.orig 2023-12-14 18:03:49 UTC
+++ client/Wayland/wlfreerdp.c
-@@ -587,7 +587,7 @@ static void wlf_client_free(freerdp* instance, rdpContext* context)
+@@ -587,7 +587,7 @@ static void wlf_client_free(freerdp* instance, rdpCont
DeleteCriticalSection(&wlf->critical);
}
@@ -8,4 +8,4 @@
+static void* uwac_event_clone(void* val)
{
UwacEvent* copy;
- const UwacEvent* ev = (const UwacEvent*)val;
+ UwacEvent* ev = (UwacEvent*)val;
diff --git a/net/freerdp/files/patch-client_X11_CMakeLists.txt b/net/freerdp/files/patch-client_X11_CMakeLists.txt
deleted file mode 100644
index e714acb95c95..000000000000
--- a/net/freerdp/files/patch-client_X11_CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- client/X11/CMakeLists.txt.orig 2017-11-28 14:26:30 UTC
-+++ client/X11/CMakeLists.txt
-@@ -111,7 +111,11 @@ if(WITH_MANPAGES)
- add_custom_target(xfreerdp.manpage ALL
- DEPENDS xfreerdp.1)
-
-- install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/xfreerdp.1 1)
-+ if(BSD)
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/xfreerdp.1 DESTINATION man/man1)
-+ else()
-+ install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/xfreerdp.1 1)
-+ endif()
- else()
- message(WARNING "WITH_MANPAGES was set, but xsltproc was not found. man-pages will not be installed")
- endif()
diff --git a/net/freerdp/files/patch-cmake_InstallFreeRDPMan.cmake b/net/freerdp/files/patch-cmake_InstallFreeRDPMan.cmake
new file mode 100644
index 000000000000..b0a4793ebea7
--- /dev/null
+++ b/net/freerdp/files/patch-cmake_InstallFreeRDPMan.cmake
@@ -0,0 +1,10 @@
+--- cmake/InstallFreeRDPMan.cmake.orig 2023-12-14 18:03:49 UTC
++++ cmake/InstallFreeRDPMan.cmake
+@@ -1,6 +1,6 @@
+ function(install_freerdp_man manpage section)
+ if(WITH_MANPAGES)
+- if(OPENBSD OR FREEBSD)
++ if(OPENBSD)
+ install(FILES ${manpage} DESTINATION man/man${section})
+ else()
+ install(FILES ${manpage} DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/man/man${section})
diff --git a/net/freerdp/files/patch-winpr_CMakeLists.txt b/net/freerdp/files/patch-winpr_CMakeLists.txt
deleted file mode 100644
index d405ef71061a..000000000000
--- a/net/freerdp/files/patch-winpr_CMakeLists.txt
+++ /dev/null
@@ -1,18 +0,0 @@
---- winpr/CMakeLists.txt.orig 2017-11-28 14:26:30 UTC
-+++ winpr/CMakeLists.txt
-@@ -180,7 +180,14 @@ if(BUILD_TESTING)
- add_subdirectory(test)
- endif()
-
--install_freerdp_man(wlog.7 7)
-+if(WITH_MANPAGES)
-+ if(BSD)
-+ install(FILES wlog.7 DESTINATION man/man7)
-+ else()
-+ install_freerdp_man(wlog.7 7)
-+ endif()
-+endif(WITH_MANPAGES)
-+
- # Exporting
-
- if(${CMAKE_VERSION} VERSION_GREATER "2.8.10")
diff --git a/net/freerdp/files/patch-winpr_libwinpr_sysinfo_sysinfo.c b/net/freerdp/files/patch-winpr_libwinpr_sysinfo_sysinfo.c
new file mode 100644
index 000000000000..794253fa4267
--- /dev/null
+++ b/net/freerdp/files/patch-winpr_libwinpr_sysinfo_sysinfo.c
@@ -0,0 +1,19 @@
+--- winpr/libwinpr/sysinfo/sysinfo.c.orig 2023-12-14 18:03:49 UTC
++++ winpr/libwinpr/sysinfo/sysinfo.c
+@@ -782,13 +782,15 @@ BOOL IsProcessorFeaturePresent(DWORD ProcessorFeature)
+ break;
+ }
+
+-#elif defined(__APPLE__) // __linux__
++#else // __linux__
+
+ switch (ProcessorFeature)
+ {
+ case PF_ARM_NEON_INSTRUCTIONS_AVAILABLE:
+ case PF_ARM_NEON:
++#ifdef __ARM_NEON
+ ret = TRUE;
++#endif
+ break;
+ }
+
diff --git a/net/freerdp/files/patch-winpr_tools_hash-cli_CMakeLists.txt b/net/freerdp/files/patch-winpr_tools_hash-cli_CMakeLists.txt
deleted file mode 100644
index b894630ed3d4..000000000000
--- a/net/freerdp/files/patch-winpr_tools_hash-cli_CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- winpr/tools/hash-cli/CMakeLists.txt.orig 2017-11-28 14:26:30 UTC
-+++ winpr/tools/hash-cli/CMakeLists.txt
-@@ -50,5 +50,11 @@ if (WITH_DEBUG_SYMBOLS AND MSVC)
- endif()
-
- set_property(TARGET ${MODULE_NAME} PROPERTY FOLDER "WinPR/Tools")
-+if(WITH_MANPAGES)
- configure_file(winpr-hash.1.in ${CMAKE_CURRENT_BINARY_DIR}/winpr-hash.1)
--install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/winpr-hash.1 1)
-+ if(BSD)
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/winpr-hash.1 DESTINATION man/man1)
-+ else()
-+ install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/winpr-hash.1 1)
-+ endif()
-+endif(WITH_MANPAGES)
diff --git a/net/freerdp/files/patch-winpr_tools_makecert-cli_CMakeLists.txt b/net/freerdp/files/patch-winpr_tools_makecert-cli_CMakeLists.txt
deleted file mode 100644
index df778cb67ddd..000000000000
--- a/net/freerdp/files/patch-winpr_tools_makecert-cli_CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- winpr/tools/makecert-cli/CMakeLists.txt.orig 2017-11-28 14:26:30 UTC
-+++ winpr/tools/makecert-cli/CMakeLists.txt
-@@ -51,5 +51,11 @@ if (WITH_DEBUG_SYMBOLS AND MSVC)
- install(FILES ${CMAKE_PDB_BINARY_DIR}/${MODULE_NAME}.pdb DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT symbols)
- endif()
-
-+if(WITH_MANPAGES)
- configure_file(winpr-makecert.1.in ${CMAKE_CURRENT_BINARY_DIR}/winpr-makecert.1)
--install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/winpr-makecert.1 1)
-+ if(BSD)
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/winpr-makecert.1 DESTINATION man/man1)
-+ else()
-+ install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/winpr-makecert.1 1)
-+ endif()
-+endif(WITH_MANPAGES)
diff --git a/net/freerdp/pkg-plist b/net/freerdp/pkg-plist
index 8cc09b44739a..4fc8b242b671 100644
--- a/net/freerdp/pkg-plist
+++ b/net/freerdp/pkg-plist
@@ -2,264 +2,264 @@ bin/winpr-hash
bin/winpr-makecert
%%WAYLAND%%bin/wlfreerdp
%%X11%%bin/xfreerdp
-include/freerdp2/freerdp/addin.h
-include/freerdp2/freerdp/altsec.h
-include/freerdp2/freerdp/api.h
-include/freerdp2/freerdp/assistance.h
-include/freerdp2/freerdp/autodetect.h
-include/freerdp2/freerdp/build-config.h
-include/freerdp2/freerdp/cache/bitmap.h
-include/freerdp2/freerdp/cache/brush.h
-include/freerdp2/freerdp/cache/cache.h
-include/freerdp2/freerdp/cache/glyph.h
-include/freerdp2/freerdp/cache/nine_grid.h
-include/freerdp2/freerdp/cache/offscreen.h
-include/freerdp2/freerdp/cache/palette.h
-include/freerdp2/freerdp/cache/pointer.h
-include/freerdp2/freerdp/channels/ainput.h
-include/freerdp2/freerdp/channels/audin.h
-include/freerdp2/freerdp/channels/channels.h
-include/freerdp2/freerdp/channels/cliprdr.h
-include/freerdp2/freerdp/channels/disp.h
-include/freerdp2/freerdp/channels/echo.h
-include/freerdp2/freerdp/channels/encomsp.h
-include/freerdp2/freerdp/channels/geometry.h
-include/freerdp2/freerdp/channels/log.h
-include/freerdp2/freerdp/channels/rail.h
-include/freerdp2/freerdp/channels/rdpdr.h
-include/freerdp2/freerdp/channels/rdpecam.h
-include/freerdp2/freerdp/channels/rdpei.h
-include/freerdp2/freerdp/channels/rdpgfx.h
-include/freerdp2/freerdp/channels/rdpsnd.h
-include/freerdp2/freerdp/channels/remdesk.h
-include/freerdp2/freerdp/channels/telemetry.h
-include/freerdp2/freerdp/channels/tsmf.h
-include/freerdp2/freerdp/channels/urbdrc.h
-include/freerdp2/freerdp/channels/video.h
-include/freerdp2/freerdp/channels/wtsvc.h
-include/freerdp2/freerdp/client.h
-include/freerdp2/freerdp/client/ainput.h
-include/freerdp2/freerdp/client/audin.h
-include/freerdp2/freerdp/client/channels.h
-include/freerdp2/freerdp/client/cliprdr.h
-include/freerdp2/freerdp/client/cmdline.h
-include/freerdp2/freerdp/client/disp.h
-include/freerdp2/freerdp/client/drdynvc.h
-include/freerdp2/freerdp/client/encomsp.h
-include/freerdp2/freerdp/client/file.h
-include/freerdp2/freerdp/client/geometry.h
-include/freerdp2/freerdp/client/printer.h
-include/freerdp2/freerdp/client/rail.h
-include/freerdp2/freerdp/client/rdpei.h
-include/freerdp2/freerdp/client/rdpgfx.h
-include/freerdp2/freerdp/client/rdpsnd.h
-include/freerdp2/freerdp/client/remdesk.h
-include/freerdp2/freerdp/client/sshagent.h
-include/freerdp2/freerdp/client/tsmf.h
-include/freerdp2/freerdp/client/video.h
-include/freerdp2/freerdp/codec/audio.h
-include/freerdp2/freerdp/codec/bitmap.h
-include/freerdp2/freerdp/codec/bulk.h
-include/freerdp2/freerdp/codec/clear.h
-include/freerdp2/freerdp/codec/color.h
-include/freerdp2/freerdp/codec/dsp.h
-include/freerdp2/freerdp/codec/h264.h
-include/freerdp2/freerdp/codec/interleaved.h
-include/freerdp2/freerdp/codec/jpeg.h
-include/freerdp2/freerdp/codec/mppc.h
-include/freerdp2/freerdp/codec/ncrush.h
-include/freerdp2/freerdp/codec/nsc.h
-include/freerdp2/freerdp/codec/planar.h
-include/freerdp2/freerdp/codec/progressive.h
-include/freerdp2/freerdp/codec/region.h
-include/freerdp2/freerdp/codec/rfx.h
-include/freerdp2/freerdp/codec/xcrush.h
-include/freerdp2/freerdp/codec/yuv.h
-include/freerdp2/freerdp/codec/zgfx.h
-include/freerdp2/freerdp/codecs.h
-include/freerdp2/freerdp/constants.h
-include/freerdp2/freerdp/crypto/ber.h
-include/freerdp2/freerdp/crypto/certificate.h
-include/freerdp2/freerdp/crypto/crypto.h
-include/freerdp2/freerdp/crypto/der.h
-include/freerdp2/freerdp/crypto/er.h
-include/freerdp2/freerdp/crypto/per.h
-include/freerdp2/freerdp/crypto/tls.h
-include/freerdp2/freerdp/display.h
-include/freerdp2/freerdp/dvc.h
-include/freerdp2/freerdp/error.h
-include/freerdp2/freerdp/event.h
-include/freerdp2/freerdp/extension.h
-include/freerdp2/freerdp/freerdp.h
-include/freerdp2/freerdp/gdi/bitmap.h
-include/freerdp2/freerdp/gdi/dc.h
-include/freerdp2/freerdp/gdi/gdi.h
-include/freerdp2/freerdp/gdi/gfx.h
-include/freerdp2/freerdp/gdi/pen.h
-include/freerdp2/freerdp/gdi/region.h
-include/freerdp2/freerdp/gdi/shape.h
-include/freerdp2/freerdp/gdi/video.h
-include/freerdp2/freerdp/graphics.h
-include/freerdp2/freerdp/heartbeat.h
-include/freerdp2/freerdp/input.h
-include/freerdp2/freerdp/license.h
-include/freerdp2/freerdp/listener.h
-include/freerdp2/freerdp/locale/keyboard.h
-include/freerdp2/freerdp/locale/locale.h
-include/freerdp2/freerdp/log.h
-include/freerdp2/freerdp/message.h
-include/freerdp2/freerdp/metrics.h
-include/freerdp2/freerdp/peer.h
-include/freerdp2/freerdp/pointer.h
-include/freerdp2/freerdp/primary.h
-include/freerdp2/freerdp/primitives.h
-include/freerdp2/freerdp/rail.h
-include/freerdp2/freerdp/scancode.h
-include/freerdp2/freerdp/secondary.h
-include/freerdp2/freerdp/server/ainput.h
-include/freerdp2/freerdp/server/audin.h
-include/freerdp2/freerdp/server/channels.h
-include/freerdp2/freerdp/server/cliprdr.h
-include/freerdp2/freerdp/server/disp.h
-include/freerdp2/freerdp/server/drdynvc.h
-include/freerdp2/freerdp/server/echo.h
-include/freerdp2/freerdp/server/encomsp.h
-include/freerdp2/freerdp/server/rail.h
-include/freerdp2/freerdp/server/rdpdr.h
-include/freerdp2/freerdp/server/rdpecam-enumerator.h
-include/freerdp2/freerdp/server/rdpecam.h
-include/freerdp2/freerdp/server/rdpei.h
-include/freerdp2/freerdp/server/rdpgfx.h
-include/freerdp2/freerdp/server/rdpsnd.h
-include/freerdp2/freerdp/server/remdesk.h
-include/freerdp2/freerdp/server/server-common.h
-include/freerdp2/freerdp/server/shadow.h
-include/freerdp2/freerdp/server/telemetry.h
-include/freerdp2/freerdp/session.h
-include/freerdp2/freerdp/settings.h
-include/freerdp2/freerdp/svc.h
-include/freerdp2/freerdp/types.h
-include/freerdp2/freerdp/update.h
-include/freerdp2/freerdp/utils/cliprdr_utils.h
-include/freerdp2/freerdp/utils/passphrase.h
-include/freerdp2/freerdp/utils/pcap.h
-include/freerdp2/freerdp/utils/profiler.h
-include/freerdp2/freerdp/utils/ringbuffer.h
-include/freerdp2/freerdp/utils/signal.h
-include/freerdp2/freerdp/utils/stopwatch.h
-include/freerdp2/freerdp/utils/string.h
-include/freerdp2/freerdp/version.h
-include/freerdp2/freerdp/window.h
+include/freerdp%%MAJORVERSION%%/freerdp/addin.h
+include/freerdp%%MAJORVERSION%%/freerdp/altsec.h
+include/freerdp%%MAJORVERSION%%/freerdp/api.h
+include/freerdp%%MAJORVERSION%%/freerdp/assistance.h
+include/freerdp%%MAJORVERSION%%/freerdp/autodetect.h
+include/freerdp%%MAJORVERSION%%/freerdp/build-config.h
+include/freerdp%%MAJORVERSION%%/freerdp/cache/bitmap.h
+include/freerdp%%MAJORVERSION%%/freerdp/cache/brush.h
+include/freerdp%%MAJORVERSION%%/freerdp/cache/cache.h
+include/freerdp%%MAJORVERSION%%/freerdp/cache/glyph.h
+include/freerdp%%MAJORVERSION%%/freerdp/cache/nine_grid.h
+include/freerdp%%MAJORVERSION%%/freerdp/cache/offscreen.h
+include/freerdp%%MAJORVERSION%%/freerdp/cache/palette.h
+include/freerdp%%MAJORVERSION%%/freerdp/cache/pointer.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/ainput.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/audin.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/channels.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/cliprdr.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/disp.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/echo.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/encomsp.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/geometry.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/log.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/rail.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/rdpdr.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/rdpecam.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/rdpei.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/rdpgfx.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/rdpsnd.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/remdesk.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/telemetry.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/tsmf.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/urbdrc.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/video.h
+include/freerdp%%MAJORVERSION%%/freerdp/channels/wtsvc.h
+include/freerdp%%MAJORVERSION%%/freerdp/client.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/ainput.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/audin.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/channels.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/cliprdr.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/cmdline.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/disp.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/drdynvc.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/encomsp.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/file.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/geometry.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/printer.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/rail.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/rdpei.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/rdpgfx.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/rdpsnd.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/remdesk.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/sshagent.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/tsmf.h
+include/freerdp%%MAJORVERSION%%/freerdp/client/video.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/audio.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/bitmap.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/bulk.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/clear.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/color.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/dsp.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/h264.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/interleaved.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/jpeg.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/mppc.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/ncrush.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/nsc.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/planar.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/progressive.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/region.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/rfx.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/xcrush.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/yuv.h
+include/freerdp%%MAJORVERSION%%/freerdp/codec/zgfx.h
+include/freerdp%%MAJORVERSION%%/freerdp/codecs.h
+include/freerdp%%MAJORVERSION%%/freerdp/constants.h
+include/freerdp%%MAJORVERSION%%/freerdp/crypto/ber.h
+include/freerdp%%MAJORVERSION%%/freerdp/crypto/certificate.h
+include/freerdp%%MAJORVERSION%%/freerdp/crypto/crypto.h
+include/freerdp%%MAJORVERSION%%/freerdp/crypto/der.h
+include/freerdp%%MAJORVERSION%%/freerdp/crypto/er.h
+include/freerdp%%MAJORVERSION%%/freerdp/crypto/per.h
+include/freerdp%%MAJORVERSION%%/freerdp/crypto/tls.h
+include/freerdp%%MAJORVERSION%%/freerdp/display.h
+include/freerdp%%MAJORVERSION%%/freerdp/dvc.h
+include/freerdp%%MAJORVERSION%%/freerdp/error.h
+include/freerdp%%MAJORVERSION%%/freerdp/event.h
+include/freerdp%%MAJORVERSION%%/freerdp/extension.h
+include/freerdp%%MAJORVERSION%%/freerdp/freerdp.h
+include/freerdp%%MAJORVERSION%%/freerdp/gdi/bitmap.h
+include/freerdp%%MAJORVERSION%%/freerdp/gdi/dc.h
+include/freerdp%%MAJORVERSION%%/freerdp/gdi/gdi.h
+include/freerdp%%MAJORVERSION%%/freerdp/gdi/gfx.h
+include/freerdp%%MAJORVERSION%%/freerdp/gdi/pen.h
+include/freerdp%%MAJORVERSION%%/freerdp/gdi/region.h
+include/freerdp%%MAJORVERSION%%/freerdp/gdi/shape.h
+include/freerdp%%MAJORVERSION%%/freerdp/gdi/video.h
+include/freerdp%%MAJORVERSION%%/freerdp/graphics.h
+include/freerdp%%MAJORVERSION%%/freerdp/heartbeat.h
+include/freerdp%%MAJORVERSION%%/freerdp/input.h
+include/freerdp%%MAJORVERSION%%/freerdp/license.h
+include/freerdp%%MAJORVERSION%%/freerdp/listener.h
+include/freerdp%%MAJORVERSION%%/freerdp/locale/keyboard.h
+include/freerdp%%MAJORVERSION%%/freerdp/locale/locale.h
+include/freerdp%%MAJORVERSION%%/freerdp/log.h
+include/freerdp%%MAJORVERSION%%/freerdp/message.h
+include/freerdp%%MAJORVERSION%%/freerdp/metrics.h
+include/freerdp%%MAJORVERSION%%/freerdp/peer.h
+include/freerdp%%MAJORVERSION%%/freerdp/pointer.h
+include/freerdp%%MAJORVERSION%%/freerdp/primary.h
+include/freerdp%%MAJORVERSION%%/freerdp/primitives.h
+include/freerdp%%MAJORVERSION%%/freerdp/rail.h
+include/freerdp%%MAJORVERSION%%/freerdp/scancode.h
+include/freerdp%%MAJORVERSION%%/freerdp/secondary.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/ainput.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/audin.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/channels.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/cliprdr.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/disp.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/drdynvc.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/echo.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/encomsp.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/rail.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/rdpdr.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/rdpecam-enumerator.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/rdpecam.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/rdpei.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/rdpgfx.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/rdpsnd.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/remdesk.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/server-common.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/shadow.h
+include/freerdp%%MAJORVERSION%%/freerdp/server/telemetry.h
+include/freerdp%%MAJORVERSION%%/freerdp/session.h
+include/freerdp%%MAJORVERSION%%/freerdp/settings.h
+include/freerdp%%MAJORVERSION%%/freerdp/svc.h
+include/freerdp%%MAJORVERSION%%/freerdp/types.h
+include/freerdp%%MAJORVERSION%%/freerdp/update.h
+include/freerdp%%MAJORVERSION%%/freerdp/utils/cliprdr_utils.h
+include/freerdp%%MAJORVERSION%%/freerdp/utils/passphrase.h
+include/freerdp%%MAJORVERSION%%/freerdp/utils/pcap.h
+include/freerdp%%MAJORVERSION%%/freerdp/utils/profiler.h
+include/freerdp%%MAJORVERSION%%/freerdp/utils/ringbuffer.h
+include/freerdp%%MAJORVERSION%%/freerdp/utils/signal.h
+include/freerdp%%MAJORVERSION%%/freerdp/utils/stopwatch.h
+include/freerdp%%MAJORVERSION%%/freerdp/utils/string.h
+include/freerdp%%MAJORVERSION%%/freerdp/version.h
+include/freerdp%%MAJORVERSION%%/freerdp/window.h
%%WAYLAND%%include/uwac0/uwac/uwac-tools.h
%%WAYLAND%%include/uwac0/uwac/uwac.h
-include/winpr2/winpr/asn1.h
-include/winpr2/winpr/assert.h
-include/winpr2/winpr/bcrypt.h
-include/winpr2/winpr/bitstream.h
-include/winpr2/winpr/clipboard.h
-include/winpr2/winpr/cmdline.h
-include/winpr2/winpr/collections.h
-include/winpr2/winpr/comm.h
-include/winpr2/winpr/credentials.h
-include/winpr2/winpr/credui.h
-include/winpr2/winpr/crt.h
-include/winpr2/winpr/crypto.h
-include/winpr2/winpr/custom-crypto.h
-include/winpr2/winpr/debug.h
-include/winpr2/winpr/dsparse.h
-include/winpr2/winpr/endian.h
-include/winpr2/winpr/environment.h
-include/winpr2/winpr/error.h
-include/winpr2/winpr/file.h
-include/winpr2/winpr/handle.h
-include/winpr2/winpr/heap.h
-include/winpr2/winpr/image.h
-include/winpr2/winpr/ini.h
-include/winpr2/winpr/input.h
-include/winpr2/winpr/interlocked.h
-include/winpr2/winpr/intrin.h
-include/winpr2/winpr/io.h
-include/winpr2/winpr/library.h
-include/winpr2/winpr/locale.h
-include/winpr2/winpr/memory.h
-include/winpr2/winpr/midl.h
-include/winpr2/winpr/ndr.h
-include/winpr2/winpr/nt.h
-include/winpr2/winpr/ntlm.h
-include/winpr2/winpr/pack.h
-include/winpr2/winpr/path.h
-include/winpr2/winpr/pipe.h
-include/winpr2/winpr/platform.h
-include/winpr2/winpr/pool.h
-include/winpr2/winpr/print.h
-include/winpr2/winpr/registry.h
-include/winpr2/winpr/rpc.h
-include/winpr2/winpr/sam.h
-include/winpr2/winpr/schannel.h
-include/winpr2/winpr/security.h
-include/winpr2/winpr/shell.h
-include/winpr2/winpr/smartcard.h
-include/winpr2/winpr/spec.h
-include/winpr2/winpr/ssl.h
-include/winpr2/winpr/sspi.h
-include/winpr2/winpr/sspicli.h
-include/winpr2/winpr/stream.h
-include/winpr2/winpr/string.h
-include/winpr2/winpr/strlst.h
-include/winpr2/winpr/synch.h
-include/winpr2/winpr/sysinfo.h
-include/winpr2/winpr/tchar.h
-include/winpr2/winpr/thread.h
-include/winpr2/winpr/timezone.h
-include/winpr2/winpr/tools/makecert.h
-include/winpr2/winpr/user.h
-include/winpr2/winpr/version.h
-include/winpr2/winpr/wincrypt.h
-include/winpr2/winpr/windows.h
-include/winpr2/winpr/winhttp.h
-include/winpr2/winpr/winpr.h
-include/winpr2/winpr/winsock.h
-include/winpr2/winpr/wlog.h
-include/winpr2/winpr/wnd.h
-include/winpr2/winpr/wtsapi.h
-include/winpr2/winpr/wtypes.h
-lib/libfreerdp-client2.so
-lib/libfreerdp-client2.so.%%MAJORVERSION%%
-lib/libfreerdp-client2.so.%%PATCHVERSION%%
-lib/libfreerdp2.so
-lib/libfreerdp2.so.%%MAJORVERSION%%
-lib/libfreerdp2.so.%%PATCHVERSION%%
+include/winpr%%MAJORVERSION%%/winpr/asn1.h
+include/winpr%%MAJORVERSION%%/winpr/assert.h
+include/winpr%%MAJORVERSION%%/winpr/bcrypt.h
+include/winpr%%MAJORVERSION%%/winpr/bitstream.h
+include/winpr%%MAJORVERSION%%/winpr/clipboard.h
+include/winpr%%MAJORVERSION%%/winpr/cmdline.h
+include/winpr%%MAJORVERSION%%/winpr/collections.h
+include/winpr%%MAJORVERSION%%/winpr/comm.h
+include/winpr%%MAJORVERSION%%/winpr/credentials.h
+include/winpr%%MAJORVERSION%%/winpr/credui.h
+include/winpr%%MAJORVERSION%%/winpr/crt.h
+include/winpr%%MAJORVERSION%%/winpr/crypto.h
+include/winpr%%MAJORVERSION%%/winpr/custom-crypto.h
+include/winpr%%MAJORVERSION%%/winpr/debug.h
+include/winpr%%MAJORVERSION%%/winpr/dsparse.h
+include/winpr%%MAJORVERSION%%/winpr/endian.h
+include/winpr%%MAJORVERSION%%/winpr/environment.h
+include/winpr%%MAJORVERSION%%/winpr/error.h
+include/winpr%%MAJORVERSION%%/winpr/file.h
+include/winpr%%MAJORVERSION%%/winpr/handle.h
+include/winpr%%MAJORVERSION%%/winpr/heap.h
+include/winpr%%MAJORVERSION%%/winpr/image.h
+include/winpr%%MAJORVERSION%%/winpr/ini.h
+include/winpr%%MAJORVERSION%%/winpr/input.h
+include/winpr%%MAJORVERSION%%/winpr/interlocked.h
+include/winpr%%MAJORVERSION%%/winpr/intrin.h
+include/winpr%%MAJORVERSION%%/winpr/io.h
+include/winpr%%MAJORVERSION%%/winpr/library.h
+include/winpr%%MAJORVERSION%%/winpr/locale.h
+include/winpr%%MAJORVERSION%%/winpr/memory.h
+include/winpr%%MAJORVERSION%%/winpr/midl.h
+include/winpr%%MAJORVERSION%%/winpr/ndr.h
+include/winpr%%MAJORVERSION%%/winpr/nt.h
+include/winpr%%MAJORVERSION%%/winpr/ntlm.h
+include/winpr%%MAJORVERSION%%/winpr/pack.h
+include/winpr%%MAJORVERSION%%/winpr/path.h
+include/winpr%%MAJORVERSION%%/winpr/pipe.h
+include/winpr%%MAJORVERSION%%/winpr/platform.h
+include/winpr%%MAJORVERSION%%/winpr/pool.h
+include/winpr%%MAJORVERSION%%/winpr/print.h
+include/winpr%%MAJORVERSION%%/winpr/registry.h
+include/winpr%%MAJORVERSION%%/winpr/rpc.h
+include/winpr%%MAJORVERSION%%/winpr/sam.h
+include/winpr%%MAJORVERSION%%/winpr/schannel.h
+include/winpr%%MAJORVERSION%%/winpr/security.h
+include/winpr%%MAJORVERSION%%/winpr/shell.h
+include/winpr%%MAJORVERSION%%/winpr/smartcard.h
+include/winpr%%MAJORVERSION%%/winpr/spec.h
+include/winpr%%MAJORVERSION%%/winpr/ssl.h
+include/winpr%%MAJORVERSION%%/winpr/sspi.h
+include/winpr%%MAJORVERSION%%/winpr/sspicli.h
+include/winpr%%MAJORVERSION%%/winpr/stream.h
+include/winpr%%MAJORVERSION%%/winpr/string.h
+include/winpr%%MAJORVERSION%%/winpr/strlst.h
+include/winpr%%MAJORVERSION%%/winpr/synch.h
+include/winpr%%MAJORVERSION%%/winpr/sysinfo.h
+include/winpr%%MAJORVERSION%%/winpr/tchar.h
+include/winpr%%MAJORVERSION%%/winpr/thread.h
+include/winpr%%MAJORVERSION%%/winpr/timezone.h
+include/winpr%%MAJORVERSION%%/winpr/tools/makecert.h
+include/winpr%%MAJORVERSION%%/winpr/user.h
+include/winpr%%MAJORVERSION%%/winpr/version.h
+include/winpr%%MAJORVERSION%%/winpr/wincrypt.h
+include/winpr%%MAJORVERSION%%/winpr/windows.h
+include/winpr%%MAJORVERSION%%/winpr/winhttp.h
+include/winpr%%MAJORVERSION%%/winpr/winpr.h
+include/winpr%%MAJORVERSION%%/winpr/winsock.h
+include/winpr%%MAJORVERSION%%/winpr/wlog.h
+include/winpr%%MAJORVERSION%%/winpr/wnd.h
+include/winpr%%MAJORVERSION%%/winpr/wtsapi.h
+include/winpr%%MAJORVERSION%%/winpr/wtypes.h
+lib/libfreerdp-client%%MAJORVERSION%%.so
+lib/libfreerdp-client%%MAJORVERSION%%.so.%%MAJORVERSION%%
+lib/libfreerdp-client%%MAJORVERSION%%.so.%%PATCHVERSION%%
+lib/libfreerdp%%MAJORVERSION%%.so
+lib/libfreerdp%%MAJORVERSION%%.so.%%MAJORVERSION%%
+lib/libfreerdp%%MAJORVERSION%%.so.%%PATCHVERSION%%
%%WAYLAND%%lib/libuwac0.so
%%WAYLAND%%lib/libuwac0.so.0
%%WAYLAND%%lib/libuwac0.so.0.2.0
-lib/libwinpr-tools2.so
-lib/libwinpr-tools2.so.%%MAJORVERSION%%
-lib/libwinpr-tools2.so.%%PATCHVERSION%%
-lib/libwinpr2.so
-lib/libwinpr2.so.%%MAJORVERSION%%
-lib/libwinpr2.so.%%PATCHVERSION%%
-libdata/pkgconfig/freerdp-client2.pc
-libdata/pkgconfig/freerdp2.pc
+lib/libwinpr-tools%%MAJORVERSION%%.so
+lib/libwinpr-tools%%MAJORVERSION%%.so.%%MAJORVERSION%%
+lib/libwinpr-tools%%MAJORVERSION%%.so.%%PATCHVERSION%%
+lib/libwinpr%%MAJORVERSION%%.so
+lib/libwinpr%%MAJORVERSION%%.so.%%MAJORVERSION%%
+lib/libwinpr%%MAJORVERSION%%.so.%%PATCHVERSION%%
+libdata/pkgconfig/freerdp-client%%MAJORVERSION%%.pc
+libdata/pkgconfig/freerdp%%MAJORVERSION%%.pc
%%WAYLAND%%libdata/pkgconfig/uwac0.pc
-libdata/pkgconfig/winpr-tools2.pc
-libdata/pkgconfig/winpr2.pc
-%%MANPAGES%%man/man1/winpr-hash.1.gz
-%%MANPAGES%%man/man1/winpr-makecert.1.gz
-%%WAYLAND%%%%MANPAGES%%man/man1/wlfreerdp.1.gz
-%%X11%%%%MANPAGES%%man/man1/xfreerdp.1.gz
-%%MANPAGES%%man/man7/wlog.7.gz
-share/cmake/Modules/FreeRDP-Client2/FreeRDP-ClientConfig.cmake
-share/cmake/Modules/FreeRDP-Client2/FreeRDP-ClientConfigVersion.cmake
-share/cmake/Modules/FreeRDP-Client2/FreeRDP-ClientTargets-%%CMAKE_BUILD_TYPE%%.cmake
-share/cmake/Modules/FreeRDP-Client2/FreeRDP-ClientTargets.cmake
-share/cmake/Modules/FreeRDP2/FreeRDPConfig.cmake
-share/cmake/Modules/FreeRDP2/FreeRDPConfigVersion.cmake
-share/cmake/Modules/FreeRDP2/FreeRDPTargets-%%CMAKE_BUILD_TYPE%%.cmake
-share/cmake/Modules/FreeRDP2/FreeRDPTargets.cmake
-share/cmake/Modules/WinPR2/WinPRConfig.cmake
-share/cmake/Modules/WinPR2/WinPRConfigVersion.cmake
-share/cmake/Modules/WinPR2/WinPRTargets-%%CMAKE_BUILD_TYPE%%.cmake
-share/cmake/Modules/WinPR2/WinPRTargets.cmake
+libdata/pkgconfig/winpr-tools%%MAJORVERSION%%.pc
+libdata/pkgconfig/winpr%%MAJORVERSION%%.pc
+%%MANPAGES%%share/man/man1/winpr-hash.1.gz
+%%MANPAGES%%share/man/man1/winpr-makecert.1.gz
+%%WAYLAND%%%%MANPAGES%%share/man/man1/wlfreerdp.1.gz
+%%X11%%%%MANPAGES%%share/man/man1/xfreerdp.1.gz
+%%MANPAGES%%share/man/man7/wlog.7.gz
+share/cmake/Modules/FreeRDP-Client%%MAJORVERSION%%/FreeRDP-ClientConfig.cmake
+share/cmake/Modules/FreeRDP-Client%%MAJORVERSION%%/FreeRDP-ClientConfigVersion.cmake
+share/cmake/Modules/FreeRDP-Client%%MAJORVERSION%%/FreeRDP-ClientTargets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/Modules/FreeRDP-Client%%MAJORVERSION%%/FreeRDP-ClientTargets.cmake
+share/cmake/Modules/FreeRDP%%MAJORVERSION%%/FreeRDPConfig.cmake
+share/cmake/Modules/FreeRDP%%MAJORVERSION%%/FreeRDPConfigVersion.cmake
+share/cmake/Modules/FreeRDP%%MAJORVERSION%%/FreeRDPTargets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/Modules/FreeRDP%%MAJORVERSION%%/FreeRDPTargets.cmake
+share/cmake/Modules/WinPR%%MAJORVERSION%%/WinPRConfig.cmake
+share/cmake/Modules/WinPR%%MAJORVERSION%%/WinPRConfigVersion.cmake
+share/cmake/Modules/WinPR%%MAJORVERSION%%/WinPRTargets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/Modules/WinPR%%MAJORVERSION%%/WinPRTargets.cmake
%%WAYLAND%%share/cmake/Modules/uwac0/uwac-%%CMAKE_BUILD_TYPE%%.cmake
%%WAYLAND%%share/cmake/Modules/uwac0/uwac.cmake
%%WAYLAND%%share/cmake/Modules/uwac0/uwacConfig.cmake