aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-07 07:13:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-07 09:01:56 +0000
commit8e495468ab83b5d30e6cca138c06d7b8c4db5a45 (patch)
treee865c1d061cfe342d1833e8824abccad6a48217f
parent17dc1dd8747711c5431e93943440b8a009df8e0d (diff)
downloadports-8e495468ab83b5d30e6cca138c06d7b8c4db5a45.tar.gz
ports-8e495468ab83b5d30e6cca138c06d7b8c4db5a45.zip
misc/py-uhi: New port: Universal Histogram Interface
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-uhi/Makefile28
-rw-r--r--misc/py-uhi/distinfo3
-rw-r--r--misc/py-uhi/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 113fc9cf8b6d..95c2ec66f9ae 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -425,6 +425,7 @@
SUBDIR += py-toil
SUBDIR += py-tqdm
SUBDIR += py-tvm
+ SUBDIR += py-uhi
SUBDIR += py-wurlitzer
SUBDIR += py-xgboost
SUBDIR += pyobd
diff --git a/misc/py-uhi/Makefile b/misc/py-uhi/Makefile
new file mode 100644
index 000000000000..6877d59ce0dc
--- /dev/null
+++ b/misc/py-uhi/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= uhi
+DISTVERSION= 0.3.1
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Universal Histogram Interface
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boost-histogram>=1.0:misc/py-boost-histogram@${PY_FLAVOR}
+
+USES= compiler:c++14-lang python:3.8+
+USE_PYTHON= distutils autoplist pytest
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+pre-configure: # uhi is officially built with "build" (https://github.com/pypa/build), but this is easily circumvented with this simple setup.py
+ @( \
+ ${ECHO} "from setuptools import setup" && \
+ ${ECHO} "setup()" \
+ ) > ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/misc/py-uhi/distinfo b/misc/py-uhi/distinfo
new file mode 100644
index 000000000000..6ecc831e33fc
--- /dev/null
+++ b/misc/py-uhi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1659855534
+SHA256 (uhi-0.3.1.tar.gz) = 6f1ebcadd1d0628337a30b012184325618047abc01c3539538b1655c69101d91
+SIZE (uhi-0.3.1.tar.gz) = 11158
diff --git a/misc/py-uhi/pkg-descr b/misc/py-uhi/pkg-descr
new file mode 100644
index 000000000000..ce461cbd87f9
--- /dev/null
+++ b/misc/py-uhi/pkg-descr
@@ -0,0 +1,6 @@
+UHI is a library that helps connect other Histogramming libraries. It is
+primarily indented to be a guide and static type check helper; you do not need
+an runtime dependency on UHI.
+
+WWW: https://uhi.readthedocs.io/en/latest/
+WWW: https://github.com/Scikit-HEP/uhi