aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 19:35:59 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 19:35:59 +0000
commit8f009815d35cfb5de7ae11d543b9bfd8426f2821 (patch)
tree92113d2013e0f536ef6c7ae8a96bddd70e2dfe84
parent37f835916cbed3979f3ea424d23e4ec592b8c6d7 (diff)
downloadports-8f009815d35cfb5de7ae11d543b9bfd8426f2821.tar.gz
ports-8f009815d35cfb5de7ae11d543b9bfd8426f2821.zip
www/py-httpbin: Fix runtime with py-werkzeug 2.1.0+
- Bump PORTREVISION for package change With hat: python
-rw-r--r--www/py-httpbin/Makefile1
-rw-r--r--www/py-httpbin/files/patch-httpbin-core.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/py-httpbin/Makefile b/www/py-httpbin/Makefile
index 13c34c7ba23a..d9610bd1b674 100644
--- a/www/py-httpbin/Makefile
+++ b/www/py-httpbin/Makefile
@@ -1,5 +1,6 @@
PORTNAME= httpbin
PORTVERSION= 0.7.0
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-httpbin/files/patch-httpbin-core.py b/www/py-httpbin/files/patch-httpbin-core.py
new file mode 100644
index 000000000000..61f342b9188f
--- /dev/null
+++ b/www/py-httpbin/files/patch-httpbin-core.py
@@ -0,0 +1,11 @@
+--- httpbin/core.py.orig 2018-05-08 11:41:03 UTC
++++ httpbin/core.py
+@@ -19,7 +19,7 @@ from flask import Flask, Response, request, render_tem
+ from six.moves import range as xrange
+ from werkzeug.datastructures import WWWAuthenticate, MultiDict
+ from werkzeug.http import http_date
+-from werkzeug.wrappers import BaseResponse
++from werkzeug.wrappers import Response as BaseResponse
+ from werkzeug.http import parse_authorization_header
+ from raven.contrib.flask import Sentry
+