aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-06-08 22:04:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-06-08 22:05:44 +0000
commit8f9452cdbb42dc86adfea23a7e2e3059caf937ee (patch)
treed9e8a1101ebe72285386c15a3ac3c8f781be4704
parent2f35021c7eb14764673ae4c44eae97551b68ebf5 (diff)
downloadports-8f9452cdbb42dc86adfea23a7e2e3059caf937ee.tar.gz
ports-8f9452cdbb42dc86adfea23a7e2e3059caf937ee.zip
audio/plasma5-plasma-pa: switch to gsettings backend
Remove dependency on gconf and make use of the more modern gsettings backend [1]. Reported by: bapt [1] https://invent.kde.org/plasma/plasma-pa/-/commit/36d6eb9c2bac53cc6653b4aa45a1ac42f0ce68c7
-rw-r--r--audio/plasma5-plasma-pa/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/plasma5-plasma-pa/Makefile b/audio/plasma5-plasma-pa/Makefile
index 9ce13f697c3e..390e9d2968fd 100644
--- a/audio/plasma5-plasma-pa/Makefile
+++ b/audio/plasma5-plasma-pa/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-pa
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= audio kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,7 @@ LIB_DEPENDS= libcanberra.so:audio/libcanberra \
USES= cmake compiler:c++11-lib gettext gnome kde:5 pkgconfig qt:5 \
shebangfix tar:xz
-USE_GNOME= gconf2
+USE_GNOME= glib20
USE_KDE= config configwidgets coreaddons ecm globalaccel i18n \
kdeclarative notifications package plasma-framework \
doctools_build
@@ -18,5 +19,6 @@ USE_QT= core dbus declarative gui network widgets \
buildtools_build qmake_build
SHEBANG_FILES= data/plasmaVolumeDisableKMixAutostart.pl
+CMAKE_OFF= USE_GCONF
.include <bsd.port.mk>