aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2024-07-24 21:43:13 +0000
committerMatthias Andree <mandree@FreeBSD.org>2024-07-24 21:43:50 +0000
commit8fb732c3c77fc3f6a689f2c36f6c558f57cedac9 (patch)
tree30660a218da874192aee149dbb2e0bbdc8812be1
parent8f1d7d33d68e46f5c01443f5689c4b1cf3d9786a (diff)
archivers/py-borgbackup: clean up 1.4.0 upgrade fallout
- Mark broken on FreeBSD 13 due to https://github.com/borgbackup/borg/issues/8269 which upstream maintainer intends to fix for borgbackup 1.4.1 (milestone). Reported by "Support SimpleRezo" in direct e-mail message. - Add UPDATING entry. The broken MOVED entry has been removed by sunpoet@ already, Reported by: Juraj Lutter <otis@>, freebsd@rail.eu.org PR: 280424 - Move py-pkgconfig to BUILD_DEPENDS to fix build failures in poudriere or on bare metal if py-pkgconfig isn't installed. Reported by: Juraj Lutter <otis@>, Hyogeol Lee <hyogeollee@gmail.com> (patch) PR: 280413
-rw-r--r--UPDATING17
-rw-r--r--archivers/py-borgbackup/Makefile6
2 files changed, 21 insertions, 2 deletions
diff --git a/UPDATING b/UPDATING
index 1cf96e29c93e..b7a2281d0b74 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,23 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20240724:
+ AFFECTS: users of archivers/py-borgbackup
+ AUTHOR: mandree@FreeBSD.org
+
+ Borgbackup has been upgraded to version 1.4.0, which does not yet
+ support FreeBSD 13.x, see https://github.com/borgbackup/borg/issues/8269
+
+ For users who are on FreeBSD 13, or who wish to continue using
+ version 1.2, use either of these commands for upgrading:
+
+ With binary packages through pkg:
+ pkg set -o archivers/py-borgbackup:archivers/py-borgbackup12
+ pkg upgrade
+
+ With portmaster or portupgrade (replace the command accordingly):
+ portmaster -o archivers/py-borgbackup12 archivers/py-borgbackup
+
20240723:
AFFECTS: users of databases/postgresql* and other software using PostgreSQL to run
AUTHOR: kbowling@FreeBSD.org
diff --git a/archivers/py-borgbackup/Makefile b/archivers/py-borgbackup/Makefile
index 34be7f812f9a..774f1033d9cf 100644
--- a/archivers/py-borgbackup/Makefile
+++ b/archivers/py-borgbackup/Makefile
@@ -12,9 +12,12 @@ WWW= https://pypi.org/project/borgbackup/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_FreeBSD_13= uses acl_extended_link_np, see https://github.com/borgbackup/borg/issues/8269
+
# note that borgbackup pins the msgpack version range per patchlevel version!
_BB_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>=1.0.2<1.1.0:devel/py-msgpack@${PY_FLAVOR}
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=1.7:devel/py-setuptools-scm@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pkgconfig>=0:devel/py-pkgconfig@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=1.7:devel/py-setuptools-scm@${PY_FLAVOR} \
${_BB_DEPENDS}
LIB_DEPENDS= liblz4.so:archivers/liblz4 \
libzstd.so:archivers/zstd \
@@ -24,7 +27,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=19.0:devel/py-packaging@${PY_FLAV
TEST_DEPENDS= ${RUN_DEPENDS} \
${PYTHON_PKGNAMEPREFIX}tox>3.2:devel/py-tox@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}virtualenv>=0:devel/py-virtualenv@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pkgconfig>=0:devel/py-pkgconfig@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR} \
fakeroot:security/fakeroot
USES= pkgconfig python:3.9+ ssl