aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-04-23 16:50:27 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-04-23 16:54:27 +0000
commit9015b311995ac418bc0a96e3c365ad57d057c6ae (patch)
tree957a8c745c9ff792da4168cf6053d4b4a5bed527
parent398794808864948a1969acce9bf189ea7b88a693 (diff)
downloadports-9015b311995ac418bc0a96e3c365ad57d057c6ae.tar.gz
ports-9015b311995ac418bc0a96e3c365ad57d057c6ae.zip
archivers/file-roller: Add missing dependencies and fix build when NAUTILUS off
Poudriere reports two linked libraries missing from file-roller dependencies. The one on libhandy causes it to fail to build when the NAUTILUS option is disabled. The libhandy library happens to be already installed by nautilus when that is present as a dependency, but the port fails to find it when nautilus and its dependencies are not already present in the system or poudriere jail at build time. Reported by: poudriere QA testing Approved by: portmgr (fixit blanket)
-rw-r--r--archivers/file-roller/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index a6389bf9ed9b..fbde8cbe9a81 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -15,14 +15,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= itstool:textproc/itstool
LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
- libnotify.so:devel/libnotify
+ libnotify.so:devel/libnotify \
+ libhandy-1.so:x11-toolkits/libhandy
RUN_DEPENDS= gtar:archivers/gtar
PORTSCOUT= limitw:1,even
USES= cpe desktop-file-utils gettext gnome libarchive localbase \
meson pkgconfig python:3.5+,build tar:xz
-USE_GNOME= cairo gtk30
+USE_GNOME= cairo gdkpixbuf2 gtk30
USE_LDCONFIG= yes
MESON_ARGS= -Dpackagekit=false
BINARY_ALIAS= python3=${PYTHON_VERSION}