aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2024-06-18 13:17:57 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2024-06-18 13:17:57 +0000
commit905388dcd28eb1f6d9140ff14e20d89083a71545 (patch)
tree796da09f6fe04ffecb90bbf0f11568b5e5c7eef3
parent726e7a61059e315715063818e98ed62e8ad21f37 (diff)
net/netatalk3: Fix some build issues
* Port a patch from the autoconf world to find the right BDB version * Correct a Meson argument to use disabled instead of false
-rw-r--r--net/netatalk3/Makefile11
-rw-r--r--net/netatalk3/files/patch-meson.build16
2 files changed, 17 insertions, 10 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index eecc32512471..7f8d9f6056eb 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -1,5 +1,6 @@
PORTNAME= netatalk
PORTVERSION= 3.2.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/netatalk-${PORTVERSION:S/./-/g}/
@@ -83,14 +84,12 @@ CONFLICTS= jday yudit # bin/dbd man/man1/uniconv.1.gz
.if ${PORT_OPTIONS:MAVAHI}=="" && ${PORT_OPTIONS:MMDNSRESPONDER}==""
SUB_LIST+= ZEROCONF=""
-MESON_ARGS+=-Denable-zeroconf=false
+MESON_ARGS+=-Denable-zeroconf=disabled
.endif
-#post-patch:
-# @${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
-# s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
-# s|%%LOCALBASE%%|${LOCALBASE}|g' \
-# ${WRKSRC}/configure
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}|' \
+ ${WRKSRC}/meson.build
# @${REINPLACE_CMD} -e 's|\.dist|\.sample|g' \
# ${WRKSRC}/config/Makefile.in
# @${REINPLACE_CMD} -e 's|%%PYTHONCMD%%|${PYTHONCMD}|' \
diff --git a/net/netatalk3/files/patch-meson.build b/net/netatalk3/files/patch-meson.build
index da457a0f49d6..ce0550a44aab 100644
--- a/net/netatalk3/files/patch-meson.build
+++ b/net/netatalk3/files/patch-meson.build
@@ -17,7 +17,15 @@
############
# Includes #
-@@ -487,6 +488,11 @@ if crypt.found()
+@@ -367,6 +368,7 @@ bdb_subdirs = [
+ '/usr',
+ ]
+ bdb_subdirs = [
++ '%%DB_NAME%%',
+ 'db4.6',
+ 'db4.7',
+ 'db4.8',
+@@ -487,6 +489,11 @@ if crypt.found()
if crypt.found()
cdata.set('HAVE_CRYPT_H', 1)
cdata.set('HAVE_LIBCRYPT', 1)
@@ -29,7 +37,7 @@
endif
des = cc.find_library('des', required: false)
-@@ -763,19 +769,7 @@ else
+@@ -763,19 +770,7 @@ else
required: false,
)
@@ -50,7 +58,7 @@
cdata.set('HAVE_TRACKER3', 1)
cdata.set(
'TRACKER_MANAGING_COMMAND',
-@@ -816,15 +810,16 @@ else
+@@ -816,15 +811,16 @@ else
endif
endif
endif
@@ -70,7 +78,7 @@
if have_spotlight
cdata.set('WITH_SPOTLIGHT', 1)
endif
-@@ -1833,6 +1828,8 @@ int deny_severity = 0;
+@@ -1833,6 +1829,8 @@ int deny_severity = 0;
tcpwrap_code = '''
int allow_severity = 0;
int deny_severity = 0;