aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2022-05-01 06:53:06 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2022-05-01 06:55:55 +0000
commit90de298b222ab8b74c707c26af21d59547898ab5 (patch)
tree39d099677a1f25c3fb4b080ae51670be7e0bf01e
parent09562717d7f4040993258c14e70d364313f92292 (diff)
downloadports-90de298b222ab8b74c707c26af21d59547898ab5.tar.gz
ports-90de298b222ab8b74c707c26af21d59547898ab5.zip
Mk/bsd.java.mk: Fix JAVA_VERSION matching
Anchor the matched patterns to be at the beginning of each word to prevent unexpected surprises e.g. with JAVA_VERSION= 17+ it results in _JAVA_VERSION set to unexpected "17 8 11 12 13 14 15 16 17 18", instead of "17 18" PR: 263483 Reported by: jrm Reviewed by: glewis Approved by: glewis
-rw-r--r--Mk/bsd.java.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.java.mk b/Mk/bsd.java.mk
index 4833fab43c8a..a88204514650 100644
--- a/Mk/bsd.java.mk
+++ b/Mk/bsd.java.mk
@@ -285,7 +285,7 @@ JAVA_RUN= jre
. undef _JAVA_PORTS_INSTALLED
. undef _JAVA_PORTS_POSSIBLE
. if defined(JAVA_VERSION)
-_JAVA_VERSION= ${JAVA_VERSION:S/1.7+/1.7 1.8+/:S/1.8+/1.8 11+/:S/1.7/7/:S/1.8/8/:S/7+/7 8+/:S/8+/8 11+/:S/11+/11 12+/:S/12+/12 13+/:S/13+/13 14+/:S/14+/14 15+/:S/15+/15 16+/:S/16+/16 17+/:S/17+/17 18+/:S/18+/18/}
+_JAVA_VERSION= ${JAVA_VERSION:S/^1.7+/1.7 1.8+/:S/^1.8+/1.8 11+/:S/^1.7/7/:S/^1.8/8/:S/^7+/7 8+/:S/^8+/8 11+/:S/^11+/11 12+/:S/^12+/12 13+/:S/^13+/13 14+/:S/^14+/14 15+/:S/^15+/15 16+/:S/^16+/16 17+/:S/^17+/17 18+/:S/^18+/18/}
. else
_JAVA_VERSION= ${__JAVA_VERSION_LIST}
. endif