aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2022-08-19 22:26:29 +0000
committerRomain Tartière <romain@FreeBSD.org>2022-08-20 00:13:34 +0000
commit914541c1f3ffcf8ef7559ce59e17b33cee85e752 (patch)
tree3c6a00242ef21a1b3744181da60a84b293f21faa
parent27b36c974b34abadcf0d42d0bac0ed9c6db61451 (diff)
downloadports-914541c1f3ffcf8ef7559ce59e17b33cee85e752.tar.gz
ports-914541c1f3ffcf8ef7559ce59e17b33cee85e752.zip
textproc/opensearch: Install plugins config files
PR: 265704 Reported by: acm
-rw-r--r--textproc/opensearch/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/textproc/opensearch/Makefile b/textproc/opensearch/Makefile
index 925b0517ec59..62a68bec938c 100644
--- a/textproc/opensearch/Makefile
+++ b/textproc/opensearch/Makefile
@@ -37,6 +37,37 @@ OPTIONS_DEFAULT=PLUGINS
CONFIG_FILES= opensearch.yml jvm.options log4j2.properties
+PLUGINS_CONFIG_FILES= \
+ opensearch-notifications-core/notifications-core.yml \
+ opensearch-notifications/notifications.yml \
+ opensearch-observability/observability.yml \
+ opensearch-performance-analyzer/agent-stats-metadata \
+ opensearch-performance-analyzer/log4j2.xml \
+ opensearch-performance-analyzer/opensearch_security.policy \
+ opensearch-performance-analyzer/performance-analyzer.properties \
+ opensearch-performance-analyzer/plugin-stats-metadata \
+ opensearch-performance-analyzer/rca.conf \
+ opensearch-performance-analyzer/rca_idle_master.conf \
+ opensearch-performance-analyzer/rca_master.conf \
+ opensearch-performance-analyzer/supervisord.conf \
+ opensearch-reports-scheduler/reports-scheduler.yml \
+ opensearch-security/action_groups.yml \
+ opensearch-security/allowlist.yml \
+ opensearch-security/audit.yml \
+ opensearch-security/config.yml \
+ opensearch-security/internal_users.yml \
+ opensearch-security/nodes_dn.yml \
+ opensearch-security/roles.yml \
+ opensearch-security/roles_mapping.yml \
+ opensearch-security/tenants.yml \
+ opensearch-security/whitelist.yml
+
+# Upstream provide some *.example files. These are also copied as sample filse
+# but we do not register them as @sample to avoid installing filse that needs
+# to be tuned a site specific way.
+PLUGINS_SAMPLE_CONFIG_FILES= \
+ opensearch-security/opensearch.yml
+
BINS= opensearch opensearch-cli opensearch-env \
opensearch-env-from-file opensearch-keystore \
opensearch-node opensearch-plugin \
@@ -70,6 +101,20 @@ do-install:
${LN} -s ${JAVASHAREDIR}/classes/jna.jar ${STAGEDIR}${PREFIX}/lib/opensearch/lib/jna.jar
do-install-PLUGINS-on:
+ ${MKDIR} ${STAGEDIR}${ETCDIR}/opensearch-notifications-core \
+ ${STAGEDIR}${ETCDIR}/opensearch-notifications \
+ ${STAGEDIR}${ETCDIR}/opensearch-observability \
+ ${STAGEDIR}${ETCDIR}/opensearch-performance-analyzer \
+ ${STAGEDIR}${ETCDIR}/opensearch-reports-scheduler \
+ ${STAGEDIR}${ETCDIR}/opensearch-security
+.for f in ${PLUGINS_CONFIG_FILES}
+ ${INSTALL} ${WRKSRC}/config/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
+ ${ECHO} "@sample ${ETCDIR}/${f}.sample" >> ${TMPPLIST}
+.endfor
+.for f in ${PLUGINS_SAMPLE_CONFIG_FILES}
+ ${INSTALL} ${WRKSRC}/config/${f}.example ${STAGEDIR}${ETCDIR}/${f}.sample
+ ${ECHO} "${ETCDIR}/${f}.sample" >> ${TMPPLIST}
+.endfor
(cd ${WRKSRC}/ && ${COPYTREE_SHARE} "plugins" ${STAGEDIR}${PREFIX}/lib/opensearch/)
(cd ${WRKSRC}/plugins/opensearch-security/tools && ${COPYTREE_BIN} "*.sh" ${STAGEDIR}${PREFIX}/lib/opensearch/plugins/opensearch-security/tools)