aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2021-09-06 19:09:21 +0000
committerXin LI <delphij@FreeBSD.org>2021-09-06 19:09:22 +0000
commit91966715bcf3989bd7c96e5910f0a83952eecdc6 (patch)
treede065b9bc17bd748e369f911ec3d37232492ed65
parent210a5da8ef9c632adaf5d33b3839e3806295fa89 (diff)
net/openldap2[45]-server: Fix PKGBASE collision.
-rw-r--r--net/openldap24-server/Makefile7
-rw-r--r--net/openldap25-server/Makefile7
2 files changed, 8 insertions, 6 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 211a6a82933b..a36363a23d6d 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -17,9 +17,9 @@ MASTER_SITES= https://www.openldap.org/software/download/OpenLDAP/%SUBDIR%/ \
http://www.openldap.org/software/download/OpenLDAP/%SUBDIR%/
MASTER_SITE_SUBDIR= openldap-release
.if defined(CLIENT_ONLY)
-PKGNAMESUFFIX= -client
+PKGNAMESUFFIX= 24-client
.else
-PKGNAMESUFFIX= -server
+PKGNAMESUFFIX= 24-server
.endif
MAINTAINER= delphij@FreeBSD.org
@@ -34,7 +34,8 @@ LICENSE_NAME= OpenLDAP Public License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-2.[0-35-9].*
+CONFLICTS_INSTALL= ${PORTNAME}2[0-3][5-9]-client-* ${PORTNAME}-client-* \
+ ${PORTNAME}2[0-3][5-9]-server-* ${PORTNAME}-server-*
GNU_CONFIGURE= yes
# :keepla because port uses lt_dlopen
diff --git a/net/openldap25-server/Makefile b/net/openldap25-server/Makefile
index 3f637cb8ac75..56cf6d239df2 100644
--- a/net/openldap25-server/Makefile
+++ b/net/openldap25-server/Makefile
@@ -17,9 +17,9 @@ MASTER_SITES= https://www.openldap.org/software/download/OpenLDAP/%SUBDIR%/ \
http://www.openldap.org/software/download/OpenLDAP/%SUBDIR%/
MASTER_SITE_SUBDIR= openldap-release
.if defined(CLIENT_ONLY)
-PKGNAMESUFFIX= -client
+PKGNAMESUFFIX= 25-client
.else
-PKGNAMESUFFIX= -server
+PKGNAMESUFFIX= 25-server
.endif
MAINTAINER= delphij@FreeBSD.org
@@ -37,7 +37,8 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
# :keepla because port uses lt_dlopen
USES= cpe gmake libtool:keepla localbase ssl tar:tgz
-CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-2.[0-46-9].*
+CONFLICTS_INSTALL= ${PORTNAME}2[0-46-9]-client-* ${PORTNAME}-client-* \
+ ${PORTNAME}2[0-46-9]-server-* ${PORTNAME}-server-*
GNU_CONFIGURE= yes