aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-05-21 11:30:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-05-21 11:33:54 +0000
commit93715fdbe16f18738c781d0ed73ce96a09fae239 (patch)
tree7dc70baf8b416a7e461591d7688bb9619d24084d
parent24fc27804829353381987dc8b6af1ce8379726c4 (diff)
downloadports-93715fdbe16f18738c781d0ed73ce96a09fae239.tar.gz
ports-93715fdbe16f18738c781d0ed73ce96a09fae239.zip
graphics/goocanvas: the port had been improved (+)
- Define LICENSE (LGPL20) - Do not manually set CPPFLAGS and LDFLAGS, USES+=localbase does the job nicely and is only needed in the NLS case anyways - Convert to option helpers and INSTALL_TARGET=install-strip - Fix documentation path (/usr/local/share/doc/goocanvas/goocanvas -> /usr/local/share/doc/goocanvas)
-rw-r--r--graphics/goocanvas/Makefile30
1 files changed, 10 insertions, 20 deletions
diff --git a/graphics/goocanvas/Makefile b/graphics/goocanvas/Makefile
index 5e57bc7066fa..6d1a87fa89ef 100644
--- a/graphics/goocanvas/Makefile
+++ b/graphics/goocanvas/Makefile
@@ -1,5 +1,4 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
-# $MCom: ports/trunk/graphics/goocanvas/Makefile 17268 2013-04-01 05:13:11Z marcus $
PORTNAME= goocanvas
PORTVERSION= 1.0.0
@@ -10,6 +9,8 @@ MASTER_SITES= GNOME
MAINTAINER= kwm@FreeBSD.org
COMMENT= Canvas widget for GTK+
+LICENSE= LGPL20
+
PORTSCOUT= ignore:1
LIB_DEPENDS= libfreetype.so:print/freetype2 \
@@ -19,35 +20,24 @@ USES= gnome libtool pathfix pkgconfig tar:bzip2
USE_GNOME= cairo gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
LIBS= -lm
PORTDOCS= *
OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_USES= gettext localbase
post-patch:
- @${REINPLACE_CMD} -e 's|$${datadir}/gtk-doc/html|${DOCSDIR}|' \
+ @${REINPLACE_CMD} -e 's|$${datadir}/gtk-doc/html|${DOCSDIR:H}|' \
${WRKSRC}/configure
-.if ! ${PORT_OPTIONS:MDOCS}
+
+post-patch-DOCS-off:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|docs||g' ${WRKSRC}/Makefile.in
-.endif
-.if ! ${PORT_OPTIONS:MNLS}
- @${REINPLACE_CMD} -e '/^SUBDIRS/s|po||g' ${WRKSRC}/Makefile.in
-.endif
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgoocanvas.so.*
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|po||g' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>