aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 10:34:36 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-04-27 12:01:44 +0000
commit947cc0959eb798fb353dbc6096f53233631fd57d (patch)
tree829763d2ca6631ab0aefcc10556a072cc8d75c05
parent5e7e1a221158b95a1a5ae90009b0cfb429bfcdab (diff)
downloadports-947cc0959eb798fb353dbc6096f53233631fd57d.tar.gz
ports-947cc0959eb798fb353dbc6096f53233631fd57d.zip
audio/spek: Update to 0.8.5
Fixes build with FFmpeg 6 Changelog: https://github.com/alexkay/spek/releases/tag/v0.8.5 PR: 270193 Approved by: portmgr (maintainer timeout, 1+ month)
-rw-r--r--audio/spek/Makefile15
-rw-r--r--audio/spek/distinfo5
-rw-r--r--audio/spek/files/patch-src_spek-audio.cc58
-rw-r--r--audio/spek/pkg-plist14
4 files changed, 22 insertions, 70 deletions
diff --git a/audio/spek/Makefile b/audio/spek/Makefile
index d71e1e24fe63..55e0baae5ee2 100644
--- a/audio/spek/Makefile
+++ b/audio/spek/Makefile
@@ -1,8 +1,7 @@
PORTNAME= spek
-PORTVERSION= 0.8.2
-PORTREVISION= 18
+DISTVERSION= 0.8.5
CATEGORIES= audio
-MASTER_SITES= https://github.com/alexkay/${PORTNAME}/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/alexkay/${PORTNAME}/releases/download/v${DISTVERSION}/
MAINTAINER= alexander@kojevnikov.com
COMMENT= Acoustic spectrum analyser
@@ -12,10 +11,10 @@ LICENSE= GPLv3+
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-USES= compiler:c++11-lib desktop-file-utils gmake gnome pkgconfig \
- tar:xz
+USES= compiler:c++11-lib desktop-file-utils gmake gnome \
+ localbase:ldflags pkgconfig tar:xz
USE_GNOME= intltool
-USE_WX= 3.0
+USE_WX= 3.2+
WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
@@ -24,8 +23,4 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-post-patch:
- @${REINPLACE_CMD} -e "s,^itlocaledir =.*$$,itlocaledir = ${PREFIX}/share/locale,g" \
- ${WRKSRC}/po/Makefile.in.in
-
.include <bsd.port.mk>
diff --git a/audio/spek/distinfo b/audio/spek/distinfo
index dbbfeb6bc6bf..be19f0b996ac 100644
--- a/audio/spek/distinfo
+++ b/audio/spek/distinfo
@@ -1,2 +1,3 @@
-SHA256 (spek-0.8.2.tar.xz) = 59f69b41155ee1a4552eb9f66b602fc059de8f31e3f05889f24d362b3e6c78ae
-SIZE (spek-0.8.2.tar.xz) = 171628
+TIMESTAMP = 1678742866
+SHA256 (spek-0.8.5.tar.xz) = 1bccf85a14a01af8f2f30476cbad004e8bf6031f500e562bbe5bbd1e5eb16c59
+SIZE (spek-0.8.5.tar.xz) = 430464
diff --git a/audio/spek/files/patch-src_spek-audio.cc b/audio/spek/files/patch-src_spek-audio.cc
deleted file mode 100644
index b2fa0fad9051..000000000000
--- a/audio/spek/files/patch-src_spek-audio.cc
+++ /dev/null
@@ -1,58 +0,0 @@
-Fix build with ffmpeg 3.x.
-
---- src/spek-audio.cc.orig 2016-12-28 01:32:07 UTC
-+++ src/spek-audio.cc
-@@ -199,7 +199,7 @@ AudioFileImpl::AudioFileImpl(
- this->packet.data = nullptr;
- this->packet.size = 0;
- this->offset = 0;
-- this->frame = avcodec_alloc_frame();
-+ this->frame = av_frame_alloc();
- this->buffer_size = 0;
- this->buffer = nullptr;
- this->frames_per_interval = 0;
-@@ -215,7 +215,7 @@ AudioFileImpl::~AudioFileImpl()
- if (this->frame) {
- // TODO: Remove this check after Debian switches to libav 9.
- #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(54, 28, 0)
-- avcodec_free_frame(&this->frame);
-+ av_frame_free(&this->frame);
- #else
- av_freep(&this->frame);
- #endif
-@@ -224,7 +224,7 @@ AudioFileImpl::~AudioFileImpl()
- this->packet.data -= this->offset;
- this->packet.size += this->offset;
- this->offset = 0;
-- av_free_packet(&this->packet);
-+ av_packet_unref(&this->packet);
- }
- if (this->format_context) {
- if (this->audio_stream >= 0) {
-@@ -255,7 +255,7 @@ int AudioFileImpl::read()
-
- for (;;) {
- while (this->packet.size > 0) {
-- avcodec_get_frame_defaults(this->frame);
-+ av_frame_unref(this->frame);
- auto codec_context = this->format_context->streams[this->audio_stream]->codec;
- int got_frame = 0;
- int len = avcodec_decode_audio4(codec_context, this->frame, &got_frame, &this->packet);
-@@ -299,7 +299,7 @@ int AudioFileImpl::read()
- this->packet.data -= this->offset;
- this->packet.size += this->offset;
- this->offset = 0;
-- av_free_packet(&this->packet);
-+ av_packet_unref(&this->packet);
- }
-
- int res = 0;
-@@ -307,7 +307,7 @@ int AudioFileImpl::read()
- if (this->packet.stream_index == this->audio_stream) {
- break;
- }
-- av_free_packet(&this->packet);
-+ av_packet_unref(&this->packet);
- }
- if (res < 0) {
- // End of file or error.
diff --git a/audio/spek/pkg-plist b/audio/spek/pkg-plist
index 7800824366ea..c4ec36e35814 100644
--- a/audio/spek/pkg-plist
+++ b/audio/spek/pkg-plist
@@ -7,21 +7,35 @@ share/icons/hicolor/24x24/apps/spek.png
share/icons/hicolor/32x32/apps/spek.png
share/icons/hicolor/48x48/apps/spek.png
share/icons/hicolor/scalable/apps/spek.svg
+%%NLS%%share/locale/bs/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/spek.mo
%%NLS%%share/locale/cs/LC_MESSAGES/spek.mo
%%NLS%%share/locale/da/LC_MESSAGES/spek.mo
%%NLS%%share/locale/de/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/el/LC_MESSAGES/spek.mo
%%NLS%%share/locale/eo/LC_MESSAGES/spek.mo
%%NLS%%share/locale/es/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/spek.mo
%%NLS%%share/locale/fr/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/he/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/spek.mo
%%NLS%%share/locale/it/LC_MESSAGES/spek.mo
%%NLS%%share/locale/ja/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/spek.mo
%%NLS%%share/locale/nb/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/spek.mo
%%NLS%%share/locale/nl/LC_MESSAGES/spek.mo
%%NLS%%share/locale/pl/LC_MESSAGES/spek.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/spek.mo
%%NLS%%share/locale/ru/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/spek.mo
%%NLS%%share/locale/sv/LC_MESSAGES/spek.mo
%%NLS%%share/locale/tr/LC_MESSAGES/spek.mo
+%%NLS%%share/locale/th/LC_MESSAGES/spek.mo
%%NLS%%share/locale/uk/LC_MESSAGES/spek.mo
%%NLS%%share/locale/vi/LC_MESSAGES/spek.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/spek.mo