aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-03-18 14:02:34 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-03-18 14:07:48 +0000
commit94c3887a35b0154dd3eacfcbe6c05a419984d1e8 (patch)
treeb9349c1cf51c7238be5c03414be97589ec6fe042
parent3885e25f6a019eaa52549deac6bb4de260a15d5f (diff)
downloadports-94c3887a35b0154dd3eacfcbe6c05a419984d1e8.tar.gz
ports-94c3887a35b0154dd3eacfcbe6c05a419984d1e8.zip
multimedia/gstreamer1-libav: drop broken FFMPEG=off after e3b732b4791c
meson.build:21:0: ERROR: Neither a subproject directory nor a FFmpeg.wrap file was found. This reverts commit 15b98e4752ce0e01d31d21102fa325f30ae59668.
-rw-r--r--multimedia/gstreamer1-libav/Makefile18
1 files changed, 2 insertions, 16 deletions
diff --git a/multimedia/gstreamer1-libav/Makefile b/multimedia/gstreamer1-libav/Makefile
index 69c00c29f4d0..ab189229e585 100644
--- a/multimedia/gstreamer1-libav/Makefile
+++ b/multimedia/gstreamer1-libav/Makefile
@@ -12,7 +12,8 @@ LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= orc>=0.4.16:devel/orc
-LIB_DEPENDS= liborc-0.4.so:devel/orc
+LIB_DEPENDS= liborc-0.4.so:devel/orc \
+ libavcodec.so:multimedia/ffmpeg
PORTSCOUT= limitw:1,even
@@ -22,19 +23,4 @@ USE_GNOME= glib20
BINARY_ALIAS= python3=${PYTHON_VERSION}
-OPTIONS_DEFINE= FFMPEG
-OPTIONS_DEFAULT=FFMPEG
-
-FFMPEG_DESC?= Use system ffmpeg instead of internal libav
-FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-FFMPEG_BUILD_DEPENDS_OFF= nasm:devel/nasm
-FFMPEG_MAKE_ENV_OFF= V=1
-FFMPEG_VARS_OFF+= NOPRECIOUSMAKEVARS=yes # ARCH
-
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MFFMPEG)
-LDFLAGS_aarch64= -Wl,-z,notext
-.endif
-
.include <bsd.port.mk>