aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-11 09:24:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-11 09:24:45 +0000
commit94d91d836101c1736238f4341b4f7a107d1f70c8 (patch)
tree738f338e045971b47c52e882e50f37b4a1b422ad
parent3f5859f965d967ab552d57549746abb2a7520b87 (diff)
downloadports-94d91d836101c1736238f4341b4f7a107d1f70c8.tar.gz
ports-94d91d836101c1736238f4341b4f7a107d1f70c8.zip
science/helfem: New port: Finite element methods for electronic structure calculations
-rw-r--r--science/Makefile1
-rw-r--r--science/helfem/Makefile26
-rw-r--r--science/helfem/distinfo3
-rw-r--r--science/helfem/pkg-descr7
-rw-r--r--science/helfem/pkg-plist16
5 files changed, 53 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 9cbe4c3e8c10..ce30460b050e 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -104,6 +104,7 @@
SUBDIR += hdf5
SUBDIR += hdf5-18
SUBDIR += healpix
+ SUBDIR += helfem
SUBDIR += hepmc3
SUBDIR += highfive
SUBDIR += hypre
diff --git a/science/helfem/Makefile b/science/helfem/Makefile
new file mode 100644
index 000000000000..211a0022a6cd
--- /dev/null
+++ b/science/helfem/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= helfem
+DISTVERSION= g20210807
+CATEGORIES= science # chemistry
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Finite element methods for electronic structure calculations
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libarmadillo.so:math/armadillo \
+ libgsl.so:math/gsl \
+ libhdf5_cpp.so:science/hdf5 \
+ libsz.so:science/szip \
+ libxc.so:science/libxc
+
+USES= cmake fortran
+
+USE_GITHUB= yes
+GH_ACCOUNT= susilehtola
+GH_PROJECT= HelFEM
+GH_TAGNAME= b6d8c11
+
+CMAKE_ON= HELFEM_FIND_DEPS # BUILD_SHARED_LIBS is broken, see https://github.com/susilehtola/HelFEM/issues/5
+
+.include <bsd.port.mk>
diff --git a/science/helfem/distinfo b/science/helfem/distinfo
new file mode 100644
index 000000000000..be7d72dabd75
--- /dev/null
+++ b/science/helfem/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1631350867
+SHA256 (susilehtola-HelFEM-g20210807-b6d8c11_GH0.tar.gz) = 76b96ca133ddc59fdce8509b10165027990d7165c66345c1cdb34a32c7ca95b4
+SIZE (susilehtola-HelFEM-g20210807-b6d8c11_GH0.tar.gz) = 1020761
diff --git a/science/helfem/pkg-descr b/science/helfem/pkg-descr
new file mode 100644
index 000000000000..85e68f749413
--- /dev/null
+++ b/science/helfem/pkg-descr
@@ -0,0 +1,7 @@
+HelFEM is a suite of programs for finite element calculations on atoms and
+diatomic molecules at the Hartree-Fock or density-functional levels of theory.
+Hundreds of functionals at the local spin density approximation (LDA),
+generalized gradient approximation (GGA), and meta-GGA levels of theory are
+supported.
+
+WWW: https://github.com/susilehtola/HelFEM
diff --git a/science/helfem/pkg-plist b/science/helfem/pkg-plist
new file mode 100644
index 000000000000..fa1a1c370223
--- /dev/null
+++ b/science/helfem/pkg-plist
@@ -0,0 +1,16 @@
+bin/atomic
+bin/diatomic
+bin/diatomic_cbasis
+bin/diatomic_cpl
+bin/gensap
+bin/libhelfem-common.a
+bin/liblegendre.a
+include/helfem.h
+include/helfem/GaussianNucleus.h
+include/helfem/HollowNucleus.h
+include/helfem/ModelPotential.h
+include/helfem/PointNucleus.h
+include/helfem/PolynomialBasis.h
+include/helfem/RadialBasis.h
+include/helfem/SphericalNucleus.h
+lib/libhelfem.a