aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2023-12-14 13:23:02 +0000
committerWen Heping <wen@FreeBSD.org>2023-12-14 13:23:02 +0000
commit9528b6a977333c0a41d2f8ada19e84f1d25fef43 (patch)
tree6c87b8a9f95d36ce1af31e2b0013bc66de0f1a22
parent6be6a29caea68a67ee76cf1d0fb04f29124a5835 (diff)
downloadports-9528b6a977333c0a41d2f8ada19e84f1d25fef43.tar.gz
ports-9528b6a977333c0a41d2f8ada19e84f1d25fef43.zip
devel/thonny: Add missing RUN_DEPENDS
PR: 275759 Reported by: scott.wl.furry@gmail.com
-rw-r--r--devel/thonny/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/thonny/Makefile b/devel/thonny/Makefile
index 6a3350695805..ce024cbaf0dd 100644
--- a/devel/thonny/Makefile
+++ b/devel/thonny/Makefile
@@ -1,5 +1,6 @@
PORTNAME= thonny
PORTVERSION= 4.1.4
+PORTREVISION= 1
CATEGORIES= devel education python
MASTER_SITES= PYPI
PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
@@ -19,7 +20,9 @@ RUN_DEPENDS= pylint:devel/pylint@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyserial>=3.4:comms/py-pyserial@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}send2trash>=1.5:deskutils/py-send2trash@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}asttokens>=2.0:devel/py-asttokens@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pip>=0:devel/py-pip@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist distutils