aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2024-04-13 00:34:24 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2024-04-13 00:34:24 +0000
commit95302c50e0525b3833ce50c0627c16f2231ac076 (patch)
tree2d01af33ce97a026b29e2476a609fc439f6aabfb
parent13ec17ffdddf23e89dd183bb7b3967ea9ce945e5 (diff)
downloadports-95302c50e0525b3833ce50c0627c16f2231ac076.tar.gz
ports-95302c50e0525b3833ce50c0627c16f2231ac076.zip
www/py-scrapy: Update to 2.11.1
Changelog: https://docs.scrapy.org/en/latest/news.html#scrapy-2-11-1-2024-02-14 PR: 277729 Approved by: skreuzer (maintainer)
-rw-r--r--www/py-scrapy/Makefile21
-rw-r--r--www/py-scrapy/distinfo6
-rw-r--r--www/py-scrapy/files/patch-setup.py19
3 files changed, 11 insertions, 35 deletions
diff --git a/www/py-scrapy/Makefile b/www/py-scrapy/Makefile
index a5669dfa555d..e66fe26420b1 100644
--- a/www/py-scrapy/Makefile
+++ b/www/py-scrapy/Makefile
@@ -1,6 +1,5 @@
PORTNAME= Scrapy
-DISTVERSION= 2.5.1
-PORTREVISION= 1
+DISTVERSION= 2.11.1
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,27 +11,23 @@ WWW= https://scrapy.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cssselect>=0.9.1:www/py-cssselect@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=18.9.0:devel/py-twisted@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cssselect>=0.9.1:www/py-cssselect@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}itemloaders>=1.0.1:devel/py-itemloaders@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}parsel>=1.5:textproc/py-parsel@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}openssl>=16.2.0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=21.0.0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}queuelib>=1.4.2:sysutils/py-queuelib@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service-identity>=16.0.0:security/py-service-identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=18.1.0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}w3lib>=1.17.0:www/py-w3lib@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}zope.interface>=4.1.3:devel/py-zope.interface@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=5.1.0:devel/py-zope.interface@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}protego>=0.1.15:www/py-protego@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}itemadapter>=0.1.0:devel/py-itemadapter@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}lxml>=3.5.0:devel/py-lxml@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pydispatcher>=2.0.5:devel/py-pydispatcher@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}lxml>=4.4.1:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tldextract>0:dns/py-tldextract@${PY_FLAVOR}
USES= cpe python
USE_PYTHON= autoplist concurrent cryptography distutils
NO_ARCH= yes
-# Remove experimental HTTP/2 support, issues with Twisted and h2
-post-extract:
- @${RM} -r ${WRKSRC}/scrapy/core/http2
- @${RM} ${WRKSRC}/scrapy/core/downloader/handlers/http2.py
-
.include <bsd.port.mk>
diff --git a/www/py-scrapy/distinfo b/www/py-scrapy/distinfo
index 881c8157d747..1a27f8f1880a 100644
--- a/www/py-scrapy/distinfo
+++ b/www/py-scrapy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1633530242
-SHA256 (Scrapy-2.5.1.tar.gz) = 13af6032476ab4256158220e530411290b3b934dd602bb6dacacbf6d16141f49
-SIZE (Scrapy-2.5.1.tar.gz) = 1072669
+TIMESTAMP = 1710200888
+SHA256 (Scrapy-2.11.1.tar.gz) = 733a039c7423e52b69bf2810b5332093d4e42a848460359c07b02ecff8f73ebe
+SIZE (Scrapy-2.11.1.tar.gz) = 1176726
diff --git a/www/py-scrapy/files/patch-setup.py b/www/py-scrapy/files/patch-setup.py
deleted file mode 100644
index 8571812fecc3..000000000000
--- a/www/py-scrapy/files/patch-setup.py
+++ /dev/null
@@ -1,19 +0,0 @@
-# Remove experimental HTTP/2 support, issues with Twisted and h2
---- setup.py.orig 2021-04-06 14:48:02 UTC
-+++ setup.py
-@@ -19,7 +19,6 @@ def has_environment_marker_platform_impl_support():
-
-
- install_requires = [
-- 'Twisted[http2]>=17.9.0',
- 'cryptography>=2.0',
- 'cssselect>=0.9.1',
- 'itemloaders>=1.0.1',
-@@ -31,7 +30,6 @@ install_requires = [
- 'zope.interface>=4.1.3',
- 'protego>=0.1.15',
- 'itemadapter>=0.1.0',
-- 'h2>=3.0,<4.0',
- ]
- extras_require = {}
- cpython_dependencies = [