aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2025-02-06 18:26:41 +0000
committerGleb Popov <arrowd@FreeBSD.org>2025-02-06 18:31:51 +0000
commit95bcd42a132b4a35ae06b5bc858e33c0f725710a (patch)
tree1d62eea385cd4a6423a8074b0b7921cb7f0c36ac
parent028c3098a24afaebecd97c91f279446b0149b469 (diff)
lang/dotnet[-runtime]: Revert "Use bundled libunwind in hope to avoiding random crashes"
The bundled libunwind performs no better and even worse, it seems. This reverts commit 6a69e4b5a8b407997e620cfe4e2b969cf274de9e.
-rw-r--r--lang/dotnet-runtime/Makefile1
-rw-r--r--lang/dotnet-runtime/files/patch-bundled-libunwind42
-rw-r--r--lang/dotnet/Makefile1
-rw-r--r--lang/dotnet/files/patch-bundled-libunwind42
4 files changed, 2 insertions, 84 deletions
diff --git a/lang/dotnet-runtime/Makefile b/lang/dotnet-runtime/Makefile
index 88474a6474f1..26c4f6acc5e7 100644
--- a/lang/dotnet-runtime/Makefile
+++ b/lang/dotnet-runtime/Makefile
@@ -1,6 +1,7 @@
PORTNAME= dotnet-host
DISTVERSIONPREFIX= v
DISTVERSION= 9.0.1
+PORTREVISION= 1
CATEGORIES= lang devel
MAINTAINER= arrowd@FreeBSD.org
diff --git a/lang/dotnet-runtime/files/patch-bundled-libunwind b/lang/dotnet-runtime/files/patch-bundled-libunwind
deleted file mode 100644
index 224365ac72d0..000000000000
--- a/lang/dotnet-runtime/files/patch-bundled-libunwind
+++ /dev/null
@@ -1,42 +0,0 @@
-Use bundled libunwind until at least
-
-https://github.com/libunwind/libunwind/issues/715
-
-is fixed. It is also believed that using bundled libunwind may help against
-random crashes on amd64 too.
-
---- src/native/corehost/apphost/static/CMakeLists.txt.orig
-+++ src/native/corehost/apphost/static/CMakeLists.txt
-@@ -244,7 +244,7 @@ endif(CLR_CMAKE_TARGET_APPLE)
-
- # On *BSD, we always use the libunwind that's part of the OS
- if(CLR_CMAKE_TARGET_FREEBSD)
-- set(CLR_CMAKE_USE_SYSTEM_LIBUNWIND 1)
-+ set(CLR_CMAKE_USE_SYSTEM_LIBUNWIND 0)
- endif()
-
- if(CLR_CMAKE_USE_SYSTEM_LIBUNWIND AND NOT CLR_CMAKE_TARGET_APPLE)
-
---- src/coreclr/pal/src/CMakeLists.txt.orig
-+++ src/coreclr/pal/src/CMakeLists.txt
-@@ -1,7 +1,7 @@
- if(CLR_CMAKE_TARGET_OSX OR CLR_CMAKE_TARGET_FREEBSD OR CLR_CMAKE_TARGET_HAIKU)
- # On OSX and *BSD, we use the libunwind that's part of the OS
- # On Haiku, we used a special port of libunwind
-- set(CLR_CMAKE_USE_SYSTEM_LIBUNWIND 1)
-+ set(CLR_CMAKE_USE_SYSTEM_LIBUNWIND 0)
- endif(CLR_CMAKE_TARGET_OSX OR CLR_CMAKE_TARGET_FREEBSD OR CLR_CMAKE_TARGET_HAIKU)
-
- if(NOT DEFINED ENV{ROOTFS_DIR})
-
---- src/native/external/libunwind.cmake.orig
-+++ src/native/external/libunwind.cmake
-@@ -96,7 +96,7 @@ elseif(CLR_CMAKE_TARGET_FREEBSD)
- set(libunwind_la_SOURCES_arm_os arm/Gos-freebsd.c)
- set(libunwind_la_SOURCES_arm_os_local arm/Los-freebsd.c)
- set(libunwind_la_SOURCES_aarch64_os aarch64/Gos-freebsd.c)
-- set(libunwind_la_SOURCES_aarch64_os_local aarch64/Los-freebsd.c)
-+ set(libunwind_la_SOURCES_aarch64_os_local aarch64/Los-freebsd.c aarch64/setcontext.S)
- list(APPEND libunwind_coredump_la_SOURCES coredump/_UCD_access_reg_freebsd.c)
- elseif(CLR_CMAKE_HOST_SUNOS)
- set(libunwind_la_SOURCES_os ${libunwind_la_SOURCES_os_solaris})
diff --git a/lang/dotnet/Makefile b/lang/dotnet/Makefile
index 1f8ad574c065..51e2f3725fd5 100644
--- a/lang/dotnet/Makefile
+++ b/lang/dotnet/Makefile
@@ -1,6 +1,7 @@
PORTNAME= dotnet
DISTVERSIONPREFIX= v
DISTVERSION= ${DOTNETVERSION}.1
+PORTREVISION= 1
CATEGORIES= lang devel
MASTER_SITES= https://github.com/dotnet/dotnet/releases/download/${DISTVERSIONPREFIX}${DISTVERSION}/release.json?dummy=/:dotnetmanifest \
https://github.com/sec/dotnet-core-freebsd-source-build/releases/download/9.0.0-rc.2-native/:bootstrap
diff --git a/lang/dotnet/files/patch-bundled-libunwind b/lang/dotnet/files/patch-bundled-libunwind
deleted file mode 100644
index 72082263884c..000000000000
--- a/lang/dotnet/files/patch-bundled-libunwind
+++ /dev/null
@@ -1,42 +0,0 @@
-Use bundled libunwind until at least
-
-https://github.com/libunwind/libunwind/issues/715
-
-is fixed. It is also believed that using bundled libunwind may help against
-random crashes on amd64 too.
-
---- src/runtime/src/native/corehost/apphost/static/CMakeLists.txt.orig
-+++ src/runtime/src/native/corehost/apphost/static/CMakeLists.txt
-@@ -244,7 +244,7 @@ endif(CLR_CMAKE_TARGET_APPLE)
-
- # On *BSD, we always use the libunwind that's part of the OS
- if(CLR_CMAKE_TARGET_FREEBSD)
-- set(CLR_CMAKE_USE_SYSTEM_LIBUNWIND 1)
-+ set(CLR_CMAKE_USE_SYSTEM_LIBUNWIND 0)
- endif()
-
- if(CLR_CMAKE_USE_SYSTEM_LIBUNWIND AND NOT CLR_CMAKE_TARGET_APPLE)
-
---- src/runtime/src/coreclr/pal/src/CMakeLists.txt.orig
-+++ src/runtime/src/coreclr/pal/src/CMakeLists.txt
-@@ -1,7 +1,7 @@
- if(CLR_CMAKE_TARGET_OSX OR CLR_CMAKE_TARGET_FREEBSD OR CLR_CMAKE_TARGET_HAIKU)
- # On OSX and *BSD, we use the libunwind that's part of the OS
- # On Haiku, we used a special port of libunwind
-- set(CLR_CMAKE_USE_SYSTEM_LIBUNWIND 1)
-+ set(CLR_CMAKE_USE_SYSTEM_LIBUNWIND 0)
- endif(CLR_CMAKE_TARGET_OSX OR CLR_CMAKE_TARGET_FREEBSD OR CLR_CMAKE_TARGET_HAIKU)
-
- if(NOT DEFINED ENV{ROOTFS_DIR})
-
---- src/runtime/src/native/external/libunwind.cmake.orig
-+++ src/runtime/src/native/external/libunwind.cmake
-@@ -96,7 +96,7 @@ elseif(CLR_CMAKE_TARGET_FREEBSD)
- set(libunwind_la_SOURCES_arm_os arm/Gos-freebsd.c)
- set(libunwind_la_SOURCES_arm_os_local arm/Los-freebsd.c)
- set(libunwind_la_SOURCES_aarch64_os aarch64/Gos-freebsd.c)
-- set(libunwind_la_SOURCES_aarch64_os_local aarch64/Los-freebsd.c)
-+ set(libunwind_la_SOURCES_aarch64_os_local aarch64/Los-freebsd.c aarch64/setcontext.S)
- list(APPEND libunwind_coredump_la_SOURCES coredump/_UCD_access_reg_freebsd.c)
- elseif(CLR_CMAKE_HOST_SUNOS)
- set(libunwind_la_SOURCES_os ${libunwind_la_SOURCES_os_solaris})