aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2021-12-12 23:35:39 +0000
committerSanthosh Raju <fox@FreeBSD.org>2021-12-12 23:44:03 +0000
commit9638c2b537873b8e21c1baae0985659cd22f38b1 (patch)
treedb2fec0a5c92cd446ff3655dbccb0321cd62d544
parentf52ce2807b99550bdd187a4f6dc96ca5882f2f44 (diff)
downloadports-9638c2b537873b8e21c1baae0985659cd22f38b1.tar.gz
ports-9638c2b537873b8e21c1baae0985659cd22f38b1.zip
audio/din: Update to 52
Changes since 51.1.1: DIN Is Noise 52: \ walked back some changes introduced in DIN 51 \ the drone tracked by gravity does not change when the selection changes \ renamed drone arrow parameter called Head to Neck /* new gravity size modulation for DIN 52 change the size (aka strength/magnitude) of gravity vector over bpm: on the gravity widget, turn on Modulate bpm = speed of gravity size modulation depth = how far to 0 gravity drops depth = 1, goes all the way to 0 and back in 1 beat depth = 0.5, goes from starting size to half size and back in 1 beat depth = 0, no size modulation ie size does not change at all default depth = 1 set an initial size using gravity presets or click on Change Size and move the mouse up or down. keep Modulate off when doing this. click Edit to edit the size modulation curve for interesting fx. /* + press q to toggle drone wanding when Menu > Drone Tools > Wand is selected ! was always in Add drone mode until DIN 51.x + optional tracking of drones when connecting them with Menu > Drone Tools > Connect + enable / disable @ Menu > Drone Tools > Track + if enabled on connection: drone 1 points to drone 2 points to drone 3 and so on + if disabled on disconnection: selected drones stop tracking any other drone + select drone on creation + Menu > Drone Params > Defaults > Select on Creation + drone is not selected by default + useful for looking at pitch/volume info of launched drones as they fly past + white = noise interpolator curve @ Menu > Editors > Noise Interpolator + white = drone that makes noise \ was grayscale in DIN 51.x + color of velocity vector of drone = color of drone \ was green in DIN51.x + constrain magnitude of drone velocity +/ acceleration to be > 0 + click on 0 checkbutton on the Menu > Drone Params > Motion > Velocity or Acceleration to toggle + if enabled, magnitude of velocity +/ acceleration will always be > 0 + if disabled, magnitude of velocity +/ acceleration can go < 0 ie will reverse movement or orbiting + browsed drone marker color is color of the browsed drone \ was green in DIN51.x * improved drone arrow drawing * improved note/frequency labeling on microtonal ranges * improved 'with left/center/right fixed' menu item on Menu > Ranges * new default volume distribution curve to have value increase (linearly) after 100% instead of staying at 100%. upto 200% now. * improved drone > < noise progress display <> moved (and renamed) Menu > Drone Params > Move under Gravity to Menu > Drone Tools > Balloon still does the same thing: releases (like gas balloons :) anchored drones these are now launched drones and die at the end of their lifetimes. <> moved Snap drones to notes / Position affects velocity from Menu > Drone Params > Motion to Menu > Drone Tools <> moved Bounces, rebound Speed% and drone bounce behaviour from Menu > Drone Params > Motion to Menu > Drone Params > Defaults as they apply equally to all launched drones * replaced drone Rise Time Min and Max spinners with a Rise time spinner + turn on ~ to generate a random rise time (default is 50% to 100% of Rise time) on drone creation + change range of randomness by editing %~ field * replaced drone Fall Time Min and Max spinners with a Fall time spinner + turn on ~ to generate a random fall time (default is 50% to 100% of Fall time) on drone removal + change range of randomness by editing %~ field + drones can bounce ahead, back or ahead/back + can select drones while voice phrasor plays + reinstated (from din-5.2.1 release!) a form of indian notation for notes + from Settings screen, choose notation = indian + a launched drone lifetime = lifetime of launcher or if ~ is active on Menu > Drone Params > Defaults > Lifetime a randomisation based on ~% of the lifetime of the launcher ! fixed bug when setting snap left/right values ! fixed mouse wheel scrolling of UI when hovering over label widget ! gravity continues tracking drone as its moved around or when scrolling microtonal keyboard
-rw-r--r--audio/din/Makefile2
-rw-r--r--audio/din/distinfo6
-rw-r--r--audio/din/files/patch-src_Makefile.am8
3 files changed, 8 insertions, 8 deletions
diff --git a/audio/din/Makefile b/audio/din/Makefile
index 31e59e34e670..d6711db6f690 100644
--- a/audio/din/Makefile
+++ b/audio/din/Makefile
@@ -1,5 +1,5 @@
PORTNAME= din
-PORTVERSION= 51.1.1
+PORTVERSION= 52
CATEGORIES= audio
MASTER_SITES= https://archive.org/download/dinisnoise_source_code/
diff --git a/audio/din/distinfo b/audio/din/distinfo
index c15169483ffa..61defaff6a75 100644
--- a/audio/din/distinfo
+++ b/audio/din/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1629545974
-SHA256 (din-51.1.1.tar.gz) = f679ead486e2a55ffef0acfd00e35d47642309acd1fd1400f64ae3c2c1d5b6e9
-SIZE (din-51.1.1.tar.gz) = 3700797
+TIMESTAMP = 1639304671
+SHA256 (din-52.tar.gz) = 22cb04592a17e3643258d783a2ec60b0dade51d2af35935511fbc54a97a00048
+SIZE (din-52.tar.gz) = 3706694
diff --git a/audio/din/files/patch-src_Makefile.am b/audio/din/files/patch-src_Makefile.am
index aff1faf5d1d8..c6962477df1e 100644
--- a/audio/din/files/patch-src_Makefile.am
+++ b/audio/din/files/patch-src_Makefile.am
@@ -1,15 +1,15 @@
Removed tcl8.6, asound and jack flags, this is now handled in the ports
script.
---- src/Makefile.am.orig 2021-07-12 01:15:59 UTC
+--- src/Makefile.am.orig 2021-12-04 02:58:55 UTC
+++ src/Makefile.am
@@ -1,7 +1,7 @@
#dinincludedir = $(pkgsrcdir)
--AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -D __BOOST_TIME__ -DPREFIX=\"@prefix@\"
+-AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
-LIBS += -ltcl8.6 -lSDL -lGL -lpthread -lasound
-+AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -D __BOOST_TIME__ -DPREFIX=\"@prefix@\"
++AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
+LIBS += -lSDL -lGL -lpthread -lasound
bin_PROGRAMS = din
- din_SOURCES = alarm.cc arrow_button.cc audio.cc authors_note.cc ball.cc ball_ops.cc basic_editor.cc beat2value.cc binaural_drone.cc binaural_drones.cc bit_display.cc box_selector.cc button.cc capturer.cc checkbutton.cc chrono.cc circler.cc command.cc compressor.cc console.cc console_iterator.cc countries.cc cross_button.cc curve.cc curve_display.cc curve_editor.cc curve_library.cc curve_mixer.cc curve_picker.cc curve_samples.cc custom_periodic.cc delay.cc din.cc din_info.cc drawrrow.cc drone.cc eval.cc fader.cc fft.cc field.cc filled_button.cc font.cc font_editor.cc fractaliser.cc globals.cc glyph.cc gravity.cc hit.cc help.cc item_list.cc keyboard_keyboard.cc label.cc levels.cc line.cc lissajous.cc listeners.cc main.cc menu.cc mesh.cc midi_in.cc minus_button.cc mocap.cc modulator.cc mondrian.cc morpher.cc morse_code.cc mouse_slider.cc multi_curve.cc note.cc noiser.cc number.cc oscilloscope.cc phrasor.cc play.cc plugin.cc plugin_browser.cc plus_button.cc point_modulator.cc range.cc recorder.cc rect.cc rose_milker.cc scale_info.cc scale_notes.cc scalelist.cc separator.cc settings.cc sine_mixer.cc slit.cc solver.cc spiraler.cc starrer.cc superformula.cc tap_bpm.cc tcl_interp.cc textboard.cc tokenizer.cc trail.cc triggered_note.cc ui.cc ui_sin_cos_radius.cc viewwin.cc warper.cc widget.cc kiss_fft.c RtAudio.cpp RtMidi.cpp
+ din_SOURCES = alarm.cc arrow_button.cc audio.cc authors_note.cc autoflip.cc autorotator.cc ball.cc ball_ops.cc basic_editor.cc beat2value.cc binaural_drone.cc binaural_drones.cc bit_display.cc box_selector.cc button.cc capturer.cc checkbutton.cc chrono.cc circler.cc command.cc compressor.cc console.cc console_iterator.cc countries.cc cross_button.cc curve.cc curve_display.cc curve_editor.cc curve_library.cc curve_mixer.cc curve_picker.cc curve_samples.cc custom_periodic.cc defvelaccel.cc delay.cc din.cc din_info.cc drawrrow.cc drone.cc eval.cc fader.cc fft.cc field.cc filled_button.cc font.cc font_editor.cc fractaliser.cc globals.cc glyph.cc gravity.cc hit.cc help.cc item_list.cc keyboard_keyboard.cc label.cc levels.cc line.cc lissajous.cc listeners.cc main.cc menu.cc mesh.cc midi_in.cc minus_button.cc mocap.cc modulator.cc mondrian.cc morpher.cc morse_code.cc mouse_slider.cc multi_curve.cc note.cc noiser.cc number.cc oscilloscope.cc phrasor.cc play.cc plugin.cc plugin_browser.cc plus_button.cc point_modulator.cc range.cc recorder.cc rect.cc rose_milker.cc scale_info.cc scale_notes.cc scalelist.cc separator.cc settings.cc sine_mixer.cc slit.cc solver.cc spiraler.cc starrer.cc superformula.cc tap_bpm.cc tcl_interp.cc textboard.cc tokenizer.cc trail.cc triggered_note.cc ui.cc ui_sin_cos_radius.cc viewwin.cc warper.cc widget.cc kiss_fft.c RtAudio.cpp RtMidi.cpp