aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Rozhuk <rozhuk.im@gmail.com>2021-07-02 09:26:40 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-07-02 09:26:40 +0000
commit9669d3437973d2961022efd38edfae4353a75406 (patch)
tree481f05c6072612d54e4bcd45337950fb6d215c96
parent730762a24c2449630dc43cab6a207e7ca0c4777b (diff)
downloadports-9669d3437973d2961022efd38edfae4353a75406.tar.gz
ports-9669d3437973d2961022efd38edfae4353a75406.zip
devel/py-ciso8601: New port
Fast ISO8601 date time parser for Python written in C. PR: 252072 Approved by: lwhsu (mentor)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ciso8601/Makefile16
-rw-r--r--devel/py-ciso8601/distinfo3
-rw-r--r--devel/py-ciso8601/pkg-descr8
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2a303d6e2579..fe91fd1b9869 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4264,6 +4264,7 @@
SUBDIR += py-check-manifest
SUBDIR += py-cheetah3
SUBDIR += py-circuits
+ SUBDIR += py-ciso8601
SUBDIR += py-cld
SUBDIR += py-cle
SUBDIR += py-cleo
diff --git a/devel/py-ciso8601/Makefile b/devel/py-ciso8601/Makefile
new file mode 100644
index 000000000000..4de30d2ac9cf
--- /dev/null
+++ b/devel/py-ciso8601/Makefile
@@ -0,0 +1,16 @@
+PORTNAME= ciso8601
+DISTVERSION= 2.1.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= Fast ISO8601 date time parser for Python written in C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-ciso8601/distinfo b/devel/py-ciso8601/distinfo
new file mode 100644
index 000000000000..88aed70b617b
--- /dev/null
+++ b/devel/py-ciso8601/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1605994961
+SHA256 (ciso8601-2.1.3.tar.gz) = bdbb5b366058b1c87735603b23060962c439ac9be66f1ae91e8c7dbd7d59e262
+SIZE (ciso8601-2.1.3.tar.gz) = 15726
diff --git a/devel/py-ciso8601/pkg-descr b/devel/py-ciso8601/pkg-descr
new file mode 100644
index 000000000000..c6203edf22ab
--- /dev/null
+++ b/devel/py-ciso8601/pkg-descr
@@ -0,0 +1,8 @@
+ciso8601 converts ISO 8601 or RFC 3339 date time strings into Python
+datetime objects. Since it's written as a C module, it is much faster
+than other Python libraries.
+
+Note: ciso8601 doesn't support the entirety of the ISO 8601 spec,
+only a popular subset.
+
+WWW: https://github.com/closeio/ciso8601