aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Certner <olce@FreeBSD.org>2025-01-09 18:15:02 +0000
committerOlivier Certner <olce@FreeBSD.org>2025-01-10 13:20:24 +0000
commit97083d47fd436e218c868dc36fa17d4fa88ac199 (patch)
tree4c379fbc0fe99e2ecd98e201fcb46ca3d4ebc705
parentd3f713ad71e2512fe5e01b5feaa107b509a879de (diff)
editors/sly: Update to latest commit (dated 2024/08/09)
Updates: - Prevent ‘C-h m’ from breaking in Sly debugger buffers. - Unbreak odd non-SLY uses of slynk/indentation system. - mrepl: Fix a bug on SBCL. - Emit :company-kind in Sly's flex CAPF (allows completion frameworks to show type icons). - Make sly-simple-completions behave more like vanilla. - Add option to control if we replace SLIME on load. The SLY contribs in the ports tree have not been bumped as this new version does not change the interface to them, so they don't need recompilation. This is a maintainer update (olce.freebsd.ports@certner.fr). Sponsored by: The FreeBSD Foundation
-rw-r--r--editors/sly/Makefile5
-rw-r--r--editors/sly/distinfo6
-rw-r--r--editors/sly/files/patch-sly.el27
3 files changed, 22 insertions, 16 deletions
diff --git a/editors/sly/Makefile b/editors/sly/Makefile
index 01b7ac36fd54..1ff0803048b8 100644
--- a/editors/sly/Makefile
+++ b/editors/sly/Makefile
@@ -1,6 +1,5 @@
PORTNAME= sly
-DISTVERSION= 1.0.43-20230624
-PORTREVISION= 4
+DISTVERSION= 1.0.43-20240809
CATEGORIES= editors elisp
PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
@@ -13,7 +12,7 @@ LICENSE= PD
USES= emacs gmake
USE_GITHUB= yes
GH_ACCOUNT= joaotavora
-GH_TAGNAME= df62abae73bd511885c9c7ec0ea7ea1469a00923
+GH_TAGNAME= 742355f7554ab6c46e5c1c9bdb89068f55359eaa
NO_ARCH= yes
diff --git a/editors/sly/distinfo b/editors/sly/distinfo
index 04049fb2af66..b1da6a4f0fc2 100644
--- a/editors/sly/distinfo
+++ b/editors/sly/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1692890116
-SHA256 (joaotavora-sly-1.0.43-20230624-df62abae73bd511885c9c7ec0ea7ea1469a00923_GH0.tar.gz) = 9e961e06cd80bfa9a993446e30da8b378ba92b3d69e52d56c3ac2e18115a0889
-SIZE (joaotavora-sly-1.0.43-20230624-df62abae73bd511885c9c7ec0ea7ea1469a00923_GH0.tar.gz) = 1840949
+TIMESTAMP = 1736445917
+SHA256 (joaotavora-sly-1.0.43-20240809-742355f7554ab6c46e5c1c9bdb89068f55359eaa_GH0.tar.gz) = ffa627a3f4740372e88990113a2af8178f7bce0771f36b35896f8018b34b6e5f
+SIZE (joaotavora-sly-1.0.43-20240809-742355f7554ab6c46e5c1c9bdb89068f55359eaa_GH0.tar.gz) = 1841274
diff --git a/editors/sly/files/patch-sly.el b/editors/sly/files/patch-sly.el
index 22aa9c81ed7c..cd96a7e4bb54 100644
--- a/editors/sly/files/patch-sly.el
+++ b/editors/sly/files/patch-sly.el
@@ -1,28 +1,35 @@
---- sly.el.orig 2023-05-23 12:54:52 UTC
+--- sly.el.orig 2024-08-09 21:19:04 UTC
+++ sly.el
-@@ -7475,22 +7475,30 @@ can be found."
- ;;;###autoload
- (add-hook 'lisp-mode-hook 'sly-editing-mode)
+@@ -7487,24 +7487,35 @@ other non-nil value to unconditionally replace SLIME."
+ (const :tag "Do not replace SLIME" nil)
+ (const :tag "Do replace SLIME" t)))
-(cond
- ((or (not (memq 'slime-lisp-mode-hook lisp-mode-hook))
- noninteractive
- (prog1
-- (y-or-n-p "[sly] SLIME detected in `lisp-mode-hook', causes keybinding conflicts. Remove it for this Emacs session?")
+- (if (eq sly-replace-slime 'ask)
+- (y-or-n-p "[sly] SLIME detected in `lisp-mode-hook', causes keybinding conflicts. Remove it for this Emacs session?")
+- sly-replace-slime)
- (warn "To restore SLIME in this session, customize `lisp-mode-hook'
-and replace `sly-editing-mode' with `slime-lisp-mode-hook'.")))
- (remove-hook 'lisp-mode-hook 'slime-lisp-mode-hook)
+(let ((proceed-p
+ (if noninteractive
-+ (lambda () t)
++ (lambda ()
++ (if (eq sly-replace-slime 'ask)
++ t
++ sly-replace-slime))
+ (let (asked resp)
+ (lambda ()
+ (unless asked
+ (setq resp
-+ (y-or-n-p
-+ (eval-when-compile
-+ (concat "[sly] SLIME detected. Try to disable it "
-+ "for this Emacs session?")))
++ (if (eq sly-replace-slime 'ask)
++ (y-or-n-p
++ (eval-when-compile
++ (concat "[sly] SLIME detected. Try to disable it "
++ "for this Emacs session?")))
++ sly-replace-slime)
+ asked t))
+ resp)))))
+ (when (and (memq 'slime-lisp-mode-hook lisp-mode-hook)