aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-12 15:57:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-12 16:00:23 +0000
commit975c4836a6e01d1e62e4f075d1d00c7c3c59f196 (patch)
treeeff091c1e7f9acac97d477519daf3833f6741d79
parent32ca8c877e886b2df0dcc62b6a784e4dbc0f2c66 (diff)
downloadports-975c4836a6e01d1e62e4f075d1d00c7c3c59f196.tar.gz
ports-975c4836a6e01d1e62e4f075d1d00c7c3c59f196.zip
math/clp: Remove bundled osi project in favor of math/osi dependency
This fixes file conflict between math/clp and math/osi.
-rw-r--r--math/clp/Makefile6
-rw-r--r--math/clp/pkg-plist27
-rw-r--r--math/highs/Makefile3
3 files changed, 6 insertions, 30 deletions
diff --git a/math/clp/Makefile b/math/clp/Makefile
index 2fab3a46b48f..8951df549c13 100644
--- a/math/clp/Makefile
+++ b/math/clp/Makefile
@@ -2,7 +2,7 @@
PORTNAME= Clp
DISTVERSION= 1.17.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= https://www.coin-or.org/download/source/${PORTNAME}/
PKGNAMEPREFIX= coin-or-
@@ -16,7 +16,8 @@ BUILD_DEPENDS= coin-or-Data-Sample>0:math/coin-or-data-sample \
coin-or-Data-Netlib>0:math/coin-or-data-netlib
LIB_DEPENDS= libcoinasl.so:math/asl \
libcoinmumps.so:math/ipopt \
- libCoinUtils.so:math/coinutils
+ libCoinUtils.so:math/coinutils \
+ libOsi.so:math/osi
RUN_DEPENDS= coin-or-Data-Sample>0:math/coin-or-data-sample \
coin-or-Data-Netlib>0:math/coin-or-data-netlib
@@ -28,6 +29,7 @@ INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --with-lapack-lib="${LAPACKLIB} -L${LOCALBASE}/lib" \
--with-blas-lib="${BLASLIB} -L${LOCALBASE}/lib" \
+ --with-osi-incdir="${LOCALBASE}/include/coin" --with-osi-lib="${LOCALBASE}/lib/libOsi.so" \
--with-coinutils-incdir="${LOCALBASE}/include/coin" --with-coinutils-lib="${LOCALBASE}/lib/libCoinUtils.so" \
--with-netlib-datadir="${LOCALBASE}/share/coin/Data/Netlib" \
--with-sample-datadir="${LOCALBASE}/share/coin/Data/Sample" \
diff --git a/math/clp/pkg-plist b/math/clp/pkg-plist
index 4620b207105e..02077c26978e 100644
--- a/math/clp/pkg-plist
+++ b/math/clp/pkg-plist
@@ -50,46 +50,19 @@ include/coin/ClpSimplexPrimal.hpp
include/coin/ClpSolve.hpp
include/coin/Clp_C_Interface.h
include/coin/Idiot.hpp
-include/coin/OsiAuxInfo.hpp
-include/coin/OsiBranchingObject.hpp
-include/coin/OsiChooseVariable.hpp
include/coin/OsiClpSolverInterface.hpp
-include/coin/OsiColCut.hpp
-include/coin/OsiCollections.hpp
-include/coin/OsiConfig.h
-include/coin/OsiCut.hpp
-include/coin/OsiCuts.hpp
-include/coin/OsiPresolve.hpp
-include/coin/OsiRowCut.hpp
-include/coin/OsiRowCutDebugger.hpp
-include/coin/OsiSolverBranch.hpp
-include/coin/OsiSolverInterface.hpp
-include/coin/OsiSolverParameters.hpp
-include/coin/OsiUnitTests.hpp
lib/libClp.so
lib/libClp.so.1
lib/libClp.so.1.14.3
lib/libClpSolver.so
lib/libClpSolver.so.1
lib/libClpSolver.so.1.14.3
-lib/libOsi.so
-lib/libOsi.so.1
-lib/libOsi.so.1.13.4
lib/libOsiClp.so
lib/libOsiClp.so.1
lib/libOsiClp.so.1.14.3
-lib/libOsiCommonTests.so
-lib/libOsiCommonTests.so.1
-lib/libOsiCommonTests.so.1.13.4
libdata/pkgconfig/clp.pc
libdata/pkgconfig/osi-clp.pc
-libdata/pkgconfig/osi-unittests.pc
-libdata/pkgconfig/osi.pc
%%DATADIR%%/coin/doc/Clp/AUTHORS
%%DATADIR%%/coin/doc/Clp/LICENSE
%%DATADIR%%/coin/doc/Clp/README
%%DATADIR%%/coin/doc/Clp/clp_addlibs.txt
-%%DATADIR%%/coin/doc/Osi/AUTHORS
-%%DATADIR%%/coin/doc/Osi/LICENSE
-%%DATADIR%%/coin/doc/Osi/README
-%%DATADIR%%/coin/doc/Osi/osi_addlibs.txt
diff --git a/math/highs/Makefile b/math/highs/Makefile
index 8b79d344b7b2..a1902ae5df05 100644
--- a/math/highs/Makefile
+++ b/math/highs/Makefile
@@ -1,5 +1,6 @@
PORTNAME= highs
DISTVERSION= g20210408
+PORTREVISION= 1
CATEGORIES= math
PKGNAMEPREFIX= coin-or-
@@ -11,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= undefined reference to fmax, see https://github.com/ERGO-Code/HiGHS/issues/505
-LIB_DEPENDS= libOsi.so:math/clp
+LIB_DEPENDS= libOsi.so:math/osi
USES= blaslapack cmake compiler:c++11-lang pkgconfig