aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-19 23:38:12 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-19 23:38:12 +0000
commit9845a1e63225422659da4c51d9deee1e8bafe0a1 (patch)
tree95cd0d5ed7f760e7e1a4fd53a6df9ae73654c0a2
parent42421128b8a52b4a6a281093a2d8fab8befd579c (diff)
downloadports-9845a1e63225422659da4c51d9deee1e8bafe0a1.tar.gz
ports-9845a1e63225422659da4c51d9deee1e8bafe0a1.zip
audio/madronalib: fix build on powerpc64le
Use GCC with its SSE translation: In file included from /wrkdirs/usr/ports/audio/madronalib/work/madronalib-1.6-1016-g103895f/source/DSP/MLDSPMathSSE.h:32: In file included from /usr/lib/clang/11.0.1/include/emmintrin.h:13: In file included from /usr/lib/clang/11.0.1/include/xmmintrin.h:13: /usr/lib/clang/11.0.1/include/mmintrin.h:33:5: error: use of undeclared identifier '__builtin_ia32_emms'; did you mean '__builtin_isless'? __builtin_ia32_emms();
-rw-r--r--audio/madronalib/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/audio/madronalib/Makefile b/audio/madronalib/Makefile
index 705f41c40013..40642b803f26 100644
--- a/audio/madronalib/Makefile
+++ b/audio/madronalib/Makefile
@@ -13,11 +13,20 @@ BROKEN_i386= error: always_inline function '_mm_load_ps' requires target feature
LIB_DEPENDS= libjack.so:audio/jack
-USES= cmake compiler:c++11-lib localbase:ldflags perl5
+USES= cmake localbase:ldflags perl5
USE_GITHUB= yes
GH_ACCOUNT= madronalabs
CMAKE_ON= LINUX_JACK
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64le
+CXXFLAGS+= -DNO_WARN_X86_INTRINSICS
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lib
+.endif
+
.include <bsd.port.mk>