aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-07-29 16:47:07 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-07-30 18:06:10 +0000
commit98727f624287cfc06da9fc0d253e362d7b59dce5 (patch)
tree8911fbbe3eb4310ca4efd0da43a1903251fa9326
parentbc850e8692dc9010c41b0413ce6df8e79e5a88b0 (diff)
downloadports-98727f624287cfc06da9fc0d253e362d7b59dce5.tar.gz
ports-98727f624287cfc06da9fc0d253e362d7b59dce5.zip
x11/swaync: add new port
swaync is a simple notification daemon with a GUI built for Sway (potentially any WM with wlroots). Features: - A panel to view previous notifications - Show album art for notifications like Spotify - Do not disturb - Click notification to execute default action - Show alternative notification actions - The same features as any other basic notification daemon Planned Features: - Customization through a CSS file - Slick animations https://github.com/ErikReider/SwayNotificationCenter
-rw-r--r--x11/Makefile1
-rw-r--r--x11/swaync/Makefile24
-rw-r--r--x11/swaync/distinfo3
-rw-r--r--x11/swaync/pkg-descr16
4 files changed, 44 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index b5c59766fce1..f5713972a776 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -342,6 +342,7 @@
SUBDIR += swayidle
SUBDIR += swaylock
SUBDIR += swaylock-effects
+ SUBDIR += swaync
SUBDIR += swayr
SUBDIR += sxhkd
SUBDIR += sxpc
diff --git a/x11/swaync/Makefile b/x11/swaync/Makefile
new file mode 100644
index 000000000000..48d42038ab8f
--- /dev/null
+++ b/x11/swaync/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= swaync
+PORTVERSION= s20210730
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Simple Wayland notification daemon with GUI
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= valac:lang/vala
+LIB_DEPENDS= libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell \
+ libhandy-1.so:x11-toolkits/libhandy
+
+USES= compiler:c11 gnome localbase:ldflags meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= gdkpixbuf2 gtk30
+GH_ACCOUNT= ErikReider
+GH_PROJECT= SwayNotificationCenter
+GH_TAGNAME= 4abddf0
+PLIST_FILES= bin/${PORTNAME} \
+ bin/${PORTNAME}-client
+
+.include <bsd.port.mk>
diff --git a/x11/swaync/distinfo b/x11/swaync/distinfo
new file mode 100644
index 000000000000..bcf7c0ce867a
--- /dev/null
+++ b/x11/swaync/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1627664346
+SHA256 (ErikReider-SwayNotificationCenter-s20210730-4abddf0_GH0.tar.gz) = ba28b71ef934d80276cbab9f524836a24be3895b1d69479534ad28bc806c41cf
+SIZE (ErikReider-SwayNotificationCenter-s20210730-4abddf0_GH0.tar.gz) = 9978035
diff --git a/x11/swaync/pkg-descr b/x11/swaync/pkg-descr
new file mode 100644
index 000000000000..335d6ffa77e9
--- /dev/null
+++ b/x11/swaync/pkg-descr
@@ -0,0 +1,16 @@
+swaync is a simple notification daemon with a GUI
+built for Sway (potentially any WM with wlroots).
+
+Features:
+- A panel to view previous notifications
+- Show album art for notifications like Spotify
+- Do not disturb
+- Click notification to execute default action
+- Show alternative notification actions
+- The same features as any other basic notification daemon
+
+Planned Features:
+- Customization through a CSS file
+- Slick animations
+
+WWW: https://github.com/ErikReider/SwayNotificationCenter