aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-25 23:20:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-25 23:20:37 +0000
commit98d311a8b74ed96470e7064b913c2b0a72fb1e7b (patch)
tree195b29c6d6a50ff0a20f9161f665002a6825f3f2
parentcf3195e1d36eb02efc6c1d945ca9f3cdb6128024 (diff)
downloadports-98d311a8b74ed96470e7064b913c2b0a72fb1e7b.tar.gz
ports-98d311a8b74ed96470e7064b913c2b0a72fb1e7b.zip
astro/pal: New port: Positional Astronomy Library
-rw-r--r--astro/Makefile1
-rw-r--r--astro/pal/Makefile36
-rw-r--r--astro/pal/distinfo3
-rw-r--r--astro/pal/pkg-descr12
4 files changed, 52 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index c75416f2e648..74793fabccd0 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -72,6 +72,7 @@
SUBDIR += p5-Net-GPSD3
SUBDIR += p5-Starlink-AST
SUBDIR += p5-Weather-Underground
+ SUBDIR += pal
SUBDIR += phd2
SUBDIR += phoon
SUBDIR += pp3
diff --git a/astro/pal/Makefile b/astro/pal/Makefile
new file mode 100644
index 000000000000..bbcaccbff909
--- /dev/null
+++ b/astro/pal/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= pal
+DISTVERSION= 0.9.8
+CATEGORIES= astro geography
+MASTER_SITES= https://github.com/Starlink/pal/releases/download/v${DISTVERSION}/
+PKGNAMESUFFIX= -astronomical
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Positional Astronomy Library
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= liberfa.so:astro/erfa
+
+USES= gmake libtool
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+PLIST_FILES= include/star/pal.h \
+ include/star/palmac.h \
+ lib/libpal.a \
+ lib/libpal.so \
+ lib/libpal.so.0 \
+ lib/libpal.so.0.0.0
+
+post-install: # remove manifest file that contains stage dir, news and docs directories, and datadir with licenses
+ @${RM} -r \
+ ${STAGEDIR}${PREFIX}/manifests \
+ ${STAGEDIR}${PREFIX}/news \
+ ${STAGEDIR}${PREFIX}/docs \
+ ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/astro/pal/distinfo b/astro/pal/distinfo
new file mode 100644
index 000000000000..718c6209b8b2
--- /dev/null
+++ b/astro/pal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1661467182
+SHA256 (pal-0.9.8.tar.gz) = 191fde8c4f45d6807d4b011511344014966bb46e44029a4481d070cd5e7cc697
+SIZE (pal-0.9.8.tar.gz) = 1267834
diff --git a/astro/pal/pkg-descr b/astro/pal/pkg-descr
new file mode 100644
index 000000000000..b882427b2962
--- /dev/null
+++ b/astro/pal/pkg-descr
@@ -0,0 +1,12 @@
+The PAL library is a partial re-implementation of Pat Wallace's popular SLALIB
+library written in C using a Gnu GPL license and layered on top of the IAU's
+SOFA library (or the BSD-licensed ERFA) where appropriate. PAL attempts to stick
+to the SLA C API where possible although palObs() has a more C-like API than the
+equivalent slaObs() function. In most cases it is enough to simply change the
+function prefix of a routine in order to link against PAL rather than SLALIB.
+Routines calling SOFA use modern notation and precession models so will return
+slightly different answers than native SLALIB. PAL functions not available in
+SOFA were ported from the Fortran version of SLALIB that ships as part of the
+Starlink software and uses a GPL licence.
+
+WWW: https://github.com/Starlink/pal