aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-14 04:08:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-14 04:08:07 +0000
commit996c7672b9173cf2fe74353c68e1842610d20dd9 (patch)
tree9147bb545af65cacc77db0b678dc96bbe8169add
parent430de3a3705c8b0eb333023d6a8cc29c18bb66fd (diff)
downloadports-996c7672b9173cf2fe74353c68e1842610d20dd9.tar.gz
ports-996c7672b9173cf2fe74353c68e1842610d20dd9.zip
mod_gnutls uses the GnuTLS library to provide SSL 3.0, TLS 1.0, TLS
1.1 and 1.2 encryption for Apache HTTPD. It is similar to mod_ssl in purpose, but does not use OpenSSL. WWW: http://www.outoforder.cc/projects/apache/mod_gnutls/ PR: ports/154463 Submitted by: Fumiyuki Shimizu <fumifumi at abacustech.jp>
Notes
Notes: svn path=/head/; revision=269128
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_gnutls/Makefile52
-rw-r--r--www/mod_gnutls/distinfo2
-rw-r--r--www/mod_gnutls/files/patch-src-Makefile.in11
-rw-r--r--www/mod_gnutls/files/pkg-message.in22
-rw-r--r--www/mod_gnutls/pkg-descr5
-rw-r--r--www/mod_gnutls/pkg-plist11
7 files changed, 104 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ae08927ac609..d22903ebda50 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -497,6 +497,7 @@
SUBDIR += mod_flickr
SUBDIR += mod_geoip
SUBDIR += mod_geoip2
+ SUBDIR += mod_gnutls
SUBDIR += mod_gzip
SUBDIR += mod_gzip2
SUBDIR += mod_h264_streaming
diff --git a/www/mod_gnutls/Makefile b/www/mod_gnutls/Makefile
new file mode 100644
index 000000000000..3c03117259e0
--- /dev/null
+++ b/www/mod_gnutls/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: mod_gnutls
+# Date created: 2011-01-19
+# Whom: Fumiyuki Shimizu <fumifumi@abacustech.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_gnutls
+PORTVERSION= 0.5.6
+CATEGORIES= www security
+MASTER_SITES= http://www.outoforder.cc/downloads/mod_gnutls/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+
+MAINTAINER= fumifumi@abacustech.jp
+COMMENT= mod_gnutls uses the GnuTLS library to provide SSL, and TLS encryption for Apache HTTPD
+
+LIB_DEPENDS= gnutls.40:${PORTSDIR}/security/gnutls
+
+USE_BZIP2= yes
+USE_AUTOTOOLS= libtool
+USE_APACHE= 2.0+
+GNU_CONFIGURE= yes
+
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+DOCS= LICENSE NEWS README README.ENV
+
+.include <bsd.port.pre.mk>
+
+DBDIR= ${PREFIX}/var/db/${PORTNAME}
+
+SUB_FILES= pkg-message
+PLIST_SUB+= DBDIR=${DBDIR}
+
+CONFIGURE_ARGS= --with-apxs=${APXS}
+
+# mod_gnutls does not conflict with mod_ssl.
+#pre-install:
+# @if test -e '${LOCALBASE}/${APACHEMODDIR}/mod_ssl.so'; then for opt in -a -A -A; do '${APXS}' -e "$${opt}" -n ssl '${LOCALBASE}/${APACHEMODDIR}/mod_ssl.so' >/dev/null 2>&1; done; else true; fi
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} '${DOCSDIR}'
+ @cd '${WRKSRC}' && ${INSTALL_DATA} ${DOCS} '${DOCSDIR}'
+.endif
+ @if test -d '${DBDIR}'; then true; else ${MKDIR} '${DBDIR}'; fi
+ @${CHOWN} '${WWWOWN}:${WWWGRP}' '${DBDIR}'
+ @${CHMOD} 'u=rwx,g=rx,o=' '${DBDIR}'
+ @${CAT} '${PKGMESSAGE}'
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_gnutls/distinfo b/www/mod_gnutls/distinfo
new file mode 100644
index 000000000000..65d75ecb15d1
--- /dev/null
+++ b/www/mod_gnutls/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mod_gnutls-0.5.6.tar.bz2) = ec7bb2b05c5a2bb8044471c4250b5f3b396d8748724bc2cb4facf76b50f9f6d4
+SIZE (mod_gnutls-0.5.6.tar.bz2) = 242219
diff --git a/www/mod_gnutls/files/patch-src-Makefile.in b/www/mod_gnutls/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..f220cd90014f
--- /dev/null
+++ b/www/mod_gnutls/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2010-09-24 15:55:26.000000000 +0900
++++ src/Makefile.in 2011-02-02 16:12:43.000000000 +0900
+@@ -612,7 +612,7 @@
+ rm -fr .libs
+
+ install: make_so
+- @${APXS_BIN} -i -n gnutls mod_gnutls.so
++ @${APXS_BIN} -i -a -n gnutls mod_gnutls.so
+ @echo ""
+ @echo ""
+ @echo "***********************************************"
diff --git a/www/mod_gnutls/files/pkg-message.in b/www/mod_gnutls/files/pkg-message.in
new file mode 100644
index 000000000000..7caae01dec85
--- /dev/null
+++ b/www/mod_gnutls/files/pkg-message.in
@@ -0,0 +1,22 @@
+*********************************************************************
+
+Sample %%PREFIX%%/etc/apache22/httpd.conf.
+
+ #LoadModule ssl_module libexec/apache22/mod_ssl.so
+ LoadModule gnutls_module libexec/apache22/mod_gnutls.so
+
+ GnuTLSCache dbm %%DBDIR%%/tls-cache
+ GnuTLSCacheTimeout 500
+
+ <VirtualHost example.com:443>
+ GnuTLSEnable on
+ GnuTLSKeyFile /etc/ssl/certs/private/example_com.key.pem
+ GnuTLSCertificateFile /etc/ssl/certs/example_com.crt.pem
+ GnuTLSClientCAFile /etc/ssl/certs/example_com.ca.pem
+ GnuTLSPriorities NORMAL:%COMPAT
+ </Directory>
+
+If you have disabled all configuration for mod_ssl,
+you have to disable LoadModule for mod_ssl.
+
+*********************************************************************
diff --git a/www/mod_gnutls/pkg-descr b/www/mod_gnutls/pkg-descr
new file mode 100644
index 000000000000..96af6d780d02
--- /dev/null
+++ b/www/mod_gnutls/pkg-descr
@@ -0,0 +1,5 @@
+mod_gnutls uses the GnuTLS library to provide SSL 3.0, TLS 1.0, TLS
+1.1 and 1.2 encryption for Apache HTTPD. It is similar to mod_ssl in
+purpose, but does not use OpenSSL.
+
+WWW: http://www.outoforder.cc/projects/apache/mod_gnutls/
diff --git a/www/mod_gnutls/pkg-plist b/www/mod_gnutls/pkg-plist
new file mode 100644
index 000000000000..4413ccc45cae
--- /dev/null
+++ b/www/mod_gnutls/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@exec '%D/sbin/apxs' -e -a -n '%%AP_NAME%%' '%D/%%APACHEMODDIR%%/%%AP_MODULE%%'
+@unexec '%D/sbin/apxs' -e -A -n '%%AP_NAME%%' '%D/%%APACHEMODDIR%%/%%AP_MODULE%%'
+@comment @exec if test -e '%D/%%APACHEMODDIR%%/mod_ssl.so'; then for opt in -a -A -A; do '%D/sbin/apxs' -e "${opt}" -n ssl '%D/%%APACHEMODDIR%%/mod_ssl.so'; done; fi
+@comment @unexec if test -e '%D/%%APACHEMODDIR%%/mod_ssl.so'; then '%D/sbin/apxs' -e -a -n ssl '%D/%%APACHEMODDIR%%/mod_ssl.so'; fi
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.ENV
+%%PORTDOCS%%@dirrm %%DOCSDIR%%