aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-09 03:23:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-09 03:24:22 +0000
commit999a9192dbc2b2b2f691499bffc497df6cefeddf (patch)
tree1cf627dc432229816548997b550979213ce0ba3e
parent85d1c982fae904a1f416820660b71a32f302965f (diff)
downloadports-999a9192dbc2b2b2f691499bffc497df6cefeddf.tar.gz
ports-999a9192dbc2b2b2f691499bffc497df6cefeddf.zip
misc/py-ipyfastscape: New port: Interactive widgets for topographic data analysis and modelling
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-ipyfastscape/Makefile32
-rw-r--r--misc/py-ipyfastscape/distinfo3
-rw-r--r--misc/py-ipyfastscape/pkg-descr11
4 files changed, 47 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d6994ccfd1c4..f9e2f2b6beed 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -407,6 +407,7 @@
SUBDIR += py-halo
SUBDIR += py-histoprint
SUBDIR += py-huepy
+ SUBDIR += py-ipyfastscape
SUBDIR += py-kartograph
SUBDIR += py-log_symbols
SUBDIR += py-mffpy
diff --git a/misc/py-ipyfastscape/Makefile b/misc/py-ipyfastscape/Makefile
new file mode 100644
index 000000000000..55b46c398a84
--- /dev/null
+++ b/misc/py-ipyfastscape/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= ipyfastscape
+DISTVERSION= 0.2.0
+CATEGORIES= misc
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Interactive widgets for topographic data analysis and modelling
+WWW= https://github.com/fastscape-lem/ipyfastscape
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipygany>=0.5.0:science/py-ipygany@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipywidgets>0:devel/py-ipywidgets@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipython>=0:devel/ipython@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}xarray>0:devel/py-xarray@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= fastscape-lem
+
+MAKE_ENV= SETUPTOOLS_SCM_PRETEND_VERSION=${DISTVERSION} # workaround for LookupError: setuptools-scm was unable to detect version for ...
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-ipyfastscape/distinfo b/misc/py-ipyfastscape/distinfo
new file mode 100644
index 000000000000..081da3fd9bbd
--- /dev/null
+++ b/misc/py-ipyfastscape/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1673233669
+SHA256 (fastscape-lem-ipyfastscape-0.2.0_GH0.tar.gz) = 08e0c6cd3559f0834844c85f5d0c2bff982411583857522ede0d06506f0c7614
+SIZE (fastscape-lem-ipyfastscape-0.2.0_GH0.tar.gz) = 16438
diff --git a/misc/py-ipyfastscape/pkg-descr b/misc/py-ipyfastscape/pkg-descr
new file mode 100644
index 000000000000..dc3546d0aec2
--- /dev/null
+++ b/misc/py-ipyfastscape/pkg-descr
@@ -0,0 +1,11 @@
+Ipyfastscape is interactive widgets for topographic data analysis and modelling
+in Jupyter notebooks.
+
+While ipyfastscape is tightly integrated with fastscape, it also integrates very
+well with any data in the form of an xarray dataset or any model created with
+xarray-simlab.
+
+The widgets available here are built on top of libraries of the jupyter's widget
+ecosystem such as ipywidgets and ipygany. You can reuse those high-level UI
+components as-is within notebooks (embedded mini-apps) or for building
+interactive dashboards that you can then publish as standalone web applications.