aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-22 13:58:16 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-22 17:18:29 +0000
commit99f34a6ee645c19a1a70c5828659feed2da725c8 (patch)
tree28c27b02a82c9ba1f34632cb3daeb32dbadab5ba
parentb98f948045efaf0ec0bf060f5e2647b97d966864 (diff)
downloadports-99f34a6ee645c19a1a70c5828659feed2da725c8.tar.gz
ports-99f34a6ee645c19a1a70c5828659feed2da725c8.zip
devel/libsigrokdecode: fix build with python3.9+
- Fix python detection and allow build with python3.9+ - Fix license, add LICENSE_FILE Approved by: portmgr blanket
-rw-r--r--devel/libsigrokdecode/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/libsigrokdecode/Makefile b/devel/libsigrokdecode/Makefile
index d101b77979cb..dc1b8159163e 100644
--- a/devel/libsigrokdecode/Makefile
+++ b/devel/libsigrokdecode/Makefile
@@ -8,7 +8,8 @@ MASTER_SITES= http://sigrok.org/download/source/libsigrokdecode/
MAINTAINER= bsam@FreeBSD.org
COMMENT= Framework for hardware logic analyzers, protocol decoders library
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
USES= gnome libtool pathfix pkgconfig python:3.4+
@@ -16,5 +17,10 @@ USE_GNOME= glib20
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+CONFIGURE_ENV= PYTHON3="${PYTHON_CMD}"
+
+post-patch:
+ @${REINPLACE_CMD} -Ee '/python-/ s|3\.[0-9]+|${PYTHON_VER}|g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>