aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2021-06-07 22:24:25 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2021-06-07 22:39:37 +0000
commit9a34ad5a4907925598c80d6c3e3cfeac1ca9e4a9 (patch)
tree9c477ccb6e5814e3d3b8047dd65b09e5ad290f11
parent3b85c190f953f948a6d768580f85149a4fc9b523 (diff)
downloadports-9a34ad5a4907925598c80d6c3e3cfeac1ca9e4a9.tar.gz
ports-9a34ad5a4907925598c80d6c3e3cfeac1ca9e4a9.zip
category/port: Package name dependencies do not support globbing.
5.9.9 of the Porters Handbook defines the use of pkgname/version dependencies which does not include globbing. Incidentally `pkg info` is used by the ports framework which does support it but external tools, like Poudriere, don't expect this. None of these needed globbing. If there is a good reason beyond convenience for the feature then it needs to be documented and tools updated.
-rw-r--r--games/py-pychess/Makefile8
-rw-r--r--japanese/japana/Makefile2
-rw-r--r--math/octave-forge-geometry/Makefile4
-rw-r--r--www/gnome-user-share/Makefile2
4 files changed, 9 insertions, 7 deletions
diff --git a/games/py-pychess/Makefile b/games/py-pychess/Makefile
index b542c1da5b3f..dc3724cf3d12 100644
--- a/games/py-pychess/Makefile
+++ b/games/py-pychess/Makefile
@@ -11,10 +11,10 @@ COMMENT= GTK chess client written in Python
LICENSE= GPLv3
COMMON_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy*>1.:databases/py-sqlalchemy13@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}psutil*>0.:sysutils/py-psutil@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}gobject*>2:devel/py-gobject3@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}websockets*>7.:devel/py-websockets@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy>1.:databases/py-sqlalchemy13@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>0.:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gobject>2:devel/py-gobject3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}websockets>7.:devel/py-websockets@${PY_FLAVOR}
RUN_DEPENDS= ${COMMON_DEPENDS}
BUILD_DEPENDS= ${COMMON_DEPENDS}
diff --git a/japanese/japana/Makefile b/japanese/japana/Makefile
index cd67464581d0..00f6b8af39a7 100644
--- a/japanese/japana/Makefile
+++ b/japanese/japana/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Web proxy converting Japanese into Romaji
-RUN_DEPENDS= *p5-Text-Kakasi>=2:japanese/p5-Text-Kakasi \
+RUN_DEPENDS= ja-p5-Text-Kakasi>=2:japanese/p5-Text-Kakasi \
p5-AppConfig>=0:devel/p5-AppConfig \
p5-libwww>=0:www/p5-libwww
diff --git a/math/octave-forge-geometry/Makefile b/math/octave-forge-geometry/Makefile
index 0f8f4ce24b4d..a60f68121b64 100644
--- a/math/octave-forge-geometry/Makefile
+++ b/math/octave-forge-geometry/Makefile
@@ -11,13 +11,15 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
LICENSE= GPLv3
LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+USES= python:env
+
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
OCTSRC= ${DISTNAME}
WRKSRC= ${WRKDIR}/${OCTSRC}/src
-RUN_DEPENDS+= py*-lxml>=0:devel/py-lxml
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml
RUN_DEPENDS+= ${TARBALLS_DIR}/matgeom.tar.gz:math/octave-forge-matgeom
.include "${.CURDIR}/../../Mk/bsd.octave.mk"
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index 7a05e418ff70..e35df9b8cda6 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libavahi-client.so:net/avahi-app \
libnotify.so:devel/libnotify \
libcanberra-gtk3.so:audio/libcanberra-gtk3 \
libunique-1.0.so:x11-toolkits/unique
-RUN_DEPENDS= ap*-mod_dnssd>=0:www/mod_dnssd \
+RUN_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_dnssd>=0:www/mod_dnssd \
console-kit-daemon:sysutils/consolekit2
USES= apache:2.2+ gettext gmake gnome libtool pkgconfig tar:xz xorg