aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Yushkin <636808@mail.ru>2023-10-27 17:08:37 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-11-06 11:02:22 +0000
commit9aa335cb8f1b9b7d13d998bde804d3a352af2a4f (patch)
tree0eddcf89cdcd0cc952f967d1bb4cb8611df38a70
parentb9ff91ba281c0b46ba553bc95633903faaf0bfc3 (diff)
downloadports-9aa335cb8f1b9b7d13d998bde804d3a352af2a4f.tar.gz
ports-9aa335cb8f1b9b7d13d998bde804d3a352af2a4f.zip
graphics/drawio: + Diagramming and whiteboarding desktop app
Co-authored-by: Alexey Donskov <voxnod@gmail.com> Sponsored by: Serenity Cybersecurity, LLC
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/drawio/Makefile27
-rw-r--r--graphics/drawio/distinfo3
-rw-r--r--graphics/drawio/files/drawio.in8
-rw-r--r--graphics/drawio/files/patch-usr_share_applications_drawio.desktop10
-rw-r--r--graphics/drawio/pkg-descr2
-rw-r--r--graphics/drawio/pkg-plist89
7 files changed, 140 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 2b8fe6e949c8..d23b9d13787c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -143,6 +143,7 @@
SUBDIR += djvulibre
SUBDIR += dmtx-utils
SUBDIR += drawing
+ SUBDIR += drawio
SUBDIR += drawpile
SUBDIR += drm-510-kmod
SUBDIR += drm-515-kmod
diff --git a/graphics/drawio/Makefile b/graphics/drawio/Makefile
new file mode 100644
index 000000000000..561a3f7de435
--- /dev/null
+++ b/graphics/drawio/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= drawio
+PORTVERSION= 22.0.3
+DISTVERSIONPREFIX= x86_64-
+CATEGORIES= graphics
+MASTER_SITES= https://github.com/jgraph/drawio-desktop/releases/download/v${PORTVERSION}/
+EXTRACT_SUFX= .rpm
+
+MAINTAINER= 636808@mail.ru
+COMMENT= Diagramming and whiteboarding desktop app
+WWW= https://drawio.com/
+
+LICENSE= APACHE20
+
+USES= desktop-file-utils electronfix:25 shared-mime-info
+
+ELECTRONFIX_MAIN_EXECUTABLE= drawio
+SUB_FILES= drawio
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ cd ${WRKSRC}/opt/ && ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PREFIX}/share
+ cd ${WRKSRC}/usr/share && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${FIND} ${STAGEDIR}${PREFIX} -name '*.orig' -delete
+
+.include <bsd.port.mk>
diff --git a/graphics/drawio/distinfo b/graphics/drawio/distinfo
new file mode 100644
index 000000000000..794e531faa18
--- /dev/null
+++ b/graphics/drawio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1698402619
+SHA256 (drawio-x86_64-22.0.3.rpm) = 2c19909a99510da7722913305d8abe3c674a13b8823dc7ab8fb67c4d3d9670bb
+SIZE (drawio-x86_64-22.0.3.rpm) = 107585929
diff --git a/graphics/drawio/files/drawio.in b/graphics/drawio/files/drawio.in
new file mode 100644
index 000000000000..778634eb81e6
--- /dev/null
+++ b/graphics/drawio/files/drawio.in
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+# workaround Chromium bug https://bugs.chromium.org/p/chromium/issues/detail?id=918234
+if [ "$DBUS_SESSION_BUS_ADDRESS" = "" ]; then
+ export DBUS_SESSION_BUS_ADDRESS="autolaunch:"
+fi
+
+exec %%DATADIR%%/drawio "$@"
diff --git a/graphics/drawio/files/patch-usr_share_applications_drawio.desktop b/graphics/drawio/files/patch-usr_share_applications_drawio.desktop
new file mode 100644
index 000000000000..4bbe2db0a154
--- /dev/null
+++ b/graphics/drawio/files/patch-usr_share_applications_drawio.desktop
@@ -0,0 +1,10 @@
+--- usr/share/applications/drawio.desktop.orig 2023-10-16 17:30:53 UTC
++++ usr/share/applications/drawio.desktop
+@@ -1,6 +1,6 @@ Name=drawio
+ [Desktop Entry]
+ Name=drawio
+-Exec=/opt/drawio/drawio %U
++Exec=drawio %U
+ Terminal=false
+ Type=Application
+ Icon=drawio
diff --git a/graphics/drawio/pkg-descr b/graphics/drawio/pkg-descr
new file mode 100644
index 000000000000..ce998feee123
--- /dev/null
+++ b/graphics/drawio/pkg-descr
@@ -0,0 +1,2 @@
+Drawio-desktop is a diagramming and whiteboarding desktop app based on Electron
+that wraps the core draw.io editor.
diff --git a/graphics/drawio/pkg-plist b/graphics/drawio/pkg-plist
new file mode 100644
index 000000000000..4f41c42e11b8
--- /dev/null
+++ b/graphics/drawio/pkg-plist
@@ -0,0 +1,89 @@
+bin/drawio
+share/applications/drawio.desktop
+%%DATADIR%%/LICENSE.electron.txt
+%%DATADIR%%/LICENSES.chromium.html
+%%DATADIR%%/chrome_100_percent.pak
+%%DATADIR%%/chrome_200_percent.pak
+%%DATADIR%%/chrome_crashpad_handler
+%%DATADIR%%/chromedriver
+%%DATADIR%%/drawio
+%%DATADIR%%/icudtl.dat
+%%DATADIR%%/libEGL.so
+%%DATADIR%%/libGLESv2.so
+%%DATADIR%%/libffmpeg.so
+%%DATADIR%%/libvk_swiftshader.so
+%%DATADIR%%/libvulkan.so
+%%DATADIR%%/locales/af.pak
+%%DATADIR%%/locales/am.pak
+%%DATADIR%%/locales/ar.pak
+%%DATADIR%%/locales/bg.pak
+%%DATADIR%%/locales/bn.pak
+%%DATADIR%%/locales/ca.pak
+%%DATADIR%%/locales/cs.pak
+%%DATADIR%%/locales/da.pak
+%%DATADIR%%/locales/de.pak
+%%DATADIR%%/locales/el.pak
+%%DATADIR%%/locales/en-GB.pak
+%%DATADIR%%/locales/en-US.pak
+%%DATADIR%%/locales/es-419.pak
+%%DATADIR%%/locales/es.pak
+%%DATADIR%%/locales/et.pak
+%%DATADIR%%/locales/fa.pak
+%%DATADIR%%/locales/fi.pak
+%%DATADIR%%/locales/fil.pak
+%%DATADIR%%/locales/fr.pak
+%%DATADIR%%/locales/gu.pak
+%%DATADIR%%/locales/he.pak
+%%DATADIR%%/locales/hi.pak
+%%DATADIR%%/locales/hr.pak
+%%DATADIR%%/locales/hu.pak
+%%DATADIR%%/locales/id.pak
+%%DATADIR%%/locales/it.pak
+%%DATADIR%%/locales/ja.pak
+%%DATADIR%%/locales/kn.pak
+%%DATADIR%%/locales/ko.pak
+%%DATADIR%%/locales/lt.pak
+%%DATADIR%%/locales/lv.pak
+%%DATADIR%%/locales/ml.pak
+%%DATADIR%%/locales/mr.pak
+%%DATADIR%%/locales/ms.pak
+%%DATADIR%%/locales/nb.pak
+%%DATADIR%%/locales/nl.pak
+%%DATADIR%%/locales/pl.pak
+%%DATADIR%%/locales/pt-BR.pak
+%%DATADIR%%/locales/pt-PT.pak
+%%DATADIR%%/locales/ro.pak
+%%DATADIR%%/locales/ru.pak
+%%DATADIR%%/locales/sk.pak
+%%DATADIR%%/locales/sl.pak
+%%DATADIR%%/locales/sr.pak
+%%DATADIR%%/locales/sv.pak
+%%DATADIR%%/locales/sw.pak
+%%DATADIR%%/locales/ta.pak
+%%DATADIR%%/locales/te.pak
+%%DATADIR%%/locales/th.pak
+%%DATADIR%%/locales/tr.pak
+%%DATADIR%%/locales/uk.pak
+%%DATADIR%%/locales/ur.pak
+%%DATADIR%%/locales/vi.pak
+%%DATADIR%%/locales/zh-CN.pak
+%%DATADIR%%/locales/zh-TW.pak
+%%DATADIR%%/resources.pak
+%%DATADIR%%/resources/app-update.yml
+%%DATADIR%%/resources/app.asar
+%%DATADIR%%/resources/package-type
+%%DATADIR%%/snapshot_blob.bin
+%%DATADIR%%/v8_context_snapshot.bin
+%%DATADIR%%/vk_swiftshader_icd.json
+share/icons/hicolor/1024x1024/apps/drawio.png
+share/icons/hicolor/128x128/apps/drawio.png
+share/icons/hicolor/16x16/apps/drawio.png
+share/icons/hicolor/192x192/apps/drawio.png
+share/icons/hicolor/256x256/apps/drawio.png
+share/icons/hicolor/32x32/apps/drawio.png
+share/icons/hicolor/48x48/apps/drawio.png
+share/icons/hicolor/512x512/apps/drawio.png
+share/icons/hicolor/64x64/apps/drawio.png
+share/icons/hicolor/720x720/apps/drawio.png
+share/icons/hicolor/96x96/apps/drawio.png
+share/mime/packages/drawio.xml