aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-01-25 05:31:05 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-01-25 06:21:47 +0000
commit9ab8ec61c30dc799a69d1b57ea625e445a18d737 (patch)
tree53eda962059d0524180a2007d43237fbd441fb4e
parente85ce0128c32742d1ec14d6fb9f8489f5bd1fa02 (diff)
downloadports-9ab8ec61c30dc799a69d1b57ea625e445a18d737.tar.gz
ports-9ab8ec61c30dc799a69d1b57ea625e445a18d737.zip
archivers/quazip: add flavors for Qt 5 and Qt 6
-rw-r--r--MOVED1
-rw-r--r--archivers/quazip/Makefile19
-rw-r--r--archivers/quazip/pkg-plist50
-rw-r--r--astro/marble/Makefile3
-rw-r--r--astro/merkaartor/Makefile4
-rw-r--r--astro/qmapshack/Makefile4
-rw-r--r--editors/texstudio/Makefile4
-rw-r--r--emulators/emu64/Makefile4
-rw-r--r--emulators/mupen64plus-qt/Makefile4
-rw-r--r--graphics/krita/Makefile4
-rw-r--r--graphics/nomacs/Makefile4
11 files changed, 54 insertions, 47 deletions
diff --git a/MOVED b/MOVED
index 8da8f381e598..06656ca60461 100644
--- a/MOVED
+++ b/MOVED
@@ -11567,7 +11567,6 @@ graphics/fracplanet@qt5|graphics/fracplanet|2019-03-16|Flavor has been removed
graphics/photivo@qt4||2019-03-16|Qt4 deprecation
graphics/photivo@qt5|graphics/photivo|2019-03-16|Flavor has been removed
archivers/quazip@qt4||2019-03-16|Qt4 deprecation
-archivers/quazip@qt5|archivers/quazip|2019-03-16|Flavor has been removed
net-p2p/transmission@qt4||2019-03-16|Qt4 deprecation
net-p2p/transmission@qt5|net-p2p/transmission-qt|2019-03-16|Flavor has been removed
x11-themes/Kvantum@qt4||2019-03-16|Qt4 deprecation
diff --git a/archivers/quazip/Makefile b/archivers/quazip/Makefile
index 4dcea7f599f8..0b69e749378a 100644
--- a/archivers/quazip/Makefile
+++ b/archivers/quazip/Makefile
@@ -1,8 +1,9 @@
PORTNAME= quazip
DISTVERSIONPREFIX= v
DISTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= archivers
-PKGNAMESUFFIX= -qt5
+PKGNAMESUFFIX= -${FLAVOR}
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt/C++ wrapper for ZIP/UNZIP package
@@ -10,16 +11,22 @@ WWW= https://github.com/stachenov/quazip
LICENSE= LGPL21
-USES= cmake compiler:c++11-lang cpe qt:5
+FLAVORS= qt5 qt6
+FLAVOR?= qt5
+
+USES= cmake compiler:c++11-lang cpe qt:${FLAVOR:S/qt//}
+CPE_VENDOR= quazip_project
USE_GITHUB= yes
GH_ACCOUNT= stachenov
-CPE_VENDOR= quazip_project
USE_LDCONFIG= yes
-USE_QT= core network \
+_USE_QT_qt5= core network \
buildtools:build testlib:build qmake:build
-CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=FALSE
+_USE_QT_qt6= base 5compat
+USE_QT= ${_USE_QT_${FLAVOR}}
+
+CMAKE_ARGS= -DQUAZIP_QT_MAJOR_VERSION=${FLAVOR:S/qt//}
-PLIST_SUB= QTVER_SUFFIX=5 \
+PLIST_SUB= QTVER_SUFFIX=${FLAVOR:S/qt//} \
QUAZIP_VERSION=${DISTVERSION}
.include <bsd.port.mk>
diff --git a/archivers/quazip/pkg-plist b/archivers/quazip/pkg-plist
index 5e89be7a4514..d94b3967a70c 100644
--- a/archivers/quazip/pkg-plist
+++ b/archivers/quazip/pkg-plist
@@ -1,25 +1,25 @@
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/JlCompress.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/ioapi.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/minizip_crypt.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quaadler32.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quachecksum32.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quacrc32.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quagzipfile.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quaziodevice.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quazip.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quazip_global.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quazip_qt_compat.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quazipdir.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quazipfile.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quazipfileinfo.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/quazipnewinfo.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/unzip.h
-include/QuaZip-Qt5-%%QUAZIP_VERSION%%/quazip/zip.h
-lib/cmake/QuaZip-Qt5-%%QUAZIP_VERSION%%/QuaZip-Qt5Config.cmake
-lib/cmake/QuaZip-Qt5-%%QUAZIP_VERSION%%/QuaZip-Qt5ConfigVersion.cmake
-lib/cmake/QuaZip-Qt5-%%QUAZIP_VERSION%%/QuaZip-Qt5_SharedTargets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/QuaZip-Qt5-%%QUAZIP_VERSION%%/QuaZip-Qt5_SharedTargets.cmake
-lib/libquazip1-qt5.so
-lib/libquazip1-qt5.so.%%QUAZIP_VERSION%%
-lib/libquazip1-qt5.so.%%QUAZIP_VERSION%%.0
-libdata/pkgconfig/quazip1-qt5.pc
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/JlCompress.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/ioapi.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/minizip_crypt.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quaadler32.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quachecksum32.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quacrc32.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quagzipfile.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quaziodevice.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quazip.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quazip_global.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quazip_qt_compat.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quazipdir.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quazipfile.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quazipfileinfo.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/quazipnewinfo.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/unzip.h
+include/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/quazip/zip.h
+lib/cmake/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/QuaZip-Qt%%QTVER_SUFFIX%%Config.cmake
+lib/cmake/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/QuaZip-Qt%%QTVER_SUFFIX%%ConfigVersion.cmake
+lib/cmake/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/QuaZip-Qt%%QTVER_SUFFIX%%_SharedTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/QuaZip-Qt%%QTVER_SUFFIX%%-%%QUAZIP_VERSION%%/QuaZip-Qt%%QTVER_SUFFIX%%_SharedTargets.cmake
+lib/libquazip1-qt%%QTVER_SUFFIX%%.so
+lib/libquazip1-qt%%QTVER_SUFFIX%%.so.%%QUAZIP_VERSION%%
+lib/libquazip1-qt%%QTVER_SUFFIX%%.so.%%QUAZIP_VERSION%%.0
+libdata/pkgconfig/quazip1-qt%%QTVER_SUFFIX%%.pc
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index f64e0a492e3e..51c1183ffd8a 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -1,5 +1,6 @@
PORTNAME= marble
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= astro education kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -9,7 +10,7 @@ WWW= https://marble.kde.org/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip
+LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip@qt5
USES= cmake compiler:c++11-lang desktop-file-utils gettext \
kde:5 qt:5 shared-mime-info tar:xz xorg
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index 7d092a0c7ca6..0e39857c7642 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -1,6 +1,6 @@
PORTNAME= merkaartor
PORTVERSION= 0.19.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= astro
MAINTAINER= dev2@heesakkers.info
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
- libquazip1-qt5.so:archivers/quazip
+ libquazip1-qt5.so:archivers/quazip@qt5
USES= compiler:c++11-lang gnome pkgconfig qmake qt:5 sqlite:3
USE_GITHUB= yes
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index 814e99d19e30..8d6e26c38599 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -1,6 +1,6 @@
PORTNAME= qmapshack
PORTVERSION= 1.16.1
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONPREFIX= V_
CATEGORIES= astro
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
- libquazip1-qt5.so:archivers/quazip \
+ libquazip1-qt5.so:archivers/quazip@qt5 \
libroutino.so:astro/routino
RUN_DEPENDS= ${LOCALBASE}/bin/bsdisks:sysutils/bsdisks
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index fa0032447838..8fa06b2931dc 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -1,6 +1,6 @@
PORTNAME= texstudio
DISTVERSION= 4.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors
MAINTAINER= rigoletto@FreeBSD.org
@@ -14,7 +14,7 @@ BROKEN_armv6= fails to compile: error: no member named mc_eip in __mcontext
LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell \
libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5 \
- libquazip1-qt5.so:archivers/quazip
+ libquazip1-qt5.so:archivers/quazip@qt5
USES= compiler:c++11-lang desktop-file-utils dos2unix \
ghostscript:run gl pkgconfig qmake qt:5 tex xorg
diff --git a/emulators/emu64/Makefile b/emulators/emu64/Makefile
index 0e54e837e25e..320aa792b7d7 100644
--- a/emulators/emu64/Makefile
+++ b/emulators/emu64/Makefile
@@ -1,6 +1,6 @@
PORTNAME= emu64
PORTVERSION= 5.0.19
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MAINTAINER= zirias@FreeBSD.org
@@ -10,7 +10,7 @@ WWW= https://github.com/ThKattanek/emu64
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip \
+LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip@qt5 \
libpng.so:graphics/png \
libavcodec.so:multimedia/ffmpeg
diff --git a/emulators/mupen64plus-qt/Makefile b/emulators/mupen64plus-qt/Makefile
index fc56e2cacdf2..8fcc860f7f97 100644
--- a/emulators/mupen64plus-qt/Makefile
+++ b/emulators/mupen64plus-qt/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mupen64plus-qt
DISTVERSION= 1.14
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MAINTAINER= maintainer@hasting.email
@@ -10,7 +10,7 @@ WWW= https://github.com/dh4/mupen64plus-qt
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip
+LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip@qt5
RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-audio-sdl.so:emulators/mupen64plus-audio-sdl \
${LOCALBASE}/lib/mupen64plus/mupen64plus-input-sdl.so:emulators/mupen64plus-input-sdl \
diff --git a/graphics/krita/Makefile b/graphics/krita/Makefile
index 7a13ca2cc26c..75ab5a299383 100644
--- a/graphics/krita/Makefile
+++ b/graphics/krita/Makefile
@@ -1,6 +1,6 @@
PORTNAME= krita
DISTVERSION= 5.1.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -33,7 +33,7 @@ LIB_DEPENDS= libImath.so:math/Imath \
libpng.so:graphics/png \
libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5 \
- libquazip1-qt5.so:archivers/quazip \
+ libquazip1-qt5.so:archivers/quazip@qt5 \
libraw.so:graphics/libraw \
libtiff.so:graphics/tiff \
libwebp.so:graphics/webp \
diff --git a/graphics/nomacs/Makefile b/graphics/nomacs/Makefile
index 276dbeab7ce6..8c42c56578e3 100644
--- a/graphics/nomacs/Makefile
+++ b/graphics/nomacs/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nomacs
PORTVERSION= 3.16
DISTVERSIONSUFFIX= .224
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
PATCH_SITES= https://github.com/nomacs/nomacs/commit/
@@ -17,7 +17,7 @@ LIB_DEPENDS= libexiv2.so:graphics/exiv2 \
libopencv_highgui.so:graphics/opencv \
libopencv_core.so:graphics/opencv \
liblcms2.so:graphics/lcms2 \
- libquazip1-qt5.so:archivers/quazip
+ libquazip1-qt5.so:archivers/quazip@qt5
USES= cmake compiler:c++11-lang cpe desktop-file-utils \
dos2unix pkgconfig qt:5