aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 13:16:47 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 13:36:24 +0000
commit9b7323194dc7771051de30dddb57755efc643cfc (patch)
tree7148ed8417274741634ee266cc1951bb74aa9427
parentd3cac3afe41fee0926b0c285b4832b3af7431a27 (diff)
downloadports-9b7323194dc7771051de30dddb57755efc643cfc.tar.gz
ports-9b7323194dc7771051de30dddb57755efc643cfc.zip
devel/py-ast-decompiler: Add py-ast-decompiler 0.7.0
ast_decompiler is a module for generating Python code given an AST.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ast-decompiler/Makefile22
-rw-r--r--devel/py-ast-decompiler/distinfo3
-rw-r--r--devel/py-ast-decompiler/pkg-descr1
4 files changed, 27 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ca6339f174e0..43ae8e9a486d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4203,6 +4203,7 @@
SUBDIR += py-asn1
SUBDIR += py-asn1crypto
SUBDIR += py-aspy.yaml
+ SUBDIR += py-ast-decompiler
SUBDIR += py-asteval
SUBDIR += py-astor
SUBDIR += py-astroid
diff --git a/devel/py-ast-decompiler/Makefile b/devel/py-ast-decompiler/Makefile
new file mode 100644
index 000000000000..1bb155aabc8e
--- /dev/null
+++ b/devel/py-ast-decompiler/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= ast-decompiler
+PORTVERSION= 0.7.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ast_decompiler-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python module to decompile AST to Python code
+WWW= https://github.com/JelleZijlstra/ast_decompiler
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.4<4:devel/py-flit-core@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-ast-decompiler/distinfo b/devel/py-ast-decompiler/distinfo
new file mode 100644
index 000000000000..bd49e83084e6
--- /dev/null
+++ b/devel/py-ast-decompiler/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680726000
+SHA256 (ast_decompiler-0.7.0.tar.gz) = efc3a507e5f8963ec7b4b2ce2ea693e3755c2f52b741c231bc344a4526738337
+SIZE (ast_decompiler-0.7.0.tar.gz) = 18413
diff --git a/devel/py-ast-decompiler/pkg-descr b/devel/py-ast-decompiler/pkg-descr
new file mode 100644
index 000000000000..a0f01872cf1b
--- /dev/null
+++ b/devel/py-ast-decompiler/pkg-descr
@@ -0,0 +1 @@
+ast_decompiler is a module for generating Python code given an AST.