aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2025-01-17 08:55:19 +0000
committerJason E. Hale <jhale@FreeBSD.org>2025-01-17 09:10:56 +0000
commit9bafae88262e317d6869cbad80d97703d8e887d2 (patch)
treec5da73d6480cf43c1fd928d44d3474c881cd7665
parenta143bb906b20a3f768934fe7fe710af5d7f1231f (diff)
graphics/gmic-qt: Update to 3.5.0
Switch to the offical gmic tarball which has included everything we need since version 2.2.2. This greatly simplifies the Makefile and reduces download overhead. Plus, Sébastien Fourey, the author of G'MIC-Qt sadly passed away in early October of last year, so we can no longer use his GitHub repo as a source. Rest in peace. Use Qt6 instead of Qt5. https://discuss.pixls.us/t/release-of-gmic-3-5/44490
-rw-r--r--graphics/gmic-qt/Makefile37
-rw-r--r--graphics/gmic-qt/distinfo12
2 files changed, 17 insertions, 32 deletions
diff --git a/graphics/gmic-qt/Makefile b/graphics/gmic-qt/Makefile
index 4d359fb8230c..67e24bfcbe36 100644
--- a/graphics/gmic-qt/Makefile
+++ b/graphics/gmic-qt/Makefile
@@ -1,16 +1,16 @@
PORTNAME= gmic-qt
DISTVERSIONPREFIX= v.
-DISTVERSION= 3.4.2
+DISTVERSION= 3.5.0
PORTEPOCH= 1
CATEGORIES= graphics kde
-MASTER_SITES= http://gmic.eu/:stdlib
-DISTFILES= gmic_stdlib_community${DISTVERSION:S/.//g}.h:stdlib
-DIST_SUBDIR= KDE/${PORTNAME}/${PORTVERSION}
-EXTRACT_ONLY= ${DISTNAME}.tar.gz ${DISTFILE_gmic} ${DISTFILE_cimg}
+MASTER_SITES= https://github.com/GreycLab/gmic/releases/download/${DISTVERSIONFULL}/ \
+ https://gmic.eu/files/source/
+DISTNAME= gmic_${DISTVERSION}
+DIST_SUBDIR= KDE/${PORTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= Versatile Qt front-end to G'MIC
-WWW= https://github.com/c-koi/gmic-qt
+WWW= https://gmic.eu
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -25,28 +25,24 @@ FLAVORS= none gimp # reflect the value of GMIC_QT_HOST for simplicity
FLAVOR?= ${FLAVORS:[1]}
gimp_PKGNAMESUFFIX= -gimp
-USES= cmake compiler:c++14-lang pkgconfig qt:5 shebangfix xorg
-USE_QT= core gui network widgets \
- buildtools:build linguisttools:build qmake:build
+USES= cmake compiler:c++17-lang gl pkgconfig qt:6 shebangfix xorg
+USE_GL= opengl
+USE_QT= base tools:build
USE_XORG= ice sm x11 xext
-USE_GITHUB= yes
-GH_ACCOUNT= c-koi
-GH_TUPLE= GreycLab:gmic:${DISTVERSIONFULL}:gmic/gmic \
- GreycLab:CImg:${DISTVERSIONFULL}:cimg
-
SHEBANG_FILES= translations/lrelease.sh \
translations/filters/csv2ts.sh \
translations/filters/ts2csv.sh
-# Use the extracted cimg/gmic & Co, as we do not want to depend on graphics/gimp
-# which would get pulled in by graphics/cimg.
-CMAKE_ARGS= -DGMIC_QT_HOST:STRING="${FLAVOR}" \
- -DGMIC_PATH:STRING="${WRKSRC_gmic}/src"
+CMAKE_ARGS= -DGMIC_QT_HOST:STRING="${FLAVOR}"
+CMAKE_ON= BUILD_WITH_QT6
CMAKE_OFF= ENABLE_SYSTEM_GMIC
PORTSCOUT= limit:[0-9]\..*
+WRKSRC= ${WRKDIR}/${DISTNAME:S|_|-|}
+WRKSRC_SUBDIR= ${PORTNAME}
+
.if ${FLAVOR} == gimp
LIB_DEPENDS+= libbabl-0.1.so:x11/babl \
libgegl-0.4.so:graphics/gegl \
@@ -61,9 +57,4 @@ PLUGINS_DIR= bin
PLIST_FILES= ${PLUGINS_DIR}/gmic_${FLAVOR:S/$/_/:S/none_//}qt
-pre-configure:
-# Copy the necessary files
- ${CP} ${WRKSRC_cimg}/CImg.h ${WRKSRC_gmic}/src
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/gmic_stdlib_community${DISTVERSION:S/.//g}.h ${WRKSRC_gmic}/src/gmic_stdlib_community.h
-
.include <bsd.port.mk>
diff --git a/graphics/gmic-qt/distinfo b/graphics/gmic-qt/distinfo
index 77ee14fc6408..b396ec56c663 100644
--- a/graphics/gmic-qt/distinfo
+++ b/graphics/gmic-qt/distinfo
@@ -1,9 +1,3 @@
-TIMESTAMP = 1725562066
-SHA256 (KDE/gmic-qt/3.4.2/gmic_stdlib_community342.h) = aaecd0d20ea499b245ca050e94a7539fd15ef49ee38652ce88d6a5d645f78876
-SIZE (KDE/gmic-qt/3.4.2/gmic_stdlib_community342.h) = 8036765
-SHA256 (KDE/gmic-qt/3.4.2/c-koi-gmic-qt-v.3.4.2_GH0.tar.gz) = be0a4b8d27b5f4349b6e1a1c8f79cf08b78a433c03cd47abbec9a40a716c8c90
-SIZE (KDE/gmic-qt/3.4.2/c-koi-gmic-qt-v.3.4.2_GH0.tar.gz) = 1456124
-SHA256 (KDE/gmic-qt/3.4.2/GreycLab-gmic-v.3.4.2_GH0.tar.gz) = 3924e7c536d3826903ad2a319102c547cf9f65d48fcc65f65173ed804e62304d
-SIZE (KDE/gmic-qt/3.4.2/GreycLab-gmic-v.3.4.2_GH0.tar.gz) = 123093705
-SHA256 (KDE/gmic-qt/3.4.2/GreycLab-CImg-v.3.4.2_GH0.tar.gz) = d427168370301f6d288d9e1c69fcc48d9d4919e977ac5c2ec013ae6ac5613efb
-SIZE (KDE/gmic-qt/3.4.2/GreycLab-CImg-v.3.4.2_GH0.tar.gz) = 12667857
+TIMESTAMP = 1737098773
+SHA256 (KDE/gmic-qt/gmic_3.5.0.tar.gz) = 847ddf438bbe73ec1447a8d98916571c75664bed050ac11212e45b2eb4c1cad0
+SIZE (KDE/gmic-qt/gmic_3.5.0.tar.gz) = 19705183