aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-05-04 06:06:46 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-05-04 06:13:32 +0000
commit9bca641885f5a98c33034719f5d1ac9f28c8bb7d (patch)
tree3ea84ee4d5094a7f70ca71ed75c2574c151b7212
parent688aaad7506f3a2690eef069a55b63a32caeed23 (diff)
downloadports-9bca641885f5a98c33034719f5d1ac9f28c8bb7d.tar.gz
ports-9bca641885f5a98c33034719f5d1ac9f28c8bb7d.zip
x11-wm/cage-devel: add new port
Supports wayvnc, uses wlroots 0.16 and wlr_scene API.
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/cage-devel/Makefile47
-rw-r--r--x11-wm/cage-devel/distinfo5
-rw-r--r--x11-wm/cage-devel/pkg-descr6
-rw-r--r--x11-wm/cage/Makefile2
5 files changed, 61 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 9730356163eb..1a1b2dcbb297 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -14,6 +14,7 @@
SUBDIR += bspwm
SUBDIR += bspwm-devel
SUBDIR += cage
+ SUBDIR += cage-devel
SUBDIR += cagebreak
SUBDIR += chamfer
SUBDIR += compiz
diff --git a/x11-wm/cage-devel/Makefile b/x11-wm/cage-devel/Makefile
new file mode 100644
index 000000000000..aaac700294d3
--- /dev/null
+++ b/x11-wm/cage-devel/Makefile
@@ -0,0 +1,47 @@
+PORTNAME= cage
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.4-54
+DISTVERSIONSUFFIX= -gbd5b20e
+CATEGORIES= x11-wm wayland
+PKGNAMESUFFIX= -devel
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 638d4fb71555.patch:-p1 # https://github.com/cage-kiosk/cage/pull/148
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Wayland kiosk (development snapshot)
+WWW= https://www.hjdskes.nl/projects/cage/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ wayland-protocols>=1.14:graphics/wayland-protocols \
+ wlroots>=0.16.0:x11-toolkits/wlroots
+LIB_DEPENDS= libwayland-server.so:graphics/wayland \
+ libwlroots.so:x11-toolkits/wlroots \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= cage-kiosk
+PLIST_FILES= bin/${PORTNAME}
+
+CONFLICTS_INSTALL= ${PORTNAME}
+
+OPTIONS_DEFINE= MANPAGES X11
+OPTIONS_DEFAULT=MANPAGES X11
+
+MANPAGES_BUILD_DEPENDS= scdoc>=1.9.2:textproc/scdoc
+MANPAGES_MESON_ENABLED= man-pages
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+X11_MESON_TRUE= xwayland
+
+post-patch:
+# Extract (snapshot) version from the port instead of meson.build
+ @${REINPLACE_CMD} -i .nogit -e 's/git.found()/false/' \
+ -e '/project_version/s/@0@/${DISTVERSIONFULL}/' \
+ ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/x11-wm/cage-devel/distinfo b/x11-wm/cage-devel/distinfo
new file mode 100644
index 000000000000..3d2be9ca9d61
--- /dev/null
+++ b/x11-wm/cage-devel/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1675207597
+SHA256 (cage-kiosk-cage-v0.1.4-54-gbd5b20e_GH0.tar.gz) = 8e1bb0539fa8eaeaa28db587ba606a0669e4345e29fade6e2fc9dad6c400bddf
+SIZE (cage-kiosk-cage-v0.1.4-54-gbd5b20e_GH0.tar.gz) = 22354
+SHA256 (638d4fb71555.patch) = 0730b618e248a453284df9c0d01378f3e3e16c8c4b453b2a8629a4b41f02cc65
+SIZE (638d4fb71555.patch) = 2232
diff --git a/x11-wm/cage-devel/pkg-descr b/x11-wm/cage-devel/pkg-descr
new file mode 100644
index 000000000000..8e84ca61c506
--- /dev/null
+++ b/x11-wm/cage-devel/pkg-descr
@@ -0,0 +1,6 @@
+Cage is a kiosk compositor for Wayland. A kiosk is a window manager
+(in the X11 world) or compositor (in the Wayland world) that is
+designed for a user experience wherein user interaction and activities
+outside the scope of the running application are prevented. That is, a
+kiosk compositor displays a single maximized application at a time and
+prevents the user from interacting with anything but this application.
diff --git a/x11-wm/cage/Makefile b/x11-wm/cage/Makefile
index d4787bf05c0e..37f4394d2d61 100644
--- a/x11-wm/cage/Makefile
+++ b/x11-wm/cage/Makefile
@@ -30,6 +30,8 @@ USE_XORG= pixman
GH_ACCOUNT= cage-kiosk
PLIST_FILES= bin/${PORTNAME}
+CONFLICTS_INSTALL= ${PORTNAME}-devel
+
OPTIONS_DEFINE= MANPAGES X11
OPTIONS_DEFAULT=MANPAGES X11