aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-07-27 20:00:44 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-07-27 20:04:56 +0000
commit9c85dbfe47abfa3c3025dd9bda79c0f058f47f37 (patch)
treea2d52a616e9227e0e1ffc149a918fa6ef3f7bb7a
parent1b009496c574b26976cd1ad3790f8354905700b9 (diff)
downloadports-9c85dbfe47abfa3c3025dd9bda79c0f058f47f37.tar.gz
ports-9c85dbfe47abfa3c3025dd9bda79c0f058f47f37.zip
www/libnghttp2: Update to 1.55.1
* Switch back to CMake for consistency with www/nghttp2 * Refresh CMake args Changelog: https://github.com/nghttp2/nghttp2/releases/tag/v1.55.1 PR: 272214 Approved by: portmgr (maintainer timeout, 2+ weeks) Sponsored by: Blinkinblox
-rw-r--r--www/libnghttp2/Makefile26
-rw-r--r--www/libnghttp2/distinfo6
-rw-r--r--www/libnghttp2/files/patch-CMakeLists.txt20
-rw-r--r--www/libnghttp2/files/patch-Makefile.in16
-rw-r--r--www/libnghttp2/pkg-plist2
5 files changed, 42 insertions, 28 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index 11aea1f84799..8e821abe0472 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nghttp2
-PORTVERSION= 1.54.0
+DISTVERSION= 1.55.1
CATEGORIES= www net
-MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -11,12 +11,22 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-
-CONFIGURE_ARGS= --enable-lib-only
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_CXXSTD= c++14
+USES= cmake compiler:c++14-lang cpe pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
+CMAKE_OFF= ENABLE_DOC \
+ ENABLE_FAILMALLOC \
+ ENABLE_HTTP3
+CMAKE_ON= ENABLE_LIB_ONLY \
+ ENABLE_STATIC_LIB \
+ CMAKE_DISABLE_FIND_PACKAGE_Jansson \
+ CMAKE_DISABLE_FIND_PACKAGE_Jemalloc \
+ CMAKE_DISABLE_FIND_PACKAGE_Libcares \
+ CMAKE_DISABLE_FIND_PACKAGE_Libev \
+ CMAKE_DISABLE_FIND_PACKAGE_Libevent \
+ CMAKE_DISABLE_FIND_PACKAGE_Libnghttp3 \
+ CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2 \
+ CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2_crypto_openssl \
+ CMAKE_DISABLE_FIND_PACKAGE_LibXml2
+
.include <bsd.port.mk>
diff --git a/www/libnghttp2/distinfo b/www/libnghttp2/distinfo
index e849787c9312..5c2a011d8ae6 100644
--- a/www/libnghttp2/distinfo
+++ b/www/libnghttp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1688166092
-SHA256 (nghttp2-1.54.0.tar.xz) = 20533c9354fbb6aa689b6aa0ddb77f91da1d242587444502832e1864308152df
-SIZE (nghttp2-1.54.0.tar.xz) = 1541460
+TIMESTAMP = 1689456353
+SHA256 (nghttp2-1.55.1.tar.xz) = 19490b7c8c2ded1cf7c3e3a54ef4304e3a7876ae2d950d60a81d0dc6053be419
+SIZE (nghttp2-1.55.1.tar.xz) = 1541884
diff --git a/www/libnghttp2/files/patch-CMakeLists.txt b/www/libnghttp2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9eb3864499c1
--- /dev/null
+++ b/www/libnghttp2/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2022-12-24 08:18:29 UTC
++++ CMakeLists.txt
+@@ -503,7 +503,7 @@ include_directories(
+ set(PKGDATADIR "${CMAKE_INSTALL_FULL_DATADIR}/${CMAKE_PROJECT_NAME}")
+ set(PKGLIBDIR "${CMAKE_INSTALL_FULL_LIBDIR}/${CMAKE_PROJECT_NAME}")
+
+-install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
++#install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
+
+ add_subdirectory(lib)
+ #add_subdirectory(lib/includes)
+@@ -519,7 +519,7 @@ if(ENABLE_DOC)
+ add_subdirectory(doc)
+ endif()
+ add_subdirectory(contrib)
+-add_subdirectory(script)
++#add_subdirectory(script)
+ add_subdirectory(bpf)
+
+
diff --git a/www/libnghttp2/files/patch-Makefile.in b/www/libnghttp2/files/patch-Makefile.in
deleted file mode 100644
index d4174dca7bda..000000000000
--- a/www/libnghttp2/files/patch-Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.in.orig 2023-02-13 12:02:52 UTC
-+++ Makefile.in
-@@ -448,11 +448,10 @@ top_srcdir = @top_srcdir@
- # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
- # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
- # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
--SUBDIRS = lib third-party src bpf examples tests integration-tests \
-- doc contrib script
-+SUBDIRS = lib
-
- ACLOCAL_AMFLAGS = -I m4
--dist_doc_DATA = README.rst
-+dist_doc_DATA =
- EXTRA_DIST = nghttpx.conf.sample proxy.pac.sample android-config android-env \
- Dockerfile.android \
- cmakeconfig.h.in \
diff --git a/www/libnghttp2/pkg-plist b/www/libnghttp2/pkg-plist
index ed807891ee4c..68891044db9d 100644
--- a/www/libnghttp2/pkg-plist
+++ b/www/libnghttp2/pkg-plist
@@ -3,5 +3,5 @@ include/nghttp2/nghttp2ver.h
lib/libnghttp2.a
lib/libnghttp2.so
lib/libnghttp2.so.14
-lib/libnghttp2.so.14.24.2
+lib/libnghttp2.so.14.24.3
libdata/pkgconfig/libnghttp2.pc