aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 09:59:42 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-28 10:21:23 +0000
commit9caf3d975792eb1bbd24383dab5b00780a3a918c (patch)
tree1c849ab30ecb6153e0e38557f3c05c14708c25af
parent51082a99431e026633bf221e3fb33a383c94dd5c (diff)
downloadports-9caf3d975792eb1bbd24383dab5b00780a3a918c.tar.gz
ports-9caf3d975792eb1bbd24383dab5b00780a3a918c.zip
archivers/unrar: Update to 7.01
-rw-r--r--archivers/unrar/Makefile4
-rw-r--r--archivers/unrar/distinfo6
-rw-r--r--archivers/unrar/files/patch-rijndael.cpp21
3 files changed, 16 insertions, 15 deletions
diff --git a/archivers/unrar/Makefile b/archivers/unrar/Makefile
index a618d03edb40..20561cf32ca5 100644
--- a/archivers/unrar/Makefile
+++ b/archivers/unrar/Makefile
@@ -1,9 +1,9 @@
PORTNAME= unrar
-PORTVERSION= 7.00
+PORTVERSION= 7.01
PORTEPOCH= 6
CATEGORIES= archivers
MASTER_SITES= https://www.rarlab.com/rar/
-DISTNAME= unrarsrc-7.0.7
+DISTNAME= unrarsrc-7.0.9
MAINTAINER?= sunpoet@FreeBSD.org
COMMENT= Extract, view & test RAR archives
diff --git a/archivers/unrar/distinfo b/archivers/unrar/distinfo
index 4103e4a3a998..a5deeaa4fa2f 100644
--- a/archivers/unrar/distinfo
+++ b/archivers/unrar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1709390346
-SHA256 (unrarsrc-7.0.7.tar.gz) = da95829c7e66fe461c06eb4bea8145e58d88d76909432d0875cd1ff86669f728
-SIZE (unrarsrc-7.0.7.tar.gz) = 258219
+TIMESTAMP = 1716448638
+SHA256 (unrarsrc-7.0.9.tar.gz) = 505c13f9e4c54c01546f2e29b2fcc2d7fabc856a060b81e5cdfe6012a9198326
+SIZE (unrarsrc-7.0.9.tar.gz) = 258287
diff --git a/archivers/unrar/files/patch-rijndael.cpp b/archivers/unrar/files/patch-rijndael.cpp
index 5a4d38cb0abf..87a02086af3c 100644
--- a/archivers/unrar/files/patch-rijndael.cpp
+++ b/archivers/unrar/files/patch-rijndael.cpp
@@ -1,4 +1,4 @@
---- rijndael.cpp.orig 2024-02-26 09:03:53 UTC
+--- rijndael.cpp.orig 2024-05-12 10:19:02 UTC
+++ rijndael.cpp
@@ -3,6 +3,7 @@
**************************************************************************/
@@ -16,7 +16,7 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
-@@ -82,20 +84,49 @@ Rijndael::Rijndael()
+@@ -82,21 +84,50 @@ Rijndael::Rijndael()
Rijndael::Rijndael()
{
@@ -24,6 +24,7 @@
if (S5[0]==0)
GenerateTables();
+#endif // OPENSSL_AES
+ m_uRounds = 0;
CBCMode = true; // Always true for RAR.
+#if !defined(OPENSSL_AES)
#ifdef USE_SSE
@@ -66,7 +67,7 @@
// Check SIMD here instead of constructor, so if object is a part of some
// structure memset'ed before use, these variables are not lost.
#if defined(USE_SSE)
-@@ -165,6 +196,7 @@ void Rijndael::Init(bool Encrypt,const byte *key,uint
+@@ -166,6 +197,7 @@ void Rijndael::Init(bool Encrypt,const byte *key,uint
if(!Encrypt)
keyEncToDec();
@@ -74,7 +75,7 @@
}
-@@ -173,6 +205,15 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
+@@ -174,6 +206,15 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
if (inputLen <= 0)
return;
@@ -90,7 +91,7 @@
size_t numBlocks = inputLen/16;
#if defined(USE_SSE)
if (AES_NI)
-@@ -237,9 +278,11 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
+@@ -238,9 +279,11 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
input += 16;
}
Copy128(m_initVector,prevBlock);
@@ -102,7 +103,7 @@
#ifdef USE_SSE
void Rijndael::blockEncryptSSE(const byte *input,size_t numBlocks,byte *outBuffer)
{
-@@ -305,6 +348,7 @@ void Rijndael::blockEncryptNeon(const byte *input,size
+@@ -306,6 +349,7 @@ void Rijndael::blockEncryptNeon(const byte *input,size
return;
}
#endif
@@ -110,7 +111,7 @@
void Rijndael::blockDecrypt(const byte *input, size_t inputLen, byte *outBuffer)
-@@ -312,6 +356,15 @@ void Rijndael::blockDecrypt(const byte *input, size_t
+@@ -313,6 +357,15 @@ void Rijndael::blockDecrypt(const byte *input, size_t
if (inputLen <= 0)
return;
@@ -126,7 +127,7 @@
size_t numBlocks=inputLen/16;
#if defined(USE_SSE)
if (AES_NI)
-@@ -380,9 +433,11 @@ void Rijndael::blockDecrypt(const byte *input, size_t
+@@ -381,9 +434,11 @@ void Rijndael::blockDecrypt(const byte *input, size_t
}
memcpy(m_initVector,iv,16);
@@ -138,7 +139,7 @@
#ifdef USE_SSE
void Rijndael::blockDecryptSSE(const byte *input, size_t numBlocks, byte *outBuffer)
{
-@@ -449,8 +504,10 @@ void Rijndael::blockDecryptNeon(const byte *input, siz
+@@ -450,8 +505,10 @@ void Rijndael::blockDecryptNeon(const byte *input, siz
memcpy(m_initVector,iv,16);
}
#endif
@@ -149,7 +150,7 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
// ALGORITHM
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
-@@ -579,6 +636,7 @@ void Rijndael::GenerateTables()
+@@ -580,6 +637,7 @@ void Rijndael::GenerateTables()
U1[b][0]=U2[b][1]=U3[b][2]=U4[b][3]=T5[I][0]=T6[I][1]=T7[I][2]=T8[I][3]=gmul(b,0xe);
}
}