aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2024-11-28 15:57:21 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2024-11-28 15:59:20 +0000
commit9cb153ab34840d98a13cde17c524498a70cdd7f3 (patch)
treef82d63d868d510bad8cf6211b8897f99d0b906f0
parent6f8be4c065a80c1c8bbd3fb56e82a673bfc7ce7f (diff)
downloadports-9cb153ab34840d98a13cde17c524498a70cdd7f3.tar.gz
ports-9cb153ab34840d98a13cde17c524498a70cdd7f3.zip
biology/ucsc-userapps: Update to v474
Several fixes and a few enhancements since v472 Changes: https://github.com/ucscGenomeBrowser/kent/releases Reported by: portscout
-rw-r--r--biology/ucsc-userapps/Makefile12
-rw-r--r--biology/ucsc-userapps/distinfo6
-rw-r--r--biology/ucsc-userapps/files/patch-kent_src_hg_lib_jksql.c14
3 files changed, 9 insertions, 23 deletions
diff --git a/biology/ucsc-userapps/Makefile b/biology/ucsc-userapps/Makefile
index 5d4fa1eb9df6..35f30e18f80d 100644
--- a/biology/ucsc-userapps/Makefile
+++ b/biology/ucsc-userapps/Makefile
@@ -1,18 +1,20 @@
PORTNAME= ucsc-userapps
-DISTVERSION= 472
+DISTVERSION= 474
CATEGORIES= biology perl5 python
-MASTER_SITES= http://hgdownload.cse.ucsc.edu/admin/exe/userApps.archive/
+MASTER_SITES= https://hgdownload.cse.ucsc.edu/admin/exe/userApps.archive/
DISTNAME= userApps.v${DISTVERSION}.src
MAINTAINER= jwb@FreeBSD.org
COMMENT= Command line tools from the UCSC Genome Browser project
WWW= https://hgdownload.cse.ucsc.edu/admin/exe/
-# Some tools in the source dist are non-free for commercial use.
-# If they are added, the license below must be changed and packaging forbidden.
+# Note: Some tools in the source dist are non-free for commercial use.
+# If they are added to the install, the license below must be changed
+# and packaging forbidden.
LICENSE= MIT
BUILD_DEPENDS= bash:shells/bash
+# FIXME: Switch from mysql to mariadb
LIB_DEPENDS= libmysqlclient.so:databases/mysql80-client \
libunwind.so:devel/libunwind \
libfreetype.so:print/freetype2 \
@@ -21,8 +23,6 @@ RUN_DEPENDS= bash:shells/bash
USES= gmake iconv localbase:ldflags shebangfix perl5 python:3.6+ ssl tar:tgz
-RESTRICTED= Redistribution is limited, see license
-
SHEBANG_FILES= kent/src/checkUmask.sh \
kent/src/utils/bigHeat \
kent/src/utils/chromToUcsc/chromToUcsc \
diff --git a/biology/ucsc-userapps/distinfo b/biology/ucsc-userapps/distinfo
index e5f22b962d6f..ea61209e348b 100644
--- a/biology/ucsc-userapps/distinfo
+++ b/biology/ucsc-userapps/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1730984296
-SHA256 (userApps.v472.src.tgz) = 26d126c51d0ba3165519b116b6461af8bfd938505f6c0871cb325a7ab82368f2
-SIZE (userApps.v472.src.tgz) = 24378966
+TIMESTAMP = 1732796640
+SHA256 (userApps.v474.src.tgz) = 87c465169b1246c3d2f56ea415461b7b2a4fb24bf5b7b95a3b590274cc7daec7
+SIZE (userApps.v474.src.tgz) = 24402279
diff --git a/biology/ucsc-userapps/files/patch-kent_src_hg_lib_jksql.c b/biology/ucsc-userapps/files/patch-kent_src_hg_lib_jksql.c
deleted file mode 100644
index e75057e7937c..000000000000
--- a/biology/ucsc-userapps/files/patch-kent_src_hg_lib_jksql.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- kent/src/hg/lib/jksql.c.orig 2024-10-16 04:15:27 UTC
-+++ kent/src/hg/lib/jksql.c
-@@ -1128,8 +1128,9 @@ if (sp->verifyServerCert && !sameString(sp->verifyServ
- // If turned on this can defeat Man-In-The-Middle attacks.
- if (sp->verifyServerCert && !sameString(sp->verifyServerCert,"0"))
- {
-- #if !defined(MARIADB_VERSION_ID) && MYSQL_VERSION_ID >= 80000
-- mysql_options(conn, MYSQL_OPT_SSL_MODE, SSL_MODE_REQUIRED);
-+ #if !defined(MARIADB_BASE_VERSION) && defined(MYSQL_VERSION_ID) && (MYSQL_VERSION_ID >= 80000)
-+ int ssl_mode = SSL_MODE_REQUIRED;
-+ mysql_options(conn, MYSQL_OPT_SSL_MODE, &ssl_mode);
- #else
- my_bool flag = TRUE;
- mysql_options(conn, MYSQL_OPT_SSL_VERIFY_SERVER_CERT, &flag);