aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-12-05 21:03:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-12-05 22:03:13 +0000
commit9cf68810b28307d8356b023152ee41cc6990fd23 (patch)
tree5ddf3b23890849e4c2feaf51849bb0222487ba14
parent864d4fdd1804d2d4f46619f781e397b9ccdf1639 (diff)
misc/opensubdiv: New port: Subdivision surface library for digital content creation
-rw-r--r--misc/Makefile1
-rw-r--r--misc/opensubdiv/Makefile27
-rw-r--r--misc/opensubdiv/distinfo3
-rw-r--r--misc/opensubdiv/pkg-descr7
-rw-r--r--misc/opensubdiv/pkg-plist81
5 files changed, 119 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index ce3d56f2bfae..bd4d788cc962 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -273,6 +273,7 @@
SUBDIR += openmvg
SUBDIR += opennn
SUBDIR += openr2
+ SUBDIR += opensubdiv
SUBDIR += openvdb
SUBDIR += orange3
SUBDIR += orion
diff --git a/misc/opensubdiv/Makefile b/misc/opensubdiv/Makefile
new file mode 100644
index 000000000000..16d52d253b4c
--- /dev/null
+++ b/misc/opensubdiv/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= opensubdiv
+DISTVERSIONPREFIX= v
+DISTVERSION= 3_4_4
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Subdivision surface library for digital content creation
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= glfw>0:graphics/glfw \
+ opencl>0:devel/opencl
+LIB_DEPENDS= libOpenCL.so:devel/ocl-icd \
+ libtbb.so:devel/tbb
+
+USES= cmake gl xorg
+USE_GL= gl
+USE_XORG= ice
+
+USE_GITHUB= yes
+GH_ACCOUNT= PixarAnimationStudios
+GH_PROJECT= OpenSubdiv
+
+CMAKE_ON= NO_EXAMPLES NO_TUTORIALS NO_REGRESSION NO_DOC NO_CUDA NO_TESTS NO_GLTESTS
+
+.include <bsd.port.mk>
diff --git a/misc/opensubdiv/distinfo b/misc/opensubdiv/distinfo
new file mode 100644
index 000000000000..b458f3d7cd7e
--- /dev/null
+++ b/misc/opensubdiv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1638735199
+SHA256 (PixarAnimationStudios-OpenSubdiv-v3_4_4_GH0.tar.gz) = 20d49f80a2b778ad4d01f091ad88d8c2f91cf6c7363940c6213241ce6f1048fb
+SIZE (PixarAnimationStudios-OpenSubdiv-v3_4_4_GH0.tar.gz) = 39228037
diff --git a/misc/opensubdiv/pkg-descr b/misc/opensubdiv/pkg-descr
new file mode 100644
index 000000000000..24834c271f17
--- /dev/null
+++ b/misc/opensubdiv/pkg-descr
@@ -0,0 +1,7 @@
+OpenSubdiv is a set of open source libraries that implement high performance
+subdivision surface (subdiv) evaluation on massively parallel CPU and GPU
+architectures. This codepath is optimized for drawing deforming subdivs with
+static topology at interactive framerates. The resulting limit surface matches
+Pixar's Renderman to numerical precision.
+
+WWW: http://graphics.pixar.com/opensubdiv
diff --git a/misc/opensubdiv/pkg-plist b/misc/opensubdiv/pkg-plist
new file mode 100644
index 000000000000..b7699f344b11
--- /dev/null
+++ b/misc/opensubdiv/pkg-plist
@@ -0,0 +1,81 @@
+bin/stringify
+include/opensubdiv/far/error.h
+include/opensubdiv/far/patchDescriptor.h
+include/opensubdiv/far/patchMap.h
+include/opensubdiv/far/patchParam.h
+include/opensubdiv/far/patchTable.h
+include/opensubdiv/far/patchTableFactory.h
+include/opensubdiv/far/primvarRefiner.h
+include/opensubdiv/far/ptexIndices.h
+include/opensubdiv/far/stencilTable.h
+include/opensubdiv/far/stencilTableFactory.h
+include/opensubdiv/far/topologyDescriptor.h
+include/opensubdiv/far/topologyLevel.h
+include/opensubdiv/far/topologyRefiner.h
+include/opensubdiv/far/topologyRefinerFactory.h
+include/opensubdiv/far/types.h
+include/opensubdiv/hbr/allocator.h
+include/opensubdiv/hbr/bilinear.h
+include/opensubdiv/hbr/catmark.h
+include/opensubdiv/hbr/cornerEdit.h
+include/opensubdiv/hbr/creaseEdit.h
+include/opensubdiv/hbr/face.h
+include/opensubdiv/hbr/faceEdit.h
+include/opensubdiv/hbr/fvarData.h
+include/opensubdiv/hbr/fvarEdit.h
+include/opensubdiv/hbr/halfedge.h
+include/opensubdiv/hbr/hierarchicalEdit.h
+include/opensubdiv/hbr/holeEdit.h
+include/opensubdiv/hbr/loop.h
+include/opensubdiv/hbr/mesh.h
+include/opensubdiv/hbr/subdivision.h
+include/opensubdiv/hbr/vertex.h
+include/opensubdiv/hbr/vertexEdit.h
+include/opensubdiv/osd/bufferDescriptor.h
+include/opensubdiv/osd/clEvaluator.h
+include/opensubdiv/osd/clGLVertexBuffer.h
+include/opensubdiv/osd/clPatchTable.h
+include/opensubdiv/osd/clVertexBuffer.h
+include/opensubdiv/osd/cpuEvaluator.h
+include/opensubdiv/osd/cpuGLVertexBuffer.h
+include/opensubdiv/osd/cpuPatchTable.h
+include/opensubdiv/osd/cpuVertexBuffer.h
+include/opensubdiv/osd/glComputeEvaluator.h
+include/opensubdiv/osd/glLegacyGregoryPatchTable.h
+include/opensubdiv/osd/glMesh.h
+include/opensubdiv/osd/glPatchTable.h
+include/opensubdiv/osd/glVertexBuffer.h
+include/opensubdiv/osd/glXFBEvaluator.h
+include/opensubdiv/osd/glslPatchShaderSource.h
+include/opensubdiv/osd/mesh.h
+include/opensubdiv/osd/nonCopyable.h
+include/opensubdiv/osd/ompEvaluator.h
+include/opensubdiv/osd/ompKernel.h
+include/opensubdiv/osd/opencl.h
+include/opensubdiv/osd/opengl.h
+include/opensubdiv/osd/tbbEvaluator.h
+include/opensubdiv/osd/tbbKernel.h
+include/opensubdiv/osd/types.h
+include/opensubdiv/sdc/bilinearScheme.h
+include/opensubdiv/sdc/catmarkScheme.h
+include/opensubdiv/sdc/crease.h
+include/opensubdiv/sdc/loopScheme.h
+include/opensubdiv/sdc/options.h
+include/opensubdiv/sdc/scheme.h
+include/opensubdiv/sdc/types.h
+include/opensubdiv/version.h
+include/opensubdiv/vtr/array.h
+include/opensubdiv/vtr/componentInterfaces.h
+include/opensubdiv/vtr/fvarLevel.h
+include/opensubdiv/vtr/fvarRefinement.h
+include/opensubdiv/vtr/level.h
+include/opensubdiv/vtr/refinement.h
+include/opensubdiv/vtr/sparseSelector.h
+include/opensubdiv/vtr/stackBuffer.h
+include/opensubdiv/vtr/types.h
+lib/libosdCPU.a
+lib/libosdCPU.so
+lib/libosdCPU.so.3.4.4
+lib/libosdGPU.a
+lib/libosdGPU.so
+lib/libosdGPU.so.3.4.4