aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 13:31:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 13:36:45 +0000
commit9d0199456c0e52ee3e221e998594da990bdb7362 (patch)
treeaf62c423905c940750e82d85ddb3dddbb78c35c2
parent7aab186cb87fc83c9268081ab0a826f46c578c70 (diff)
downloadports-9d0199456c0e52ee3e221e998594da990bdb7362.tar.gz
ports-9d0199456c0e52ee3e221e998594da990bdb7362.zip
devel/py-blinker: Update to 1.6
-rw-r--r--devel/py-blinker/Makefile11
-rw-r--r--devel/py-blinker/distinfo6
-rw-r--r--devel/py-blinker/pkg-descr2
3 files changed, 11 insertions, 8 deletions
diff --git a/devel/py-blinker/Makefile b/devel/py-blinker/Makefile
index 38a46a7dab50..99ad39144529 100644
--- a/devel/py-blinker/Makefile
+++ b/devel/py-blinker/Makefile
@@ -1,18 +1,23 @@
PORTNAME= blinker
-PORTVERSION= 1.5
+PORTVERSION= 1.6
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Fast, simple object-to-object and broadcast signaling
-WWW= https://pythonhosted.org/blinker/
+WWW= https://pythonhosted.org/blinker/ \
+ https://github.com/pallets-eco/blinker
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.2:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
+
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
diff --git a/devel/py-blinker/distinfo b/devel/py-blinker/distinfo
index 79e5e366a360..c8e875fab2e0 100644
--- a/devel/py-blinker/distinfo
+++ b/devel/py-blinker/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1658176306
-SHA256 (blinker-1.5.tar.gz) = 923e5e2f69c155f2cc42dafbbd70e16e3fde24d2d4aa2ab72fbe386238892462
-SIZE (blinker-1.5.tar.gz) = 27022
+TIMESTAMP = 1680726114
+SHA256 (blinker-1.6.tar.gz) = 5874afe21df4bae8885d31a0a6c4b5861910a575eae6176f051fbb9a6571481b
+SIZE (blinker-1.6.tar.gz) = 28511
diff --git a/devel/py-blinker/pkg-descr b/devel/py-blinker/pkg-descr
index a711f6d3b2ac..644b60822922 100644
--- a/devel/py-blinker/pkg-descr
+++ b/devel/py-blinker/pkg-descr
@@ -10,5 +10,3 @@ The core of Blinker is quite small but provides powerful features:
- sending arbitrary data payloads
- collecting return values from signal receivers
- thread safety
-
-See also: https://github.com/pallets-eco/blinker