aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2016-02-01 09:48:34 +0000
committerRenato Botelho <garga@FreeBSD.org>2016-02-01 09:48:34 +0000
commit9d2e434521cda063e31d2c1e475e3f623d79fc6c (patch)
treebd395496700398cd68226b34d78f1007ba78ec19
parent26b6d315dae0e96b78ac77a18c17822ae96d0504 (diff)
downloadports-9d2e434521cda063e31d2c1e475e3f623d79fc6c.tar.gz
ports-9d2e434521cda063e31d2c1e475e3f623d79fc6c.zip
Add a new option to conditionalize xconv installation
xconv is the only piece of xinetd written in perl, removing it from package also removes perl dependency. Add a new option, on by default to don't change current behavior, to select to install or not xconv. While here, re-generate patches using `make makepatch` to silence portlint PR: 205661 Approved by: maintainer timeout (> 30 days) Obtained from: pfSense Sponsored by: Rubicon Communications (Netgate)
Notes
Notes: svn path=/head/; revision=407691
-rw-r--r--security/xinetd/Makefile12
-rw-r--r--security/xinetd/files/patch-Makefile.in6
-rw-r--r--security/xinetd/files/patch-xinetd__builtins.c6
-rw-r--r--security/xinetd/files/patch-xinetd__xconfig.h4
-rw-r--r--security/xinetd/pkg-plist2
5 files changed, 17 insertions, 13 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index 3281cd5980be..06ffe8f14b82 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -14,16 +14,20 @@ GNU_CONFIGURE= yes
USE_RC_SUBR= xinetd
ALL_TARGET= build
CONFIGURE_ARGS+= --with-loadavg
+OPTIONS_SUB= yes
-USES= cpe shebangfix perl5
-USE_PERL5= run
+USES= cpe shebangfix
SHEBANG_FILES= ${WRKSRC}/xinetd/xconv.pl
-OPTIONS_DEFINE= IPV6 LIBWRAP
-OPTIONS_DEFAULT= LIBWRAP
+OPTIONS_DEFINE= IPV6 LIBWRAP XCONV
+OPTIONS_DEFAULT= LIBWRAP XCONV
+
+XCONV_DESC= Install xconv utility (requires perl)
IPV6_CONFIGURE_WITH= ipv6
LIBWRAP_CONFIGURE_WITH= libwrap
+XCONV_USES= perl5
+XCONV_USE= PERL5=run
post-patch:
@${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/xinetd/xconfig.h
diff --git a/security/xinetd/files/patch-Makefile.in b/security/xinetd/files/patch-Makefile.in
index 5ed041b80d44..18a06b907550 100644
--- a/security/xinetd/files/patch-Makefile.in
+++ b/security/xinetd/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Wed Jul 31 19:03:43 2002
-+++ Makefile.in Mon Aug 19 11:49:58 2002
-@@ -76,16 +76,14 @@
+--- Makefile.in.orig 2007-09-20 17:01:52 UTC
++++ Makefile.in
+@@ -77,16 +77,14 @@ install: build
for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
test -d $$i || mkdir -p $$i ; done
$(INSTALL_CMD) -m 755 xinetd/xinetd $(DAEMONDIR)
diff --git a/security/xinetd/files/patch-xinetd__builtins.c b/security/xinetd/files/patch-xinetd__builtins.c
index 49e31e8fce2c..c16e17e0e151 100644
--- a/security/xinetd/files/patch-xinetd__builtins.c
+++ b/security/xinetd/files/patch-xinetd__builtins.c
@@ -1,6 +1,6 @@
---- xinetd/builtins.c.orig 2013-10-03 16:04:32.562080623 +0400
-+++ xinetd/builtins.c 2013-10-03 16:04:57.297350342 +0400
-@@ -617,7 +617,7 @@
+--- xinetd/builtins.c.orig 2012-05-09 15:40:29 UTC
++++ xinetd/builtins.c
+@@ -617,7 +617,7 @@ static void tcpmux_handler( const struct
if( SC_IS_INTERNAL( scp ) ) {
SC_INTERNAL(scp, nserp);
} else {
diff --git a/security/xinetd/files/patch-xinetd__xconfig.h b/security/xinetd/files/patch-xinetd__xconfig.h
index 2f25829c7be8..187fb37bf752 100644
--- a/security/xinetd/files/patch-xinetd__xconfig.h
+++ b/security/xinetd/files/patch-xinetd__xconfig.h
@@ -1,5 +1,5 @@
---- xinetd/xconfig.h.orig Sun Sep 15 19:23:41 2002
-+++ xinetd/xconfig.h Sun Sep 15 19:23:55 2002
+--- xinetd/xconfig.h.orig 2003-02-19 17:29:28 UTC
++++ xinetd/xconfig.h
@@ -29,7 +29,7 @@
#endif
diff --git a/security/xinetd/pkg-plist b/security/xinetd/pkg-plist
index c08fd708c30f..a12dc02dd505 100644
--- a/security/xinetd/pkg-plist
+++ b/security/xinetd/pkg-plist
@@ -1,4 +1,4 @@
-bin/xconv
+%%XCONV%%bin/xconv
sbin/xinetd
man/man5/xinetd.conf.5.gz
man/man8/xconv.8.gz