aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2025-02-06 10:34:16 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2025-02-06 10:34:16 +0000
commit9f1b10984d4548be73309760bc932077d15dbb24 (patch)
tree59b197674982b2cf18eecbc8d9a5e4b9d71cd9b6
parentedd17f50f290e172552e99a53a32afdf8898f1af (diff)
net/krdc: Unbreak FREERDP option and make it a default option, fix dependencies
net/freerdp has been fixed in 94b44b66bdc7254a5520347a8f7849392990e838. Also fix dependencies. PR: 284602 Approved by: arrowd (kde, maintainer)
-rw-r--r--net/krdc/Makefile24
-rw-r--r--net/krdc/pkg-plist2
2 files changed, 16 insertions, 10 deletions
diff --git a/net/krdc/Makefile b/net/krdc/Makefile
index 5fdb13769cc5..b7b35e4cf36a 100644
--- a/net/krdc/Makefile
+++ b/net/krdc/Makefile
@@ -1,21 +1,26 @@
PORTNAME= krdc
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= RDP and VNC client for KDE
WWW= https://kde.org/applications/internet/krdc/
-LIB_DEPENDS= libvncserver.so:net/libvncserver \
+LIB_DEPENDS= libvncclient.so:net/libvncserver \
+ libxkbcommon.so:x11/libxkbcommon \
+ libwayland-client.so:graphics/wayland \
+ libwayland-cursor.so:graphics/wayland \
libssh.so:security/libssh
-USES= cmake compiler:c++11-lang desktop-file-utils gettext kde:6 \
+USES= cmake compiler:c++11-lang desktop-file-utils gettext gl kde:6 \
pkgconfig qt:6 shared-mime-info tar:xz xorg
+USE_GL= opengl
USE_KDE= activities bookmarks colorscheme completion config \
configwidgets coreaddons crash dnssd doctools i18n iconthemes \
- kcmutils notifications notifyconfig statusnotifieritem \
- wallet widgetsaddons xmlgui \
- ecm:build
+ jobwidgets kcmutils kio notifications notifyconfig service \
+ solid statusnotifieritem wallet widgetsaddons windowsystem \
+ xmlgui ecm:build
USE_QT= base declarative wayland
USE_XORG= x11
USE_LDCONFIG= yes
@@ -23,11 +28,12 @@ USE_LDCONFIG= yes
CMAKE_ON= WITH_VNC
OPTIONS_DEFINE= FREERDP DOCS
+OPTIONS_DEFAULT= FREERDP
OPTIONS_SUB= yes
-FREERDP_CMAKE_BOOL= WITH_RDP
FREERDP_DESC= Remote Desktop support via FreeRDP
-FREERDP_BUILD_DEPENDS= xfreerdp:net/freerdp
-FREERDP_RUN_DEPENDS= xfreerdp:net/freerdp
-FREERDP_BROKEN= net/freerdp2 has broken cmake files
+FREERDP_LIB_DEPENDS= libfreerdp2.so:net/freerdp \
+ libfreerdp-client2.so:net/freerdp \
+ libwinpr2.so:net/freerdp
+FREERDP_CMAKE_BOOL= WITH_RDP
.include <bsd.port.mk>
diff --git a/net/krdc/pkg-plist b/net/krdc/pkg-plist
index f46c7d072e82..3a66c6dad10e 100644
--- a/net/krdc/pkg-plist
+++ b/net/krdc/pkg-plist
@@ -10,7 +10,7 @@ lib/libkrdccore.so.5
%%QT_PLUGINDIR%%/krdc/kcms/libkcm_krdc_vncplugin.so
%%QT_PLUGINDIR%%/krdc/krdc_testplugin.so
%%QT_PLUGINDIR%%/krdc/krdc_vncplugin.so
-%%FREERDP%%%%QT_PLUGINDIR%%/krdc/libkrdc_rdpplugin.so
+%%FREERDP%%%%QT_PLUGINDIR%%/krdc/krdc_rdpplugin.so
share/applications/org.kde.krdc.desktop
share/config.kcfg/krdc.kcfg
share/locale/af/LC_MESSAGES/krdc.mo