aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-11-11 19:44:43 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-11-11 19:44:43 +0000
commita0ff809a2bda235a69ed468b01543c45a57b6f8c (patch)
tree95d31287bd78b0c545d21012d0d6402809b7f4d5
parentee9ee2d99d5f055a07b46fe474397afd234f6dc8 (diff)
downloadports-a0ff809a2bda235a69ed468b01543c45a57b6f8c.tar.gz
ports-a0ff809a2bda235a69ed468b01543c45a57b6f8c.zip
misc/vote: new port -- a simple, transparent git based voting system
Teams like core and portmgr regularly hold votes on certain topics. In the past these votes were held via email. This script tries to lessen the burden of the secretary of those teams. Vote's can be created using: > vote create <vote topic> <due date in YYYYMMDD> <some more text> People can vote using > vote vote <vid> <yes/no/abstain> People can also vote in-stead of other people > vote votefor <vid> <yes/no/abstain> <whom> All votes and results are neatly tracked inside a git repository.
-rw-r--r--misc/Makefile1
-rw-r--r--misc/vote/Makefile16
-rw-r--r--misc/vote/distinfo3
-rw-r--r--misc/vote/pkg-descr1
4 files changed, 21 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 62f5ac79115a..caf51b51cfbc 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -544,6 +544,7 @@
SUBDIR += vifm
SUBDIR += visp
SUBDIR += viz
+ SUBDIR += vote
SUBDIR += vxl
SUBDIR += wego
SUBDIR += whichman
diff --git a/misc/vote/Makefile b/misc/vote/Makefile
new file mode 100644
index 000000000000..9f9a4b897479
--- /dev/null
+++ b/misc/vote/Makefile
@@ -0,0 +1,16 @@
+PORTNAME= vote
+DISTVERSION= 1.1
+CATEGORIES= misc
+MASTER_SITES= https://codeberg.org/tcberner/${PORTNAME}/archive/
+
+MAINTAINER= tcberner@FreeBSD.org
+COMMENT= Transparent git based voting system
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/vote
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/vote/vote ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/vote/distinfo b/misc/vote/distinfo
new file mode 100644
index 000000000000..d9414c8ce104
--- /dev/null
+++ b/misc/vote/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1668195518
+SHA256 (vote-1.1.tar.gz) = de2ad0d28cf777239fdb7e6c7c44a5dda528283bef6b807ade5ca02246497705
+SIZE (vote-1.1.tar.gz) = 5196
diff --git a/misc/vote/pkg-descr b/misc/vote/pkg-descr
new file mode 100644
index 000000000000..c373668d2e00
--- /dev/null
+++ b/misc/vote/pkg-descr
@@ -0,0 +1 @@
+Transparent git-based vote tool for FreeBSD's teams.