aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-11-24 10:56:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-11-24 11:09:16 +0000
commita2130025a44cb526e9a42f81e3a97de0d2c50092 (patch)
tree0a9fd8aecaffc9b51a5cdf4c4bb7e2100a1f2b7e
parentcf11e8c92b9d4b6d49d9a8d1a3583c4419df52c1 (diff)
downloadports-a2130025a44cb526e9a42f81e3a97de0d2c50092.tar.gz
ports-a2130025a44cb526e9a42f81e3a97de0d2c50092.zip
devel/libmcfp: New port: C++ header only library to parse command line arguments
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libmcfp/Makefile24
-rw-r--r--devel/libmcfp/distinfo3
-rw-r--r--devel/libmcfp/pkg-descr2
-rw-r--r--devel/libmcfp/pkg-plist7
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7c17a6155677..acdafe337a36 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1258,6 +1258,7 @@
SUBDIR += libmatheval
SUBDIR += libmatthew
SUBDIR += libmba
+ SUBDIR += libmcfp
SUBDIR += libmill
SUBDIR += libmimedir
SUBDIR += libmodi
diff --git a/devel/libmcfp/Makefile b/devel/libmcfp/Makefile
new file mode 100644
index 000000000000..8b9054ea5014
--- /dev/null
+++ b/devel/libmcfp/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= libmcfp
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.2
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ header only library to parse command line arguments
+WWW= https://github.com/mhekkel/libmcfp
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${LOCALBASE}/include/boost/test/included/unit_test.hpp:devel/boost-libs
+
+USES= cmake:testing localbase
+
+USE_GITHUB= yes
+GH_ACCOUNT= mhekkel
+
+CMAKE_TESTING_ON= ENABLE_TESTING
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libmcfp/distinfo b/devel/libmcfp/distinfo
new file mode 100644
index 000000000000..4516158056e3
--- /dev/null
+++ b/devel/libmcfp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1669286645
+SHA256 (mhekkel-libmcfp-v1.2.2_GH0.tar.gz) = 688f1235f4881c6a2ad8b3f543bed4a9bec2f38191363843db68b1710b610b8e
+SIZE (mhekkel-libmcfp-v1.2.2_GH0.tar.gz) = 14695
diff --git a/devel/libmcfp/pkg-descr b/devel/libmcfp/pkg-descr
new file mode 100644
index 000000000000..cbc91fb0b119
--- /dev/null
+++ b/devel/libmcfp/pkg-descr
@@ -0,0 +1,2 @@
+libmcfp is a library for parsing command line arguments and configuration files
+and making them available throughout a program.
diff --git a/devel/libmcfp/pkg-plist b/devel/libmcfp/pkg-plist
new file mode 100644
index 000000000000..55c0b29c5bae
--- /dev/null
+++ b/devel/libmcfp/pkg-plist
@@ -0,0 +1,7 @@
+include/mcfp.hpp
+include/mcfp/mcfp.hpp
+include/mcfp/text.hpp
+include/mcfp/utilities.hpp
+lib/cmake/libmcfp/libmcfpConfig.cmake
+lib/cmake/libmcfp/libmcfpConfigVersion.cmake
+lib/cmake/libmcfp/libmcfpTargets.cmake