aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-21 17:59:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-21 18:12:13 +0000
commita24d20e152896128086ef501a6412dcaa9174a87 (patch)
treeb34415d590ace29c511960b8381b0063b487507c
parentfa3cd60121f67b7d15394eb616a123a827e50b46 (diff)
downloadports-a24d20e152896128086ef501a6412dcaa9174a87.tar.gz
ports-a24d20e152896128086ef501a6412dcaa9174a87.zip
devel/rubygem-opt_parse_validator: Fix gemspec for rubygem-addressable 2.8.0 update
- Bump PORTREVISION for package change
-rw-r--r--devel/rubygem-opt_parse_validator/Makefile3
-rw-r--r--devel/rubygem-opt_parse_validator/files/patch-gemspec11
2 files changed, 13 insertions, 1 deletions
diff --git a/devel/rubygem-opt_parse_validator/Makefile b/devel/rubygem-opt_parse_validator/Makefile
index d15be3235d29..69a255cf381d 100644
--- a/devel/rubygem-opt_parse_validator/Makefile
+++ b/devel/rubygem-opt_parse_validator/Makefile
@@ -1,5 +1,6 @@
PORTNAME= opt_parse_validator
PORTVERSION= 1.9.3
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
@@ -10,7 +11,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-activesupport60>=5.2<6.2.0:devel/rubygem-activesupport60 \
- rubygem-addressable>=2.5<2.8:www/rubygem-addressable
+ rubygem-addressable>=2.5<2.9:www/rubygem-addressable
USES= gem
USE_RUBY= yes
diff --git a/devel/rubygem-opt_parse_validator/files/patch-gemspec b/devel/rubygem-opt_parse_validator/files/patch-gemspec
new file mode 100644
index 000000000000..8e83b323a1bc
--- /dev/null
+++ b/devel/rubygem-opt_parse_validator/files/patch-gemspec
@@ -0,0 +1,11 @@
+--- opt_parse_validator.gemspec.orig 2021-07-19 18:01:07 UTC
++++ opt_parse_validator.gemspec
+@@ -23,7 +23,7 @@ Gem::Specification.new do |s|
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<activesupport>.freeze, [">= 5.2", "< 6.2.0"])
+- s.add_runtime_dependency(%q<addressable>.freeze, [">= 2.5", "< 2.8"])
++ s.add_runtime_dependency(%q<addressable>.freeze, [">= 2.5", "< 2.9"])
+ s.add_development_dependency(%q<bundler>.freeze, [">= 1.6"])
+ s.add_development_dependency(%q<rake>.freeze, ["~> 13.0"])
+ s.add_development_dependency(%q<rspec>.freeze, ["~> 3.10.0"])