aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2022-07-06 06:17:30 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2022-07-06 06:18:47 +0000
commita2c16e6ad7b1ba3d4bde5a312c11629d1c136401 (patch)
tree29ea3c5a04faa9bba4cec8c581c6ee220b6a993b
parente6b8eba2ffe1733748eba080a83588ba7fdcd256 (diff)
downloadports-a2c16e6ad7b1ba3d4bde5a312c11629d1c136401.tar.gz
ports-a2c16e6ad7b1ba3d4bde5a312c11629d1c136401.zip
devel/electron19: update to 19.0.7
-rw-r--r--devel/electron19/Makefile11
-rw-r--r--devel/electron19/Makefile.version2
-rw-r--r--devel/electron19/distinfo16
-rw-r--r--devel/electron19/files/package.json2
-rw-r--r--devel/electron19/files/patch-electron_BUILD.gn16
-rw-r--r--devel/electron19/files/patch-electron_shell_browser_api_electron__api__web__contents.cc14
-rw-r--r--devel/electron19/files/patch-electron_shell_browser_electron__browser__client.cc4
-rw-r--r--devel/electron19/files/patch-electron_shell_browser_native__window__views.cc16
-rw-r--r--devel/electron19/files/patch-electron_spec-main_chromium-spec.ts6
9 files changed, 47 insertions, 40 deletions
diff --git a/devel/electron19/Makefile b/devel/electron19/Makefile
index 6597131e4d8f..4629acc4fb7f 100644
--- a/devel/electron19/Makefile
+++ b/devel/electron19/Makefile
@@ -2,10 +2,12 @@ PORTNAME= electron
DISTVERSIONPREFIX= v
DISTVERSION= ${ELECTRON_VER:S/-beta./.b/}
CATEGORIES= devel
-MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/:chromium \
+MASTER_SITES= https://github.com/tagattie/FreeBSD-Electron/releases/download/v19.0.7/:chromium \
+ https://commondatastorage.googleapis.com/chromium-nodejs/:chromium_node \
https://commondatastorage.googleapis.com/chromium-fonts/:chromium_testfonts
PKGNAMESUFFIX= ${ELECTRON_VER_MAJOR}
DISTFILES= chromium-${CHROMIUM_VER}${EXTRACT_SUFX}:chromium \
+ ${CHROMIUM_NODE_MODULES_HASH}:chromium_node \
${CHROMIUM_TEST_FONTS_HASH}:chromium_testfonts \
electron-yarn-cache-${ELECTRON_VER}${EXTRACT_SUFX}:prefetch
DIST_SUBDIR= ${PORTNAME}
@@ -135,7 +137,9 @@ SNDIO_VARS= GN_ARGS+=use_sndio=true
SNDIO_VARS_OFF= GN_ARGS+=use_sndio=false
# See ${WRKSRC}/electron/DEPS for CHROMIUM_VER
-CHROMIUM_VER= 102.0.5005.115
+CHROMIUM_VER= 102.0.5005.134
+# See ${WRKSRC}/third_party/node/node_modules.tar.gz.sha1 for CHROMIUM_NODE_MODULES_HASH
+CHROMIUM_NODE_MODULES_HASH= df473d4b1ab26ce6b669007521f2ffb8ff99f9d7
# See ${WRKSRC}/third_party/test_fonts/test_fonts.tar.gz.sha1 for CHROMIUM_TEST_FONTS_HASH
CHROMIUM_TEST_FONTS_HASH= cd96fc55dc243f6c6f4cb63ad117cad6cd48dceb
# See ${WRKSRC}/electron/DEPS for NODE_VER
@@ -149,7 +153,7 @@ REACTIVEOBJC_VER= 74ab5baccc6f7202c8ac69a8d1e152c29dc1ea76
# See ${WRKSRC}/electron/DEPS for MANTLE_VER
MANTLE_VER= 78d3966b3c331292ea29ec38661b25df0a245948
-YARN_TIMESTAMP= 1656133689
+YARN_TIMESTAMP= 1656908896
GN_ARGS+= clang_use_chrome_plugins=false \
enable_hangout_services_extension=true \
@@ -242,6 +246,7 @@ post-extract:
${WRKSRC}/third_party/squirrel.mac/vendor/ReactiveObjC
${MV} ${WRKDIR}/${PORTNAME}-${ELECTRON_VER}/${GH_PROJECT_mantle}-${MANTLE_VER} \
${WRKSRC}/third_party/squirrel.mac/vendor/Mantle
+ ${MV} ${WRKDIR}/${PORTNAME}-${ELECTRON_VER}/node_modules ${WRKSRC}/third_party/node
${MV} ${WRKDIR}/${PORTNAME}-${ELECTRON_VER}/test_fonts ${WRKSRC}/third_party/test_fonts
# Install node modules for electron
${MV} ${WRKDIR}/${PORTNAME}-${ELECTRON_VER}/yarn-offline-cache ${WRKDIR}
diff --git a/devel/electron19/Makefile.version b/devel/electron19/Makefile.version
index cc089f054f6e..1ea45ee3c319 100644
--- a/devel/electron19/Makefile.version
+++ b/devel/electron19/Makefile.version
@@ -1,2 +1,2 @@
-ELECTRON_VER= 19.0.6
+ELECTRON_VER= 19.0.7
ELECTRON_VER_MAJOR= ${ELECTRON_VER:C/\..*//}
diff --git a/devel/electron19/distinfo b/devel/electron19/distinfo
index 6422d931bccf..0980d810bc82 100644
--- a/devel/electron19/distinfo
+++ b/devel/electron19/distinfo
@@ -1,12 +1,14 @@
-TIMESTAMP = 1656134761
-SHA256 (electron/chromium-102.0.5005.115.tar.xz) = 301d40e5373b6dad9bc6aeb6898116d1f7dd2d0589ed18e108c56e2290df47e6
-SIZE (electron/chromium-102.0.5005.115.tar.xz) = 1461900356
+TIMESTAMP = 1656921150
+SHA256 (electron/chromium-102.0.5005.134.tar.xz) = d3791c8c87ee355d541be2f58562c433f57bfee877d4ec21bea62b7097ac821a
+SIZE (electron/chromium-102.0.5005.134.tar.xz) = 1302386848
+SHA256 (electron/df473d4b1ab26ce6b669007521f2ffb8ff99f9d7) = 38fa60c59a8398ae33f8d12c1234735a74dc3c8d0c6d4bc7a9c212c2b4b7fef8
+SIZE (electron/df473d4b1ab26ce6b669007521f2ffb8ff99f9d7) = 12046529
SHA256 (electron/cd96fc55dc243f6c6f4cb63ad117cad6cd48dceb) = ec973eccd669d417fbf2d0a4dac730744a3174268ff062db5451b55c82bc3492
SIZE (electron/cd96fc55dc243f6c6f4cb63ad117cad6cd48dceb) = 26759650
-SHA256 (electron/electron-yarn-cache-19.0.6.tar.xz) = d86db9a915f339df32b03da8ae6829a1cf905780642227e1a619f8fefa010eb1
-SIZE (electron/electron-yarn-cache-19.0.6.tar.xz) = 37911760
-SHA256 (electron/electron-electron-v19.0.6_GH0.tar.gz) = 5246401b1b64497947b4a9d14b98605064894453ac97efdffa025e7f1d1d8f41
-SIZE (electron/electron-electron-v19.0.6_GH0.tar.gz) = 10169676
+SHA256 (electron/electron-yarn-cache-19.0.7.tar.xz) = 0ae120cef545bc25f4471b590e43b54b530fb49a5f3072ddcb0ad248e68b7ebf
+SIZE (electron/electron-yarn-cache-19.0.7.tar.xz) = 37911736
+SHA256 (electron/electron-electron-v19.0.7_GH0.tar.gz) = 073e27bdd1fb0fd766156b19e82c026f112a3a44c26c3e9e2436d16b3dc31461
+SIZE (electron/electron-electron-v19.0.7_GH0.tar.gz) = 10507900
SHA256 (electron/nodejs-node-v16.14.2_GH0.tar.gz) = cc2331a5c35d3dda0035d9cba71c3b8e234bc68e18ffd955b385c1e97062528f
SIZE (electron/nodejs-node-v16.14.2_GH0.tar.gz) = 88432213
SHA256 (electron/nodejs-nan-65b32af46e9d7fab2e4ff657751205b3865f4920_GH0.tar.gz) = a649b75bfa9c1a0254c73d022c6e98924b9471f593bcc83832daaf68da4cae8d
diff --git a/devel/electron19/files/package.json b/devel/electron19/files/package.json
index 61b47f9120a4..232a54d8c843 100644
--- a/devel/electron19/files/package.json
+++ b/devel/electron19/files/package.json
@@ -1,6 +1,6 @@
{
"name": "electron",
- "version": "19.0.6",
+ "version": "19.0.7",
"repository": "https://github.com/electron/electron",
"description": "Build cross platform desktop apps with JavaScript, HTML, and CSS",
"devDependencies": {
diff --git a/devel/electron19/files/patch-electron_BUILD.gn b/devel/electron19/files/patch-electron_BUILD.gn
index ec9c65d226d0..c3c25476648a 100644
--- a/devel/electron19/files/patch-electron_BUILD.gn
+++ b/devel/electron19/files/patch-electron_BUILD.gn
@@ -1,6 +1,6 @@
---- electron/BUILD.gn.orig 2022-06-22 15:31:07 UTC
+--- electron/BUILD.gn.orig 2022-06-30 15:53:29 UTC
+++ electron/BUILD.gn
-@@ -447,7 +447,7 @@ source_set("electron_lib") {
+@@ -448,7 +448,7 @@ source_set("electron_lib") {
defines += [ "GDK_DISABLE_DEPRECATION_WARNINGS" ]
}
@@ -9,7 +9,7 @@
deps += [
"//components/crash/core/app",
"//components/crash/core/browser",
-@@ -489,6 +489,10 @@ source_set("electron_lib") {
+@@ -490,6 +490,10 @@ source_set("electron_lib") {
]
}
@@ -20,7 +20,7 @@
if (is_mac) {
deps += [
"//components/remote_cocoa/app_shim",
-@@ -545,6 +549,12 @@ source_set("electron_lib") {
+@@ -546,6 +550,12 @@ source_set("electron_lib") {
cflags_objcc = [ "-fobjc-weak" ]
}
}
@@ -33,7 +33,7 @@
if (is_linux) {
libs = [ "xshmfence" ]
deps += [
-@@ -1179,7 +1189,7 @@ if (is_mac) {
+@@ -1180,7 +1190,7 @@ if (is_mac) {
":electron_app_manifest",
":electron_lib",
":packed_resources",
@@ -42,7 +42,7 @@
"//content:sandbox_helper_win",
"//electron/buildflags",
"//ui/strings",
-@@ -1205,7 +1215,7 @@ if (is_mac) {
+@@ -1206,7 +1216,7 @@ if (is_mac) {
public_deps = [ "//tools/v8_context_snapshot:v8_context_snapshot" ]
}
@@ -51,7 +51,7 @@
data_deps += [ "//components/crash/core/app:chrome_crashpad_handler" ]
}
-@@ -1273,7 +1283,7 @@ if (is_mac) {
+@@ -1274,7 +1284,7 @@ if (is_mac) {
configs += [ "//build/config/gcc:rpath_for_built_shared_libraries" ]
}
@@ -60,7 +60,7 @@
deps += [ "//sandbox/linux:chrome_sandbox" ]
}
}
-@@ -1405,7 +1415,7 @@ dist_zip("electron_dist_zip") {
+@@ -1406,7 +1416,7 @@ dist_zip("electron_dist_zip") {
":electron_version",
":licenses",
]
diff --git a/devel/electron19/files/patch-electron_shell_browser_api_electron__api__web__contents.cc b/devel/electron19/files/patch-electron_shell_browser_api_electron__api__web__contents.cc
index bd1b265cf79a..6c6a48b70a37 100644
--- a/devel/electron19/files/patch-electron_shell_browser_api_electron__api__web__contents.cc
+++ b/devel/electron19/files/patch-electron_shell_browser_api_electron__api__web__contents.cc
@@ -1,6 +1,6 @@
---- electron/shell/browser/api/electron_api_web_contents.cc.orig 2022-06-08 15:30:58 UTC
+--- electron/shell/browser/api/electron_api_web_contents.cc.orig 2022-06-30 15:53:29 UTC
+++ electron/shell/browser/api/electron_api_web_contents.cc
-@@ -149,11 +149,11 @@
+@@ -150,11 +150,11 @@
#include "ui/base/cocoa/defaults_utils.h"
#endif
@@ -14,7 +14,7 @@
#include "ui/gfx/font_render_params.h"
#endif
-@@ -394,7 +394,7 @@ absl::optional<base::TimeDelta> GetCursorBlinkInterval
+@@ -395,7 +395,7 @@ absl::optional<base::TimeDelta> GetCursorBlinkInterval
ui::TextInsertionCaretBlinkPeriodFromDefaults());
if (system_value)
return *system_value;
@@ -23,7 +23,7 @@
if (auto* linux_ui = views::LinuxUI::instance())
return linux_ui->GetCursorBlinkInterval();
#elif BUILDFLAG(IS_WIN)
-@@ -832,7 +832,7 @@ void WebContents::InitWithSessionAndOptions(
+@@ -834,7 +834,7 @@ void WebContents::InitWithSessionAndOptions(
accept_languages.pop_back();
prefs->accept_languages = accept_languages;
@@ -32,7 +32,7 @@
// Update font settings.
static const gfx::FontRenderParams params(
gfx::GetFontRenderParams(gfx::FontRenderParamsQuery(), nullptr));
-@@ -2358,7 +2358,7 @@ void WebContents::ForcefullyCrashRenderer() {
+@@ -2360,7 +2360,7 @@ void WebContents::ForcefullyCrashRenderer() {
content::RenderProcessHost* rph = rwh->GetProcess();
if (rph) {
@@ -41,7 +41,7 @@
// A generic |CrashDumpHungChildProcess()| is not implemented for Linux.
// Instead we send an explicit IPC to crash on the renderer's IO thread.
rph->ForceCrash();
-@@ -2930,7 +2930,7 @@ void WebContents::CopyImageAt(int x, int y) {
+@@ -2936,7 +2936,7 @@ void WebContents::CopyImageAt(int x, int y) {
void WebContents::Focus() {
// Focusing on WebContents does not automatically focus the window on macOS
// and Linux, do it manually to match the behavior on Windows.
@@ -50,7 +50,7 @@
if (owner_window())
owner_window()->Focus(true);
#endif
-@@ -3763,7 +3763,7 @@ ui::ImageModel WebContents::GetDevToolsWindowIcon() {
+@@ -3769,7 +3769,7 @@ ui::ImageModel WebContents::GetDevToolsWindowIcon() {
}
#endif
diff --git a/devel/electron19/files/patch-electron_shell_browser_electron__browser__client.cc b/devel/electron19/files/patch-electron_shell_browser_electron__browser__client.cc
index ec451aa2be85..e8df547c64ba 100644
--- a/devel/electron19/files/patch-electron_shell_browser_electron__browser__client.cc
+++ b/devel/electron19/files/patch-electron_shell_browser_electron__browser__client.cc
@@ -1,6 +1,6 @@
---- electron/shell/browser/electron_browser_client.cc.orig 2022-06-08 15:30:58 UTC
+--- electron/shell/browser/electron_browser_client.cc.orig 2022-06-30 15:53:29 UTC
+++ electron/shell/browser/electron_browser_client.cc
-@@ -185,7 +185,7 @@
+@@ -186,7 +186,7 @@
#include "content/public/common/child_process_host.h"
#endif
diff --git a/devel/electron19/files/patch-electron_shell_browser_native__window__views.cc b/devel/electron19/files/patch-electron_shell_browser_native__window__views.cc
index 6565d7dab65c..a54bb6e73baf 100644
--- a/devel/electron19/files/patch-electron_shell_browser_native__window__views.cc
+++ b/devel/electron19/files/patch-electron_shell_browser_native__window__views.cc
@@ -1,4 +1,4 @@
---- electron/shell/browser/native_window_views.cc.orig 2022-06-08 15:30:58 UTC
+--- electron/shell/browser/native_window_views.cc.orig 2022-06-30 15:53:29 UTC
+++ electron/shell/browser/native_window_views.cc
@@ -43,7 +43,7 @@
#include "ui/wm/core/shadow_types.h"
@@ -63,7 +63,7 @@
// On Linux and Windows the minimum and maximum size should be updated with
// window size when window is not resizable.
if (!resizable_) {
-@@ -940,7 +940,7 @@ bool NativeWindowViews::IsClosable() {
+@@ -955,7 +955,7 @@ bool NativeWindowViews::IsClosable() {
return false;
}
return !(info.fState & MFS_DISABLED);
@@ -72,7 +72,7 @@
return true;
#endif
}
-@@ -1332,7 +1332,7 @@ void NativeWindowViews::SetProgressBar(double progress
+@@ -1347,7 +1347,7 @@ void NativeWindowViews::SetProgressBar(double progress
NativeWindow::ProgressState state) {
#if BUILDFLAG(IS_WIN)
taskbar_host_.SetProgressBar(GetAcceleratedWidget(), progress, state);
@@ -81,7 +81,7 @@
if (unity::IsRunning()) {
unity::SetProgressFraction(progress);
}
-@@ -1394,7 +1394,7 @@ content::DesktopMediaID NativeWindowViews::GetDesktopM
+@@ -1409,7 +1409,7 @@ content::DesktopMediaID NativeWindowViews::GetDesktopM
#if BUILDFLAG(IS_WIN)
window_handle =
reinterpret_cast<content::DesktopMediaID::Id>(accelerated_widget);
@@ -90,7 +90,7 @@
window_handle = static_cast<uint32_t>(accelerated_widget);
#endif
aura::WindowTreeHost* const host =
-@@ -1497,7 +1497,7 @@ void NativeWindowViews::SetIcon(HICON window_icon, HIC
+@@ -1512,7 +1512,7 @@ void NativeWindowViews::SetIcon(HICON window_icon, HIC
SendMessage(hwnd, WM_SETICON, ICON_BIG,
reinterpret_cast<LPARAM>(app_icon_.get()));
}
@@ -99,7 +99,7 @@
void NativeWindowViews::SetIcon(const gfx::ImageSkia& icon) {
auto* tree_host = views::DesktopWindowTreeHostLinux::GetHostForWidget(
GetAcceleratedWidget());
-@@ -1567,7 +1567,7 @@ bool NativeWindowViews::CanMaximize() const {
+@@ -1582,7 +1582,7 @@ bool NativeWindowViews::CanMaximize() const {
bool NativeWindowViews::CanMinimize() const {
#if BUILDFLAG(IS_WIN)
return minimizable_;
@@ -108,7 +108,7 @@
return true;
#endif
}
-@@ -1641,7 +1641,7 @@ void NativeWindowViews::HandleKeyboardEvent(
+@@ -1656,7 +1656,7 @@ void NativeWindowViews::HandleKeyboardEvent(
if (widget_destroyed_)
return;
@@ -117,7 +117,7 @@
if (event.windows_key_code == ui::VKEY_BROWSER_BACK)
NotifyWindowExecuteAppCommand(kBrowserBackward);
else if (event.windows_key_code == ui::VKEY_BROWSER_FORWARD)
-@@ -1660,7 +1660,7 @@ void NativeWindowViews::OnMouseEvent(ui::MouseEvent* e
+@@ -1675,7 +1675,7 @@ void NativeWindowViews::OnMouseEvent(ui::MouseEvent* e
// Alt+Click should not toggle menu bar.
root_view_->ResetAltState();
diff --git a/devel/electron19/files/patch-electron_spec-main_chromium-spec.ts b/devel/electron19/files/patch-electron_spec-main_chromium-spec.ts
index 5e59c7d878f1..c26929b09feb 100644
--- a/devel/electron19/files/patch-electron_spec-main_chromium-spec.ts
+++ b/devel/electron19/files/patch-electron_spec-main_chromium-spec.ts
@@ -1,4 +1,4 @@
---- electron/spec-main/chromium-spec.ts.orig 2022-05-25 15:32:14 UTC
+--- electron/spec-main/chromium-spec.ts.orig 2022-06-30 15:53:29 UTC
+++ electron/spec-main/chromium-spec.ts
@@ -400,13 +400,13 @@ describe('command line switches', () => {
it('should not set an invalid locale', async () => testLocale('asdfkl', currentLocale));
@@ -18,7 +18,7 @@
});
describe('--remote-debugging-pipe switch', () => {
-@@ -1536,12 +1536,12 @@ describe('font fallback', () => {
+@@ -1598,12 +1598,12 @@ describe('font fallback', () => {
expect(fonts[0].familyName).to.equal('Arial');
} else if (process.platform === 'darwin') {
expect(fonts[0].familyName).to.equal('Helvetica');
@@ -33,7 +33,7 @@
const html = `
<html lang="ja-JP">
<head>
-@@ -1767,7 +1767,7 @@ describe('navigator.clipboard', () => {
+@@ -1829,7 +1829,7 @@ describe('navigator.clipboard', () => {
});
});